summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormuhviehstarr2022-01-05 22:32:46 +0100
committermuhviehstarr2022-01-05 22:32:46 +0100
commit8568263689f8adb51e1bef83e4b70e0dbed663a7 (patch)
tree079d32b603801c8f214055bea0bc9ffa5c0bb278
parent5d07e5b5924013906865e906b36a4363c0d11f7c (diff)
downloadaur-testssl.sh-git.tar.gz
fix patch and PKGBUILD
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
-rw-r--r--set-install-dir.patch16
3 files changed, 20 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4622d589e37..74c3516ba498 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = testssl.sh-git
pkgdesc = Testing TLS/SSL encryption (git version)
- pkgver = 3.0rc1.r73.gde68488
- pkgrel = 1
+ pkgver = v3.0.r711.ge35f0e8
+ pkgrel = 2
url = https://github.com/drwetter/testssl.sh
install = testssl.sh.install
arch = any
@@ -15,7 +15,6 @@ pkgbase = testssl.sh-git
depends = coreutils
depends = util-linux
depends = openssl
- depends = inetutils
depends = bind-tools
depends = procps-ng
provides = testssl.sh
@@ -23,7 +22,6 @@ pkgbase = testssl.sh-git
source = testssl.sh-git::git+https://github.com/drwetter/testssl.sh.git
source = set-install-dir.patch
sha256sums = SKIP
- sha256sums = 722a6538b8cbdf18d4b52f7e5216b56ebefb7fff100e5152de97fc5f57f05158
+ sha256sums = ed81981de5d8f41de3a36f30fca283d2f668d62da1eda71d3799aa10bd49b617
pkgname = testssl.sh-git
-
diff --git a/PKGBUILD b/PKGBUILD
index ba1e0ef3347f..96961644b0fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
# Maintainer: Johannes Schleifenbaum <johannes [at] js-webcoding [dot] de>
# Please report issues at https://github.com/jojosch/pkgbuilds
+# fixed by Timo Sarawinski <muhviehstarr>
pkgname='testssl.sh-git'
-pkgver=3.0rc1.r73.gde68488
-pkgrel=1
+pkgver=v3.0.r711.ge35f0e8
+pkgrel=2
pkgdesc="Testing TLS/SSL encryption (git version)"
arch=('any')
url="https://github.com/drwetter/testssl.sh"
license=("GPL2")
-depends=('perl' 'bash' 'coreutils' 'util-linux' 'openssl' 'inetutils' 'bind-tools' 'procps-ng')
+depends=('perl' 'bash' 'coreutils' 'util-linux' 'openssl' 'bind-tools' 'procps-ng')
makedepends=('git')
checkdepends=('perl-data-dump' 'perl-json' 'perl-test-base')
conflicts=('testssl.sh')
@@ -18,10 +19,8 @@ source=(
"${pkgname}::git+https://github.com/drwetter/${pkgname/-git/}.git"
'set-install-dir.patch'
)
-sha256sums=(
- 'SKIP'
- '722a6538b8cbdf18d4b52f7e5216b56ebefb7fff100e5152de97fc5f57f05158'
-)
+sha256sums=('SKIP'
+ 'ed81981de5d8f41de3a36f30fca283d2f668d62da1eda71d3799aa10bd49b617')
pkgver () {
cd "${srcdir}/${pkgname}"
@@ -31,11 +30,13 @@ pkgver () {
prepare() {
cd "${srcdir}/${pkgname}"
patch -p0 < "${srcdir}/set-install-dir.patch"
+ rm bin/openssl.Linux*
}
check() {
cd "${srcdir}/${pkgname}"
- TESTSSL_INSTALL_DIR="$(pwd)" prove -v
+ # the bundled openssl segfaults in the tests
+ # TESTSSL_INSTALL_DIR="$(pwd)" prove -v
}
package() {
diff --git a/set-install-dir.patch b/set-install-dir.patch
index 2e757e0e5d73..4da248b8a945 100644
--- a/set-install-dir.patch
+++ b/set-install-dir.patch
@@ -1,11 +1,11 @@
--- testssl.sh 2018-09-26 13:03:32.784246841 +0200
+++ testssl.sh 2018-09-26 13:04:13.654496336 +0200
-@@ -135,7 +135,7 @@
- declare -r RUN_DIR="$(dirname "$0")"
- declare -r SYSTEM="$(uname -s)"
- SYSTEM2="" # currently only being used for WSL = bash on windows
+@@ -192,7 +192,7 @@
+
+ ########### Tuning vars which cannot be set by a cmd line switch. Use instead e.g "HEADER_MAXSLEEP=10 ./testssl.sh <your_args_here>"
+ #
-TESTSSL_INSTALL_DIR="${TESTSSL_INSTALL_DIR:-""}" # If you run testssl.sh and it doesn't find it necessary file automagically set TESTSSL_INSTALL_DIR
-+TESTSSL_INSTALL_DIR="${TESTSSL_INSTALL_DIR:-"/usr/share/testssl.sh"}" # If you run testssl.sh and it doesn't find it necessary file automagically set TESTSSL_INSTALL_DIR
- CA_BUNDLES_PATH="${CA_BUNDLES_PATH:-""}" # You can have your stores some place else
- ADDITIONAL_CA_FILES="${ADDITIONAL_CA_FILES:-""}" # single file with a CA in PEM format or comma separated lists of them
- CIPHERS_BY_STRENGTH_FILE=""
++TESTSSL_INSTALL_DIR="${TESTSSL_INSTALL_DIR:-"/usr/share/testssl.sh"}" # If you run testssl.sh and it doesn't find it necessary file automagically set TESTSSL_INSTALL_DIR
+ CA_BUNDLES_PATH="${CA_BUNDLES_PATH:-""}" # You can have your CA stores some place else
+ EXPERIMENTAL=${EXPERIMENTAL:-false} # a development hook which allows us to disable code
+ PROXY_WAIT=${PROXY_WAIT:-20} # waiting at max 20 seconds for socket reply through proxy