diff options
author | Alex Hirzel | 2024-05-21 02:36:28 -0400 |
---|---|---|
committer | Alex Hirzel | 2024-05-21 02:36:28 -0400 |
commit | e8f0c1ca6a3b1ddd3402199e90a9185b316cba1f (patch) | |
tree | 51e395e849370780c6dc1240ab835bad64329a17 | |
parent | 4b416fd0ce1870f70ab3fb93cc3ee279be54e0eb (diff) | |
download | aur-e8f0c1ca6a3b1ddd3402199e90a9185b316cba1f.tar.gz |
fix build - thanks Chris Zhang!
-rw-r--r-- | .SRCINFO | 11 | ||||
-rw-r--r-- | PKGBUILD | 18 |
2 files changed, 19 insertions, 10 deletions
@@ -1,17 +1,20 @@ pkgbase = tev pkgdesc = High dynamic range (HDR) image comparison tool for graphics people. Supports primarily OpenEXR files. pkgver = 1.27 - pkgrel = 1 + pkgrel = 2 url = https://github.com/Tom94/tev arch = i686 arch = x86_64 - license = BSD + license = LicenseRef-BSD + makedepends = clang makedepends = cmake makedepends = git - makedepends = clang - depends = libpng depends = hicolor-icon-theme + depends = libc++ + depends = libc++abi + depends = libdeflate depends = libglvnd + depends = libpng provides = tev conflicts = tev source = tev::git+https://github.com/Tom94/tev.git#tag=v1.27 @@ -2,14 +2,14 @@ _pkgname=tev pkgname=${_pkgname} pkgver=1.27 -pkgrel=1 +pkgrel=2 epoch= pkgdesc="High dynamic range (HDR) image comparison tool for graphics people. Supports primarily OpenEXR files." arch=("i686" "x86_64") url="https://github.com/Tom94/tev" -license=('BSD') -depends=("libpng" "hicolor-icon-theme" "libglvnd") -makedepends=("cmake" "git" "clang") +license=('LicenseRef-BSD') +depends=("hicolor-icon-theme" "libc++" "libc++abi" "libdeflate" "libglvnd" "libpng") +makedepends=("clang" "cmake" "git") provides=("tev") conflicts=("tev") install= @@ -23,14 +23,20 @@ prepare() { build() { cd "${_pkgname}/build" || exit 1 - cmake -DCMAKE_INSTALL_PREFIX=/usr \ + cmake -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr" \ -DCMAKE_C_COMPILER=clang \ -DCMAKE_CXX_COMPILER=clang++ \ + -DOPENEXR_INSTALL=OFF\ + -DOPENEXR_INSTALL_TOOLS=OFF \ + -DOPENEXR_INSTALL_PKG_CONFIG=OFF \ + -DIMATH_INSTALL=OFF \ + -DIMATH_INSTALL_PKG_CONFIG=OFF \ + -GNinja \ .. cmake --build . } package() { - cmake --build "${_pkgname}/build" --target install -- DESTDIR="${pkgdir}" + cmake --build "${_pkgname}/build" --target install install -Dm644 "${_pkgname}/LICENSE.txt" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE" } |