summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbitwave2015-09-04 13:31:46 +0200
committerbitwave2015-09-04 13:31:46 +0200
commit735da4728ba778104036e0358f77ca72f07576d8 (patch)
treeea7c5bfce91ff30f62d5f46ff7b2a9592642e4d5
downloadaur-735da4728ba778104036e0358f77ca72f07576d8.tar.gz
added 8.2 textadept
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD68
-rw-r--r--textadept.install4
3 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a5a45ae28c40
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = textadept
+ pkgdesc = A fast, minimalist and remarkably extensible text editor
+ pkgver = 8.2
+ pkgrel = 1
+ url = http://foicica.com/textadept
+ install = textadept.install
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = lua
+ depends = desktop-file-utils
+ optdepends = gtk2: for GUI version
+ optdepends = python: for reStructuredText language module
+ conflicts = textadept-beta
+ conflicts = textadept-git
+ conflicts = textadept-latest-stable
+ conflicts = textadept-modules
+ conflicts = textadept-modules-beta
+ source = http://foicica.com/textadept/download/textadept_8.2.x86_64.tgz
+ source = http://foicica.com/textadept/download/textadept_8.2.modules.zip
+ source = textadept.install
+ sha256sums = 1845b63c1c75e6d21b8811493bad2bb9c7c0d2d675d1013608560dfa932d4b19
+ sha256sums = 02a60fba2889dd68d26258f4763fc68d23a30e504fd25d5f1c1992f3d9732a09
+ sha256sums = b2971d4c6743033b16b172c2b208942a4a6082c7bcfb593ae25bff3fbad45b4b
+
+pkgname = textadept
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2d25f6f80e05
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# Maintainer: bitwave
+
+pkgname=textadept
+pkgver=8.2
+pkgrel=1
+pkgdesc="A fast, minimalist and remarkably extensible text editor"
+url="http://foicica.com/textadept"
+arch=('i686' 'x86_64')
+license=('MIT')
+depends=('lua' 'desktop-file-utils')
+optdepends=('gtk2: for GUI version'
+ 'python: for reStructuredText language module')
+conflicts=('textadept-beta' 'textadept-git' 'textadept-latest-stable'
+ 'textadept-modules' 'textadept-modules-beta')
+_arch=x86_64
+[ "$CARCH" = "i686" ] && _arch=i386
+source=(http://foicica.com/textadept/download/${pkgname}_${pkgver}.${_arch}.tgz
+ http://foicica.com/textadept/download/${pkgname}_${pkgver}.modules.zip
+ textadept.install)
+sha256sums=('1845b63c1c75e6d21b8811493bad2bb9c7c0d2d675d1013608560dfa932d4b19'
+ '02a60fba2889dd68d26258f4763fc68d23a30e504fd25d5f1c1992f3d9732a09'
+ 'b2971d4c6743033b16b172c2b208942a4a6082c7bcfb593ae25bff3fbad45b4b')
+[ "$CARCH" = "i686" ] &&
+sha256sums[0]='ad0ebca39e6cf98cac16e93257572da31966c984ed42521abf09b536766b5210'
+package() {
+ cd textadept_${pkgver}.${_arch}
+
+ # Create directories
+ install -d $pkgdir/opt/textadept
+ install -d $pkgdir/usr/share/applications
+ install -d $pkgdir/usr/share/doc
+ install -d $pkgdir/usr/share/licenses/textadept
+ install -d $pkgdir/usr/bin
+
+ # Copy files and directories
+ cp -r core lexers modules scripts themes doc *.lua LICENSE \
+ $pkgdir/opt/textadept
+ install -m755 textadept textadept-curses textadeptjit textadeptjit-curses \
+ $pkgdir/opt/textadept
+ install -m644 src/*.desktop $pkgdir/usr/share/applications/
+
+ # Copy icons
+ rm $pkgdir/opt/textadept/core/images/*.{ico,icns}
+ for res in 16 32 48 64 128 256; do
+ install -d $pkgdir/usr/share/icons/hicolor/${res}x${res}/apps
+ ln -s /opt/textadept/core/images/ta_${res}x${res}.png \
+ $pkgdir/usr/share/icons/hicolor/${res}x${res}/apps/textadept.png
+ done
+ install -d $pkgdir/usr/share/icons/hicolor/scalable/apps
+ ln -s /opt/textadept/core/images/textadept.svg \
+ $pkgdir/usr/share/icons/hicolor/scalable/apps/textadept.svg
+
+ # Link binaries, license and documentation
+ ln -s /opt/textadept/textadept{,jit}{,-curses} $pkgdir/usr/bin/
+ ln -s /opt/textadept/LICENSE $pkgdir/usr/share/licenses/$pkgname/
+ ln -s /opt/textadept/doc $pkgdir/usr/share/doc/textadept
+
+ # Copy modules
+ cd $srcdir/textadept_${pkgver}.modules
+ cp -r modules $pkgdir/opt/textadept
+
+ # Clean up
+ rm $pkgdir/opt/textadept/doc/bombay
+ rm $pkgdir/opt/textadept/modules/yaml/libyaml{.dll,jit.dll,osx.so}
+ rm -rf `find $pkgdir -type d -name .hg`
+}
+
+install=textadept.install \ No newline at end of file
diff --git a/textadept.install b/textadept.install
new file mode 100644
index 000000000000..860ae7f14d02
--- /dev/null
+++ b/textadept.install
@@ -0,0 +1,4 @@
+post_install() {
+ update-desktop-database -q
+ xdg-icon-resource forceupdate
+} \ No newline at end of file