summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArjun Nemani2018-07-09 10:20:27 +0530
committerArjun Nemani2018-07-09 10:20:27 +0530
commitdf9640c7b66ac326324262c846b07913822b4bfa (patch)
tree21dc9bd5bb0c8daed11b61115ce17f5341190fb0
downloadaur-textlint-plugin-html.tar.gz
Add npm textlint-plugin-html to AUR
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba6974d86111
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = textlint-plugin-html
+ pkgdesc = textlint HTML processsor plugin.
+ pkgver = 0.1.7
+ pkgrel = 1
+ url = https://github.com/textlint/textlint-plugin-html
+ arch = any
+ depends = nodejs
+ depends = npm
+ noextract = textlint-plugin-html-0.1.7.tgz
+ source = http://registry.npmjs.org/textlint-plugin-html/-/textlint-plugin-html-0.1.7.tgz
+ sha1sums = acb90a9b8edcc013cf48b491b2a90d60321a23cf
+
+pkgname = textlint-plugin-html
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8729a72dd10a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+_npmname=textlint-plugin-html
+_npmver=0.1.7
+pkgname=textlint-plugin-html # All lowercase
+pkgver=0.1.7
+pkgrel=1
+pkgdesc="textlint HTML processsor plugin."
+arch=(any)
+url="https://github.com/textlint/textlint-plugin-html"
+license=()
+depends=('nodejs' 'npm' )
+optdepends=()
+source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$_npmver.tgz)
+noextract=($_npmname-$_npmver.tgz)
+sha1sums=(acb90a9b8edcc013cf48b491b2a90d60321a23cf)
+
+package() {
+ cd $srcdir
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p $_npmdir
+ cd $_npmdir
+ npm install -g --prefix "$pkgdir/usr" $_npmname@$_npmver
+}
+
+# vim:set ts=2 sw=2 et: