summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorshellkr2016-06-26 05:24:32 +0200
committershellkr2016-06-26 05:24:32 +0200
commitbe0cba9f08d0058c3779cfd219282f5e275c0c46 (patch)
treef94b5c44a95e8a24259c451ddbd80219fc2f5cff
parent9b0648c700f32b0fb10a95623467360a3267712b (diff)
downloadaur-be0cba9f08d0058c3779cfd219282f5e275c0c46.tar.gz
Upstream restructured file layout and also added a man page
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD22
-rw-r--r--textsuggest.patch21
3 files changed, 20 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29564f8f90d1..d95163817030 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
# Generated by mksrcinfo v8
-# Sat Jun 25 01:08:08 UTC 2016
+# Sun Jun 26 03:23:25 UTC 2016
pkgbase = textsuggest-git
pkgdesc = Simple Linux utility to autocomplete words using rofi
- pkgver = r23.1519640
- pkgrel = 2
+ pkgver = r35.ccbcbc9
+ pkgrel = 1
url = https://github.com/bharadwaj-raju/TextSuggest
arch = any
license = GPL3
makedepends = git
depends = python
depends = rofi
- depends = xorg-setxkbmap
depends = xdotool
depends = xclip
provides = textsuggest
diff --git a/PKGBUILD b/PKGBUILD
index af6e5f3ed25c..df025fec6288 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=textsuggest-git
_gitname=${pkgname%-git*}
-pkgver=r23.1519640
-pkgrel=2
+pkgver=r35.ccbcbc9
+pkgrel=1
pkgdesc='Simple Linux utility to autocomplete words using rofi'
arch=('any')
url="https://github.com/bharadwaj-raju/TextSuggest"
license=('GPL3')
-depends=('python' 'rofi' 'xorg-setxkbmap' 'xdotool' 'xclip')
+depends=('python' 'rofi' 'xdotool' 'xclip')
makedepends=('git')
provides=("$_gitname")
source=("$_gitname::git+https://github.com/bharadwaj-raju/TextSuggest.git")
@@ -21,20 +21,18 @@ pkgver() {
prepare() {
cd "$srcdir/$_gitname"
- patch -uN "TextSuggest.py" "$startdir/textsuggest.patch"
+ patch -uN "TextSuggest.py" "$startdir/textsuggest.patch"
}
package() {
cd "$srcdir/$_gitname"
- install -d "$pkgdir/usr/lib/python3.5/site-packages/textsuggest/EnglishOpenWordList/"
- install -d "$pkgdir/usr/bin/"
- install -D -m755 TextSuggest.py "$pkgdir/usr/lib/python3.5/site-packages/textsuggest/"
- install -D -m644 EnglishOpenWordList/* "$pkgdir/usr/lib/python3.5/site-packages/textsuggest/EnglishOpenWordList/"
- install -D -m644 Extra_Words.txt "$pkgdir/usr/lib/python3.5/site-packages/textsuggest/"
- install -D -m644 languages.py "$pkgdir/usr/lib/python3.5/site-packages/textsuggest/"
- install -D -m644 fonts.py "$pkgdir/usr/lib/python3.5/site-packages/textsuggest/"
+ install -d "$pkgdir/usr/share/"
+ cp -rf textsuggest "$pkgdir/usr/share/"
+ install -D -m755 TextSuggest.py "$pkgdir/usr/bin/textsuggest"
+ install -D -m644 languages.py -t "$pkgdir/usr/lib/python3.5/site-packages/"
+ install -D -m644 fonts.py -t "$pkgdir/usr/lib/python3.5/site-packages/"
+ install -D -m644 textsuggest.1 -t "$pkgdir/usr/share/man/man1/"
install -D -m644 README.md "$pkgdir/usr/share/doc/$pkgname/README"
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/COPYING"
- ln -fs "/usr/lib/python3.5/site-packages/textsuggest/TextSuggest.py" "$pkgdir/usr/bin/textsuggest"
}
diff --git a/textsuggest.patch b/textsuggest.patch
index 00fe948fd372..b4a7702c712a 100644
--- a/textsuggest.patch
+++ b/textsuggest.patch
@@ -1,18 +1,11 @@
---- TextSuggest-orig.py 2016-06-24 23:47:38.626860367 +0200
-+++ TextSuggest.py 2016-06-24 23:58:54.896907919 +0200
-@@ -44,7 +44,7 @@
+--- TextSuggest.py 2016-06-26 03:58:15.207902622 +0200
++++ textsuggest.new 2016-06-26 05:19:07.357888524 +0200
+@@ -89,7 +89,7 @@
- suggest_method = 'replace'
+ hist_file = os.path.expanduser('~/.config/textsuggest/history.txt')
--script_cwd = os.path.abspath(os.path.join(__file__, os.pardir))
-+script_cwd = os.path.abspath(os.path.join(__file__, '/usr/lib/python3.5/site-packages/textsuggest/'))
+-extra_words_file = os.path.expanduser('~/.config/textsuggest/Extra_Words.txt')
++extra_words_file = os.path.expanduser('/usr/share/textsuggest/Extra_Words.txt')
- custom_words_file = os.path.expanduser('~/.Custom_Words.txt')
+ custom_words_file = os.path.expanduser('~/.config/textsuggest/Custom_Words.txt')
-@@ -348,4 +348,4 @@
-
- if __name__ == '__main__':
-
-- main(current_word)
-\ No newline at end of file
-+ main(current_word)