summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBertrand "Kamek" Bousquet2020-04-16 21:55:26 -0400
committerBertrand "Kamek" Bousquet2020-04-16 21:55:26 -0400
commit238f8d26071b2d1da73f8135104383a2ef7f4e22 (patch)
tree92c2bfe4f70a8e590f43ebf2cfe7afaaa53bd1e3
downloadaur-tftools-bin.tar.gz
initial config
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..63f2882b98df
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = tftools-bin
+ pkgdesc = A CLI helper for working with TensorFlow
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/kamek-pf/tftools
+ arch = x86_64
+ license = MIT
+ depends = tensorflow
+ provides = tftools
+ conflicts = tftools
+ source = tftools::https://github.com/kamek-pf/tftools/releases/download/0.1.0/tftools-x86_64-unknown-linux-gnu
+ sha256sums = 08b146fc02e39de896ddbc92a97bb491977e87276802b3756dc88cc3830c4cf8
+
+pkgname = tftools-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..372b74084478
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Bertrand "Kamek" Bousquet <b.kamek@gmail.com>
+
+pkgname=tftools-bin
+_pkgname=${pkgname%-bin}
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="A CLI helper for working with TensorFlow"
+depends=('tensorflow')
+arch=('x86_64')
+url="https://github.com/kamek-pf/tftools"
+license=("MIT")
+provides=(${_pkgname})
+conflicts=(${_pkgname})
+source=("${_pkgname}::${url}/releases/download/${pkgver}/${_pkgname}-${arch}-unknown-linux-gnu")
+sha256sums=("08b146fc02e39de896ddbc92a97bb491977e87276802b3756dc88cc3830c4cf8")
+
+package() {
+ install -Dm755 "${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+}