summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Tran2021-06-22 20:20:48 +1000
committerVictor Tran2021-06-22 20:20:48 +1000
commitb87594abb6f8a5739321a761f6e98d6b342b6a10 (patch)
treed4a703960bfccb386e47d318a7b777035e56e5a1
parentf362671ea1044414df880bf087569d9dc74a0d19 (diff)
downloadaur-b87594abb6f8a5739321a761f6e98d6b342b6a10.tar.gz
Bump version because of soname bump for pulseaudio-qt5
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD12
2 files changed, 15 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d389258a6dd..a03e0a35463b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = thedesk
pkgdesc = Desktop Environment built on Qt
- pkgver = beta3
- pkgrel = 1
+ pkgver = beta4
+ pkgrel = 3
url = https://github.com/vicr123/thedesk
arch = x86_64
license = GPL3
@@ -17,8 +17,10 @@ pkgbase = thedesk
makedepends = modemmanager-qt
makedepends = qt5-location
makedepends = libtwebservices
- source = thedesk-beta3::https://github.com/vicr123/thedesk/archive/beta3.tar.gz
- sha256sums = cb38e02e6183bb8de13c6ac606723622b6d495c7a484f0451a8d353932955d8e
+ makedepends = bluez-qt
+ makedepends = qrencode
+ source = thedesk-beta4::https://github.com/vicr123/thedesk/archive/beta4.tar.gz
+ sha256sums = fba59e6a6aa9940728f6e6e5db61445f44fbcc0adfa8b2f30f3e4c7649f4ac29
pkgname = thedesk
depends = the-libs
@@ -36,6 +38,9 @@ pkgname = thedesk
depends = accountsservice
depends = qt5-location
depends = libtwebservices
+ depends = bluez-qt
+ depends = qrencode
+ depends = thedesk-xdg-utils
pkgname = td-polkitagent
depends = the-libs
@@ -52,4 +57,3 @@ pkgname = thedesk-platform
pkgname = libthedesk
depends = the-libs
depends = libtdesktopenvironment
-
diff --git a/PKGBUILD b/PKGBUILD
index 3f7527607a6b..94cffae59fcb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Victor Tran <vicr12345 at gmail dot com>
pkgname=('thedesk' 'td-polkitagent' 'thedesk-platform' 'libthedesk')
-pkgver=beta3
-pkgrel=1
+pkgver=beta4
+pkgrel=3
pkgdesc="Desktop Environment built on Qt"
arch=("x86_64")
url="https://github.com/vicr123/thedesk"
license=('GPL3')
-makedepends=('polkit-qt5' 'qt5-tools' 'the-libs' 'libtdesktopenvironment' 'pulseaudio-qt' 'libx11' 'libxi' 'xf86-input-libinput' 'networkmanager-qt' 'modemmanager-qt' 'qt5-location' 'libtwebservices')
-source=("thedesk-$pkgver"::'https://github.com/vicr123/thedesk/archive/beta3.tar.gz')
-sha256sums=('cb38e02e6183bb8de13c6ac606723622b6d495c7a484f0451a8d353932955d8e')
+makedepends=('polkit-qt5' 'qt5-tools' 'the-libs' 'libtdesktopenvironment' 'pulseaudio-qt' 'libx11' 'libxi' 'xf86-input-libinput' 'networkmanager-qt' 'modemmanager-qt' 'qt5-location' 'libtwebservices' 'bluez-qt' 'qrencode')
+source=("thedesk-$pkgver"::'https://github.com/vicr123/thedesk/archive/beta4.tar.gz')
+sha256sums=('fba59e6a6aa9940728f6e6e5db61445f44fbcc0adfa8b2f30f3e4c7649f4ac29')
doInstallModule() {
pushd "$pkgbase-$pkgver/build/$1"
@@ -46,7 +46,7 @@ package_td-polkitagent() {
}
package_thedesk() {
- depends=('the-libs' 'kwin' 'libtdesktopenvironment' 'td-polkitagent' 'libthedesk' 'thedesk-platform' 'pulseaudio-qt' 'libx11' 'libxi' 'xf86-input-libinput' 'networkmanager-qt' 'modemmanager-qt' 'accountsservice' 'qt5-location' 'libtwebservices')
+ depends=('the-libs' 'kwin' 'libtdesktopenvironment' 'td-polkitagent' 'libthedesk' 'thedesk-platform' 'pulseaudio-qt' 'libx11' 'libxi' 'xf86-input-libinput' 'networkmanager-qt' 'modemmanager-qt' 'accountsservice' 'qt5-location' 'libtwebservices' 'bluez-qt' 'qrencode' 'thedesk-xdg-utils')
doInstallModule 'desktop';
doInstallModule 'plugins';