summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Tran2020-06-29 23:22:41 +1000
committerVictor Tran2020-06-29 23:22:41 +1000
commit1b21439db7c622d784916f4b7e709fdd9c8cbd8d (patch)
tree7dfab579b913638be382f753620b567565a6e2ce
downloadaur-theframe.tar.gz
Initial Commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d707f9059464
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = theframe
+ pkgdesc = Animation Tool
+ pkgver = 1.0
+ pkgrel = 0
+ url = https://github.com/vicr123/theframe
+ arch = x86_64
+ license = GPL3
+ makedepends = qt5-tools
+ depends = qt5-base
+ depends = the-libs
+ depends = qt5-svg
+ depends = ffmpeg
+ source = theframe-1.0::https://github.com/vicr123/theFrame/archive/v1.0.tar.gz
+ sha256sums = 4c27200f3736dacee9cfe27b6cfabfbaddc27a2b696954d596b9b48cd33bbfdd
+
+pkgname = theframe
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a5ba36512416
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Victor Tran <vicr12345 at gmail dot com>
+pkgname=theframe
+pkgver=1.0
+pkgrel=0
+pkgdesc="Animation Tool"
+arch=("x86_64")
+url="https://github.com/vicr123/theframe"
+license=('GPL3')
+depends=('qt5-base' 'the-libs' 'qt5-svg' 'ffmpeg')
+makedepends=('qt5-tools')
+source=("$pkgname-$pkgver"::"https://github.com/vicr123/theFrame/archive/v1.0.tar.gz")
+sha256sums=('4c27200f3736dacee9cfe27b6cfabfbaddc27a2b696954d596b9b48cd33bbfdd')
+
+build() {
+ cd "theFrame-$pkgver"
+ qmake
+ make
+}
+
+package() {
+ cd "theFrame-$pkgver"
+ make install INSTALL_ROOT=$pkgdir
+}