summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoractionless2020-03-16 03:53:05 +0100
committeractionless2020-03-16 03:53:05 +0100
commitaef36b5db01b6baff55ccc88f7c9d4b44dae8288 (patch)
tree1d89aa66a1d47b24a6b77d9d2f6b6679d956fa30
parent06c420c86f9ed3735f4a6383a42bcc9528250cd0 (diff)
downloadaur-aef36b5db01b6baff55ccc88f7c9d4b44dae8288.tar.gz
use more variables
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6103657eeccd..f2e592fd29c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -23,7 +23,7 @@ pkgbase = themix-theme-oomox-git
conflicts = themix-theme-oomox
options = !strip
source = git+https://github.com/themix-project/oomox.git#branch=master
- source = git+https://github.com/themix-project/oomox-gtk-theme.git#branch=master
+ source = oomox-gtk-theme::git+https://github.com/themix-project/oomox-gtk-theme.git#branch=master
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index b699cb31f061..b1c3603e5acf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,6 +2,7 @@
# Upstream URL: https://github.com/themix-project/oomox-gtk-theme
_pkgname=themix-theme-oomox
+_reponame=oomox-gtk-theme
pkgname="${_pkgname}-git"
pkgver=1.11.1.r21.g0143d5a1
pkgrel=2
@@ -13,7 +14,7 @@ url="https://github.com/themix-project/oomox-gtk-theme"
license=('GPL3')
source=(
"git+https://github.com/themix-project/oomox.git#branch=master"
- "git+https://github.com/themix-project/oomox-gtk-theme.git#branch=master"
+ "${_reponame}::git+https://github.com/themix-project/oomox-gtk-theme.git#branch=master"
)
md5sums=('SKIP'
'SKIP')
@@ -43,18 +44,20 @@ provides=($_pkgname)
conflicts=($_pkgname)
pkgver() {
- cd "${srcdir}/oomox-gtk-theme"
+ cd "${srcdir}/${_reponame}"
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
_oomox_dir=/opt/oomox
+ _plugin_name=theme_oomox
+ _plugin_subpath="/gtk-theme"
pkg_tmp_dir="${pkgdir}/_tmp"
rm -fr "$pkg_tmp_dir"
cp -r "${srcdir}/oomox" "$pkg_tmp_dir"
- rm -rf "${pkg_tmp_dir}/plugins/theme_oomox/gtk-theme"
- cp -r "${srcdir}/oomox-gtk-theme" "${pkg_tmp_dir}/plugins/theme_oomox/gtk-theme"
+ rm -rf "${pkg_tmp_dir}/plugins/${_plugin_name}${_plugin_subpath}"
+ cp -r "${srcdir}/${_reponame}" "${pkg_tmp_dir}/plugins/${_plugin_name}${_plugin_subpath}"
cd "$pkg_tmp_dir"
make DESTDIR="${pkgdir}" APPDIR="${_oomox_dir}" PREFIX="/usr" install_theme_oomox