summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoractionless2020-03-16 03:23:33 +0100
committeractionless2020-03-16 03:23:33 +0100
commitd903ada8596ccbf721e2e8663586b37068f3ac5a (patch)
tree75b9a094e6a7b117ac54365dc93d54052c236103
downloadaur-d903ada8596ccbf721e2e8663586b37068f3ac5a.tar.gz
initial commit
-rw-r--r--.SRCINFO31
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD60
3 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cb6c13cc08a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = themix-theme-oomox-git
+ pkgdesc = Oomox theme plugin (GTK2, GTK3, Cinnamon, Metacity, Openbox, Qt5ct, Unity, Xfwm) for Themix GUI designer. Have a hack for HiDPI in GTK2.
+ pkgver = 1.11.1.r21.g0143d5a1
+ pkgrel = 1
+ url = https://github.com/themix-project/oomox-gtk-theme
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ makedepends = git
+ depends = gtk3
+ depends = glib2
+ depends = gdk-pixbuf2
+ depends = gtk-engine-murrine
+ depends = gtk-engines
+ depends = sassc
+ depends = librsvg
+ depends = sed
+ depends = findutils
+ depends = grep
+ depends = bc
+ optdepends = themix-gui: GUI
+ provides = themix-theme-oomox
+ conflicts = themix-theme-oomox
+ options = !strip
+ source = git+https://github.com/themix-project/oomox.git#branch=master
+ source = git+https://github.com/themix-project/oomox-gtk-theme.git#branch=master
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = themix-theme-oomox-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..adc0c6a922f9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/
+src/
+
+oomox/
+oomox-gtk-theme/
+themix-theme-oomox-git-*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7fa5e540c177
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Yauhen Kirylau <actionless DOT loveless PLUS aur AT gmail MF com>
+# Upstream URL: https://github.com/themix-project/oomox-gtk-theme
+
+pkgname=themix-theme-oomox-git
+pkgver=1.11.1.r21.g0143d5a1
+pkgrel=1
+pkgdesc="Oomox theme plugin
+ (GTK2, GTK3, Cinnamon, Metacity, Openbox, Qt5ct, Unity, Xfwm) for Themix GUI designer.
+ Have a hack for HiDPI in GTK2."
+arch=('x86_64' 'i686')
+url="https://github.com/themix-project/oomox-gtk-theme"
+license=('GPL3')
+source=(
+ "git+https://github.com/themix-project/oomox.git#branch=master"
+ "git+https://github.com/themix-project/oomox-gtk-theme.git#branch=master"
+)
+md5sums=('SKIP'
+ 'SKIP')
+depends=(
+ 'gtk3'
+ 'glib2' # oomox, materia, arc
+ 'gdk-pixbuf2' # oomox, materia, arc
+ 'gtk-engine-murrine' # oomox, materia, arc
+ 'gtk-engines' # oomox, materia, arc
+ 'sassc' # oomox, materia, arc
+ 'librsvg' # oomox, gnome-colors
+ 'sed' # oomox, materia, arc, gnome-colors, archdroid
+ 'findutils' # oomox, materia, arc, gnome-colors, arch-droid
+ 'grep' # oomoxify, oomox, materia, arc, gnome-colors
+ 'bc' # oomoxify, oomox, materia, arc, gnome-colors
+)
+makedepends=(
+ 'git'
+)
+optdepends=(
+ 'themix-gui: GUI'
+)
+options=(
+ '!strip'
+)
+provides=('themix-theme-oomox')
+conflicts=('themix-theme-oomox')
+
+pkgver() {
+ cd "${srcdir}/oomox-gtk-theme"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ _oomox_dir=/opt/oomox
+ _oomox_gui_dir=${_oomox_dir}/oomox_gui
+ cd "${srcdir}/oomox"
+
+ rm -fr plugins/theme_oomox/gtk-theme
+ mv "${srcdir}/oomox-gtk-theme" plugins/theme_oomox/gtk-theme
+ make DESTDIR="${pkgdir}" APPDIR="${_oomox_dir}" PREFIX="/usr" install_theme_oomox
+ python -O -m compileall ${pkgdir}${_oomox_gui_dir} -d ${_oomox_gui_dir}
+}
+
+# vim: ft=PKGBUILD