summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoractionless2020-03-16 04:06:30 +0100
committeractionless2020-03-16 04:06:30 +0100
commitd985f1b1c613f9f96a7180ec386d86820ac2c607 (patch)
treebf0bea60c6d1c1e267ab3eb2d6b051096c428acd
parentaef36b5db01b6baff55ccc88f7c9d4b44dae8288 (diff)
downloadaur-d985f1b1c613f9f96a7180ec386d86820ac2c607.tar.gz
compile python files
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f2e592fd29c0..250c294dced6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = themix-theme-oomox-git
pkgdesc = Oomox theme plugin (GTK2, GTK3, Cinnamon, Metacity, Openbox, Qt5ct, Unity, Xfwm) for Themix GUI designer. Have a hack for HiDPI in GTK2.
pkgver = 1.11.1.r21.g0143d5a1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/themix-project/oomox-gtk-theme
arch = x86_64
arch = i686
license = GPL3
makedepends = git
+ makedepends = python
depends = gtk3
depends = glib2
depends = gdk-pixbuf2
diff --git a/PKGBUILD b/PKGBUILD
index b1c3603e5acf..71bb13f00f7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _pkgname=themix-theme-oomox
_reponame=oomox-gtk-theme
pkgname="${_pkgname}-git"
pkgver=1.11.1.r21.g0143d5a1
-pkgrel=2
+pkgrel=3
pkgdesc="Oomox theme plugin
(GTK2, GTK3, Cinnamon, Metacity, Openbox, Qt5ct, Unity, Xfwm) for Themix GUI designer.
Have a hack for HiDPI in GTK2."
@@ -33,6 +33,7 @@ depends=(
)
makedepends=(
'git'
+ 'python'
)
optdepends=(
'themix-gui: GUI'
@@ -62,6 +63,8 @@ package() {
cd "$pkg_tmp_dir"
make DESTDIR="${pkgdir}" APPDIR="${_oomox_dir}" PREFIX="/usr" install_theme_oomox
rm -fr "$pkg_tmp_dir"
+
+ python -O -m compileall "${pkgdir}${_oomox_dir}/plugins/${_plugin_name}" -d "${_oomox_dir}/plugins/${_plugin_name}"
}
# vim: ft=PKGBUILD