summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Tran2017-01-25 12:03:32 +1100
committerVictor Tran2017-01-25 12:03:32 +1100
commitd2a20676ebe9354c4717e480a3bb5859d2f20695 (patch)
treeef8f64fa5b7e6de842dd7e84d2db8c0b89f3dbfe
parentab988445c74fbdb4a75237e69bf2d13e63e6cc50 (diff)
downloadaur-d2a20676ebe9354c4717e480a3bb5859d2f20695.tar.gz
Update to 6.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89d9005c7189..c09aecb7eecc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = theshell
pkgdesc = Desktop Shell that gets out of your way
- pkgver = 5.2
+ pkgver = 6.0
pkgrel = 0
url = https://github.com/vicr123/theshell
arch = x86_64
@@ -17,6 +17,8 @@ pkgbase = theshell
depends = libcups
depends = qt5-base
depends = ts-qtplatform
+ depends = the-libs
+ depends = qt5-charts
depends = qt5-location
depends = kscreen
depends = kdepimlibs4
@@ -26,7 +28,7 @@ pkgbase = theshell
optdepends = alsa-utils: for volume controls
optdepends = pocketsphinx: for theWave
optdepends = festival: for theWave
- source = theshell-5.2::git+https://github.com/vicr123/theshell#branch=master
+ source = theshell-6.0::git+https://github.com/vicr123/theshell#branch=master
md5sums = SKIP
pkgname = theshell
diff --git a/PKGBUILD b/PKGBUILD
index 5799e75c79d7..cf33c3f0b1dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Victor Tran <vicr12345 at gmail dot com>
pkgname=theshell
-pkgver=5.2
+pkgver=6.0
pkgrel=0
pkgdesc="Desktop Shell that gets out of your way"
arch=("x86_64")
@@ -9,7 +9,7 @@ url="https://github.com/vicr123/theshell"
license=('GPL3')
depends=('kwidgetsaddons' 'xdg-utils' 'wmctrl' 'kwin'
'networkmanager' 'xorg-xbacklight' 'redshift' 'tsscreenlock'
-'libcups' 'qt5-base' 'ts-qtplatform'
+'libcups' 'qt5-base' 'ts-qtplatform' 'the-libs' 'qt5-charts'
'qt5-location' 'kscreen' 'kdepimlibs4' 'akonadi' 'ts-polkitagent' 'ts-bt')
optdepends=('alsa-utils: for volume controls'
'pocketsphinx: for theWave'
@@ -21,6 +21,7 @@ md5sums=('SKIP')
build() {
cd "$pkgname-$pkgver"
qdbuscpp2xml -M -s notificationdbus.h -o org.freedesktop.Notifications.xml
+ qdbuscpp2xml -a -o org.thesuite.power.xml upowerdbus.h
qmake theShell.pro
make
}
@@ -32,4 +33,6 @@ package() {
cp "$pkgname-$pkgver/init_theshell" "$pkgdir/usr/bin"
mkdir -p "$pkgdir/usr/share/xsessions"
cp "$pkgname-$pkgver/theshell.desktop" "$pkgdir/usr/share/xsessions"
+ mkdir -p "$pkgdir/usr/share/theshell/translations"
+ cp "$pkgname-$pkgver/translations/"* "$pkgdir/usr/share/theshell/translations"
}