summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Tran2016-05-29 17:18:21 +1000
committerVictor Tran2016-05-29 17:18:21 +1000
commit09242f0ac331fcbb27d461f6b6f96be780388984 (patch)
treebc55059260310f6695b7d73b9582d3d26ea22577
downloadaur-09242f0ac331fcbb27d461f6b6f96be780388984.tar.gz
Initial Commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD32
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e6b434821436
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = theshell-blueprint
+ pkgdesc = Desktop Shell that gets out of your way (blueprint version)
+ pkgver = 2.0b
+ pkgrel = 0
+ url = https://github.com/vicr123/theshell
+ arch = x86_64
+ license = GPL3
+ makedepends = qtchooser
+ makedepends = git
+ depends = kwidgetsaddons
+ depends = xdg-utils
+ depends = wmctrl
+ depends = kwin
+ depends = networkmanager
+ depends = xorg-xbacklight
+ depends = redshift
+ optdepends = alsa-utils: for volume controls
+ optdepends = pocketsphinx: for theWave
+ optdepends = festival: for theWave
+ source = theshell-blueprint-2.0b::git+https://github.com/vicr123/theshell#branch=blueprint
+ md5sums = SKIP
+
+pkgname = theshell-blueprint
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1086c6b50522
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+
+# Maintainer: Victor Tran <vicr12345 at gmail dot com>
+pkgname=theshell-blueprint
+pkgver=2.0b
+pkgrel=0
+pkgdesc="Desktop Shell that gets out of your way (blueprint version)"
+arch=("x86_64")
+url="https://github.com/vicr123/theshell"
+license=('GPL3')
+depends=('kwidgetsaddons' 'xdg-utils' 'wmctrl' 'kwin' 'networkmanager' 'xorg-xbacklight' 'redshift')
+optdepends=('alsa-utils: for volume controls'
+ 'pocketsphinx: for theWave'
+ 'festival: for theWave')
+makedepends=('qtchooser' 'git')
+source=("$pkgname-$pkgver"::'git+https://github.com/vicr123/theshell#branch=blueprint')
+md5sums=('SKIP')
+
+build() {
+ cd "$pkgname-$pkgver"
+ qdbuscpp2xml -M -s notificationdbus.h -o org.freedesktop.Notifications.xml
+ qmake theShell.pro
+ make
+}
+
+package() {
+ chmod +x "$pkgname-$pkgver/init_theshell"
+ mkdir -p "$pkgdir/usr/bin"
+ cp "$pkgname-$pkgver/theshell" "$pkgdir/usr/bin"
+ cp "$pkgname-$pkgver/init_theshell" "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/share/xsessions"
+ cp "$pkgname-$pkgver/theshell.desktop" "$pkgdir/usr/share/xsessions"
+}