summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Tran2017-01-22 00:19:40 +1100
committerVictor Tran2017-01-22 00:19:40 +1100
commit687573bd4ca52a5d08d3efae79a659c83dede3a2 (patch)
treea5d47f17873e8f6735e9a61b615dcbf6a8049c06
parent64f07b435ffc16f7a344381d568b25c0b8c0e478 (diff)
downloadaur-687573bd4ca52a5d08d3efae79a659c83dede3a2.tar.gz
Update to 6.0b
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3b65f97a5b0..fe7426a911d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = theshell-blueprint
pkgdesc = Desktop Shell that gets out of your way
- pkgver = 5.3b
+ pkgver = 6.0b
pkgrel = 0
url = https://github.com/vicr123/theshell
arch = x86_64
@@ -26,7 +26,7 @@ pkgbase = theshell-blueprint
optdepends = alsa-utils: for volume controls
optdepends = pocketsphinx: for theWave
optdepends = festival: for theWave
- source = theshell-blueprint-5.3b::git+https://github.com/vicr123/theshell#branch=blueprint
+ source = theshell-blueprint-6.0b::git+https://github.com/vicr123/theshell#branch=blueprint
md5sums = SKIP
pkgname = theshell-blueprint
diff --git a/PKGBUILD b/PKGBUILD
index 9c6837c844ef..7c1df18db3d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Victor Tran <vicr12345 at gmail dot com>
pkgname=theshell-blueprint
-pkgver=5.3b
+pkgver=6.0b
pkgrel=0
pkgdesc="Desktop Shell that gets out of your way"
arch=("x86_64")
@@ -21,6 +21,7 @@ md5sums=('SKIP')
build() {
cd "$pkgname-$pkgver"
qdbuscpp2xml -M -s notificationdbus.h -o org.freedesktop.Notifications.xml
+ qdbuscpp2xml -a -o org.thesuite.power.xml upowerdbus.h
qmake theShell.pro
make
}
@@ -32,4 +33,6 @@ package() {
cp "$pkgname-$pkgver/init_theshell" "$pkgdir/usr/bin"
mkdir -p "$pkgdir/usr/share/xsessions"
cp "$pkgname-$pkgver/theshell.desktop" "$pkgdir/usr/share/xsessions"
+ mkdir -p "$pkgdir/usr/share/theshell/translations"
+ cp "$pkgname-$pkgver/translations/"* "$pkgdir/usr/share/theshell/translations"
}