summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Tran2017-08-22 17:57:28 +1000
committerVictor Tran2017-08-22 17:57:28 +1000
commita09f7c63cce90c27836e5b613a2d96e160785e0f (patch)
tree13fa53bac97363e66c678c3248add7552ee79a9b
parenta0974d480d2016dec8a5f3a6b9663510edbc1b6f (diff)
downloadaur-a09f7c63cce90c27836e5b613a2d96e160785e0f.tar.gz
Start using ts-startsession
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
-rwxr-xr-xinitscript.sh5
-rw-r--r--theshellb.desktop4
4 files changed, 6 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a9ac312aeaf7..3a6b09f9c6bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -17,6 +17,7 @@ pkgbase = theshell-blueprint
depends = libcups
depends = qt5-base
depends = ts-qtplatform
+ depends = ts-startsession
depends = qt5-location
depends = kscreen
depends = kdepimlibs4
@@ -29,8 +30,6 @@ pkgbase = theshell-blueprint
optdepends = festival: for theWave
source = theshell-blueprint-6.2b::git+https://github.com/vicr123/theshell#branch=blueprint
source = theshellb.desktop
- source = initscript.sh
- md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index eca5b32cf9dd..189819ab8e86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,16 +9,15 @@ url="https://github.com/vicr123/theshell"
license=('GPL3')
depends=('kwidgetsaddons' 'xdg-utils' 'wmctrl' 'kwin'
'networkmanager' 'xorg-xbacklight' 'redshift' 'tsscreenlock'
-'libcups' 'qt5-base' 'ts-qtplatform'
+'libcups' 'qt5-base' 'ts-qtplatform' 'ts-startsession'
'qt5-location' 'kscreen' 'kdepimlibs4' 'akonadi' 'ts-polkitagent' 'ts-bt' 'ts-bugreport')
optdepends=('alsa-utils: for volume controls'
'pocketsphinx: for theWave'
'festival: for theWave')
makedepends=('git')
source=("$pkgname-$pkgver"::'git+https://github.com/vicr123/theshell#branch=blueprint'
- "theshellb.desktop"
- "initscript.sh")
-md5sums=('SKIP' 'SKIP' 'SKIP')
+ "theshellb.desktop")
+md5sums=('SKIP' 'SKIP')
build() {
cd "$pkgname-$pkgver"
@@ -37,6 +36,4 @@ package() {
cp "initscript.sh" "$pkgdir/usr/bin/init_theshellb"
mkdir -p "$pkgdir/usr/share/xsessions"
cp "theshellb.desktop" "$pkgdir/usr/share/xsessions"
- #mkdir -p "$pkgdir/usr/share/theshell/translations"
- #cp "$pkgname-$pkgver/translations/"* "$pkgdir/usr/share/theshell/translations"
}
diff --git a/initscript.sh b/initscript.sh
deleted file mode 100755
index 9f9d6820fbf9..000000000000
--- a/initscript.sh
+++ /dev/null
@@ -1,5 +0,0 @@
-export XDG_CURRENT_DESKTOP=KDE
-export DE=kde
-export KDE_SESSION_VERSION=5
-export QT_QPA_PLATFORMTHEME=ts
-theshellb
diff --git a/theshellb.desktop b/theshellb.desktop
index b0eb0017c69a..1c08d2c9a178 100644
--- a/theshellb.desktop
+++ b/theshellb.desktop
@@ -1,8 +1,8 @@
[Desktop Entry]
Encoding=UTF-8
Type=XSession
-Exec=/usr/bin/init_theshellb
-TryExec=/usr/bin/init_theshellb
+Exec=/usr/bin/ts-startsession --blueprint
+TryExec=/usr/bin/ts-startsession --blueprint
DesktopNames=theShell
Name=theShell Blueprint
Comment=Desktop Shell for theOS