summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Tran2017-09-27 20:44:21 +1000
committerVictor Tran2017-09-27 20:44:21 +1000
commitc4ffa470be31dd36bb6565746141a794434aaa2c (patch)
treeea6dbe03de90b54bf571ae5b2bf323df3c37a953
parent4837d6f4db033ef90a0a73703c95c6bdb2865a06 (diff)
downloadaur-c4ffa470be31dd36bb6565746141a794434aaa2c.tar.gz
Update PKGBUILD for new build instructions
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD16
-rw-r--r--theshellb.desktop8
3 files changed, 5 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8365b36f0b66..40082beae084 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -30,8 +30,6 @@ pkgbase = theshell-blueprint
optdepends = pocketsphinx: for theWave
optdepends = festival: for theWave
source = theshell-blueprint-7.1b::git+https://github.com/vicr123/theshell#branch=blueprint
- source = theshellb.desktop
- md5sums = SKIP
md5sums = SKIP
pkgname = theshell-blueprint
diff --git a/PKGBUILD b/PKGBUILD
index 7edb19fcee81..3204437a4636 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,22 +15,16 @@ optdepends=('alsa-utils: for volume controls'
'pocketsphinx: for theWave'
'festival: for theWave')
makedepends=('git')
-source=("$pkgname-$pkgver"::'git+https://github.com/vicr123/theshell#branch=blueprint'
- "theshellb.desktop")
-md5sums=('SKIP' 'SKIP')
+source=("$pkgname-$pkgver"::'git+https://github.com/vicr123/theshell#branch=blueprint')
+md5sums=('SKIP')
build() {
cd "$pkgname-$pkgver"
- git checkout blueprint
- qdbuscpp2xml -a -o org.thesuite.power.xml upowerdbus.h
- qdbuscpp2xml -a -o org.thesuite.theshell.xml dbussignals.h
- qmake theShell.pro
+ qmake "CONFIG+=blueprint" theShell.pro
make
}
package() {
- mkdir -p "$pkgdir/usr/bin"
- cp "$pkgname-$pkgver/theshell" "$pkgdir/usr/bin/theshellb"
- mkdir -p "$pkgdir/usr/share/xsessions"
- cp "theshellb.desktop" "$pkgdir/usr/share/xsessions"
+ cd "$pkgname-$pkgver"
+ make install INSTALL_ROOT=$pkgdir
}
diff --git a/theshellb.desktop b/theshellb.desktop
deleted file mode 100644
index 6e9f76904b48..000000000000
--- a/theshellb.desktop
+++ /dev/null
@@ -1,8 +0,0 @@
-[Desktop Entry]
-Encoding=UTF-8
-Type=XSession
-Exec=/usr/bin/ts-startsession --blueprint
-TryExec=/usr/bin/ts-startsession
-DesktopNames=theShell
-Name=theShell Blueprint
-Comment=Desktop Shell for theOS