summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Tran2017-06-08 19:37:35 +1000
committerVictor Tran2017-06-08 19:37:35 +1000
commitdb50244dfb0ba02c5bbdf752d1cc04b4927e5b95 (patch)
treeee0cef953a7d2f544c69198f7a22339a4ad82445
parentabeb0aef8fea462a5058b736b997c92a2ec9a644 (diff)
downloadaur-db50244dfb0ba02c5bbdf752d1cc04b4927e5b95.tar.gz
Fix init script
-rw-r--r--PKGBUILD9
-rwxr-xr-xinitscript.sh5
2 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7a1c31afe2b6..75b962c8feb9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,8 +16,9 @@ optdepends=('alsa-utils: for volume controls'
'festival: for theWave')
makedepends=('git')
source=("$pkgname-$pkgver"::'git+https://github.com/vicr123/theshell#branch=blueprint'
- "theshellb.desktop")
-md5sums=('SKIP' 'SKIP')
+ "theshellb.desktop"
+ "initscript.sh")
+md5sums=('SKIP' 'SKIP' 'SKIP')
build() {
cd "$pkgname-$pkgver"
@@ -29,10 +30,10 @@ build() {
}
package() {
- chmod +x "$pkgname-$pkgver/init_theshell"
+ chmod +x "initscript.sh"
mkdir -p "$pkgdir/usr/bin"
cp "$pkgname-$pkgver/theshell" "$pkgdir/usr/bin/theshellb"
- cp "$pkgname-$pkgver/init_theshell" "$pkgdir/usr/bin/init_theshellb"
+ cp "initscript.sh" "$pkgdir/usr/bin/init_theshellb"
mkdir -p "$pkgdir/usr/share/xsessions"
cp "theshellb.desktop" "$pkgdir/usr/share/xsessions"
#mkdir -p "$pkgdir/usr/share/theshell/translations"
diff --git a/initscript.sh b/initscript.sh
new file mode 100755
index 000000000000..9f9d6820fbf9
--- /dev/null
+++ b/initscript.sh
@@ -0,0 +1,5 @@
+export XDG_CURRENT_DESKTOP=KDE
+export DE=kde
+export KDE_SESSION_VERSION=5
+export QT_QPA_PLATFORMTHEME=ts
+theshellb