summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-18 19:18:38 +0800
committerzxp198210052024-03-18 19:18:38 +0800
commit0bcd2ff44bec2675ce8078b16338da8b448f68c5 (patch)
treeafd201e1f6a7eafd374622390e08c39e4f77e669
parenta14dc6b4ced5e08902d48f8b4ecaaf00ce9da831 (diff)
downloadaur-thinreports-section-editor-bin.tar.gz
fix errors
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
-rw-r--r--thinreports-section-editor.sh8
3 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f140d851d7d7..4c00c77c1144 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = thinreports-section-editor-bin
pkgdesc = A template editor for Thinreports to edit Section Format templates
pkgver = 1.0.0_dev
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/thinreports/thinreports
arch = x86_64
license = MIT
- depends = electron21
+ makedepends = fuse2
+ depends = electron21-bin
depends = hicolor-icon-theme
provides = thinreports-section-editor=1.0.0_dev
conflicts = thinreports-section-editor
@@ -14,6 +15,6 @@ pkgbase = thinreports-section-editor-bin
source = thinreports-section-editor.sh
sha256sums = 818e3b1fdf4fb1ed1fdbe47cc58a034074a652577a887b168edfb033f47b6aeb
sha256sums = 2d416fa05a32860094f618f477a982dd77676b236dc710f2a4df289b7e43ae0c
- sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
pkgname = thinreports-section-editor-bin
diff --git a/PKGBUILD b/PKGBUILD
index 70b530fd3d09..7903e1e2cea8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=thinreports-section-editor-bin
pkgver=1.0.0_dev
_electronversion=21
-pkgrel=5
+pkgrel=6
pkgdesc="A template editor for Thinreports to edit Section Format templates"
arch=('x86_64')
url="https://github.com/thinreports/thinreports"
@@ -11,9 +11,12 @@ license=('MIT')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
- "electron${_electronversion}"
+ "electron${_electronversion}-bin"
'hicolor-icon-theme'
)
+makedepends=(
+ 'fuse2'
+)
source=(
"${pkgname%-bin}-${pkgver}.AppImage::${_ghurl}/releases/download/v${pkgver//_/-}/${pkgname%-bin}-${pkgver//_/-}-linux-20221031-0b5119.AppImage"
"LICENSE-${pkgver}::https://raw.githubusercontent.com/thinreports/thinreports-section-editor/v${pkgver//_/-}/LICENSE"
@@ -21,11 +24,12 @@ source=(
)
sha256sums=('818e3b1fdf4fb1ed1fdbe47cc58a034074a652577a887b168edfb033f47b6aeb'
'2d416fa05a32860094f618f477a982dd77676b236dc710f2a4df289b7e43ae0c'
- '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
+ 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
diff --git a/thinreports-section-editor.sh b/thinreports-section-editor.sh
index f9ced1432cfc..7ddcaab8d734 100644
--- a/thinreports-section-editor.sh
+++ b/thinreports-section-editor.sh
@@ -1,14 +1,16 @@
-#!/bin/sh
+#!/bin/bash
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file