summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiang Gao2017-02-04 14:29:36 -0500
committerXiang Gao2017-02-04 14:29:36 -0500
commitecb7a392838cb307cfa3762a415df3a534d201fa (patch)
tree303ae41034fb8294bd244ae0ed6fcf0afea19aa4
downloadaur-ecb7a392838cb307cfa3762a415df3a534d201fa.tar.gz
first pkgbuild, version 1.8.2
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bf56c908912e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = thrust
+ pkgdesc = A parallel algorithms library which resembles the C++ Standard Template Library (STL).
+ pkgver = 1.8.2
+ pkgrel = 1
+ url = http://thrust.github.io/
+ arch = any
+ license = APACHE
+ depends = cuda
+ source = https://github.com/thrust/thrust/releases/download/1.8.2/thrust-1.8.2.zip
+ sha256sums = 00925daee4d9505b7f33d0ed42ab0de0f9c68c4ffbe2a41e6d04452cdee77b2d
+
+pkgname = thrust
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a62de24aa254
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Xiang Gao <qasdfgtyuiop@gmail.com>
+pkgname=thrust
+pkgver=1.8.2
+pkgrel=1
+arch=('any')
+license=('APACHE')
+url="http://thrust.github.io/"
+pkgdesc="A parallel algorithms library which resembles the C++ Standard Template Library (STL)."
+
+source=("https://github.com/thrust/thrust/releases/download/$pkgver/$pkgname-$pkgver.zip")
+
+sha256sums=('00925daee4d9505b7f33d0ed42ab0de0f9c68c4ffbe2a41e6d04452cdee77b2d')
+
+depends=('cuda')
+
+package() {
+ install -d "${pkgdir}/usr/include"
+ cp -r "${srcdir}/$pkgname" "${pkgdir}/usr/include/$pkgname"
+}