summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel M. Capella2021-06-20 14:15:21 -0400
committerDaniel M. Capella2021-06-20 14:15:21 -0400
commitf18e30555679019742066196448c6cd7e373a322 (patch)
tree4f7113c31e5374c82704493d60122e852a9042bf
parent66844a29983c3a213699291ed4fbd6a8dd536f21 (diff)
downloadaur-thumbs.tar.gz
0.6.0
-rw-r--r--.SRCINFO9
-rw-r--r--0001-Global-install.patch36
-rw-r--r--PKGBUILD6
3 files changed, 25 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ee79ad6452e..07552a576334 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = thumbs
pkgdesc = Copy/pasting like vimium/vimperator
- pkgver = 0.5.1
+ pkgver = 0.6.0
pkgrel = 1
url = https://github.com/fcsonline/tmux-thumbs
arch = x86_64
@@ -9,10 +9,9 @@ pkgbase = thumbs
depends = gcc-libs
optdepends = bash: for tmux integration
optdepends = tmux: for tmux integration
- source = thumbs-0.5.1.tar.gz::https://static.crates.io/crates/thumbs/thumbs-0.5.1.crate
+ source = thumbs-0.6.0.tar.gz::https://static.crates.io/crates/thumbs/thumbs-0.6.0.crate
source = 0001-Global-install.patch
- b2sums = 9e62fd3d68803cc502ea54789eaf637a34b74d7c816d1b0d23b5d710a0a18b785b6f87010005c6fd28b2847c0ed18e06dea7fe487e70380ad192e2e560ad5be3
- b2sums = 0f1f7f9bfe0e44cd3d1851978189c21a8f22b27f90e75d8d5f75f6ca6b80aad334b9df71cc272e11fff55dc2767960ce60c74d93df3194e552fab331d4467dc0
+ b2sums = 706833eba52a29ddde6d8fc400de547c90c6a7552eca82392d026a4cb535f166c7065804ea39fed7099f45c6f9c7ffcdc02e1594a73f441dbf4d446bcc4197e8
+ b2sums = 2161a433de291d3b6bce06e96750f44fbbb042fb26a568f022cf4fd1dfc7af2ecb2b1452032a6447b6459f4b80a7f6bee739d8af1769bd0e5c75cd318fd2682a
pkgname = thumbs
-
diff --git a/0001-Global-install.patch b/0001-Global-install.patch
index 2bdd4b57bf65..c47b8c427e72 100644
--- a/0001-Global-install.patch
+++ b/0001-Global-install.patch
@@ -1,4 +1,4 @@
-From 99c1b8cb71c85e9f26e73fdaebf6405f2c0e66f7 Mon Sep 17 00:00:00 2001
+From 02ef06f34e702cb6c728d102ccca7817bc189392 Mon Sep 17 00:00:00 2001
From: "Daniel M. Capella" <polyzen@archlinux.org>
Date: Tue, 4 Aug 2020 18:30:54 -0400
Subject: [PATCH] Global install
@@ -10,7 +10,7 @@ Subject: [PATCH] Global install
3 files changed, 4 insertions(+), 22 deletions(-)
diff --git a/src/swapper.rs b/src/swapper.rs
-index 49da403..21aa815 100644
+index cce19e0..e2fc3d8 100644
--- a/src/swapper.rs
+++ b/src/swapper.rs
@@ -57,7 +57,6 @@ fn dbg(msg: &str) {
@@ -20,24 +20,24 @@ index 49da403..21aa815 100644
- dir: String,
command: String,
upcase_command: String,
- osc52: bool,
-@@ -73,7 +72,6 @@ pub struct Swapper<'a> {
+ multi_command: String,
+@@ -74,7 +73,6 @@ pub struct Swapper<'a> {
impl<'a> Swapper<'a> {
fn new(
executor: Box<&'a mut dyn Executor>,
- dir: String,
command: String,
upcase_command: String,
- osc52: bool,
-@@ -85,7 +83,6 @@ impl<'a> Swapper<'a> {
+ multi_command: String,
+@@ -87,7 +85,6 @@ impl<'a> Swapper<'a> {
Swapper {
executor,
- dir,
command,
upcase_command,
- osc52,
-@@ -210,11 +207,10 @@ impl<'a> Swapper<'a> {
+ multi_command,
+@@ -213,11 +210,10 @@ impl<'a> Swapper<'a> {
};
let pane_command = format!(
@@ -50,38 +50,38 @@ index 49da403..21aa815 100644
tmp = TMP_FILE,
args = args.join(" "),
zoom_command = zoom_command,
-@@ -421,7 +417,6 @@ mod tests {
- Box::new(&mut executor),
+@@ -447,7 +443,6 @@ mod tests {
+ "".to_string(),
"".to_string(),
"".to_string(),
- "".to_string(),
false,
);
-@@ -443,7 +438,6 @@ mod tests {
- Box::new(&mut executor),
+@@ -470,7 +465,6 @@ mod tests {
+ "".to_string(),
"".to_string(),
"".to_string(),
- "".to_string(),
false,
);
-@@ -465,7 +459,6 @@ mod tests {
- let upcase_command = "open \"{}\"".to_string();
+@@ -493,7 +487,6 @@ mod tests {
+ let multi_command = "open \"{}\"".to_string();
let mut swapper = Swapper::new(
Box::new(&mut executor),
- "".to_string(),
user_command,
upcase_command,
- false,
-@@ -542,7 +535,6 @@ fn main() -> std::io::Result<()> {
+ multi_command,
+@@ -578,7 +571,6 @@ fn main() -> std::io::Result<()> {
let mut executor = RealShell::new();
let mut swapper = Swapper::new(
Box::new(&mut executor),
- dir.to_string(),
command.to_string(),
upcase_command.to_string(),
- osc52,
+ multi_command.to_string(),
diff --git a/tmux-thumbs.sh b/tmux-thumbs.sh
index 92d5625..f1e0a26 100755
--- a/tmux-thumbs.sh
@@ -133,5 +133,5 @@ index 4fc9355..dc03d1d 100755
-fi
+tmux bind-key "${THUMBS_KEY}" run-shell -b /usr/share/thumbs/tmux-thumbs.sh
--
-2.30.0
+2.32.0
diff --git a/PKGBUILD b/PKGBUILD
index a01a99a1ef87..1ac0f08d244c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel M. Capella <polyzen@archlinux.org>
pkgname=thumbs
-pkgver=0.5.1
+pkgver=0.6.0
pkgrel=1
pkgdesc='Copy/pasting like vimium/vimperator'
arch=('x86_64')
@@ -13,8 +13,8 @@ optdepends=('bash: for tmux integration'
'tmux: for tmux integration')
source=("$pkgname-$pkgver.tar.gz::https://static.crates.io/crates/$pkgname/$pkgname-$pkgver.crate"
'0001-Global-install.patch')
-b2sums=('9e62fd3d68803cc502ea54789eaf637a34b74d7c816d1b0d23b5d710a0a18b785b6f87010005c6fd28b2847c0ed18e06dea7fe487e70380ad192e2e560ad5be3'
- '0f1f7f9bfe0e44cd3d1851978189c21a8f22b27f90e75d8d5f75f6ca6b80aad334b9df71cc272e11fff55dc2767960ce60c74d93df3194e552fab331d4467dc0')
+b2sums=('706833eba52a29ddde6d8fc400de547c90c6a7552eca82392d026a4cb535f166c7065804ea39fed7099f45c6f9c7ffcdc02e1594a73f441dbf4d446bcc4197e8'
+ '2161a433de291d3b6bce06e96750f44fbbb042fb26a568f022cf4fd1dfc7af2ecb2b1452032a6447b6459f4b80a7f6bee739d8af1769bd0e5c75cd318fd2682a')
prepare() {
cd $pkgname-$pkgver