summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2020-07-31 15:21:49 -0400
committerTed Alff2020-07-31 15:21:49 -0400
commit6dfb95a5612a07e7e90427ccd4718ea7952554d1 (patch)
treecf3d6c3df00e300d46362af35dda49462a07680b
parent50838aac32b3e0804bae729383bc500d3da2a046 (diff)
downloadaur-6dfb95a5612a07e7e90427ccd4718ea7952554d1.tar.gz
Adopt and update.
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD47
2 files changed, 38 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b30334fbe4a..591abffda33f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,20 @@
-# Generated by mksrcinfo v8
-# Sun Sep 10 19:46:11 UTC 2017
pkgbase = thunar-git
pkgdesc = file manager for xfce
- pkgver = 1.6.12.r96.g9d9ed111
+ pkgver = 4.15.1+57+g0eb5aa16
pkgrel = 1
- url = http://thunar.xfce.org
+ url = https://thunar.xfce.org
arch = i686
arch = x86_64
- groups = xfce4-git
+ arch = armv7h
+ arch = aarch64
+ groups = xfce4-devel
license = GPL
- makedepends = git
+ makedepends = intltool
+ makedepends = xfce4-panel
+ makedepends = gtk-doc
+ makedepends = gobject-introspection
makedepends = xfce4-dev-tools
+ makedepends = git
depends = desktop-file-utils
depends = exo
depends = gtk3
@@ -19,17 +23,17 @@ pkgbase = thunar-git
depends = libexif
depends = libnotify
depends = libpng
- depends = libxfce4ui
- depends = libxfce4util
+ depends = libxfce4ui>=4.15.3
+ depends = libxfce4util>=4.15.2
optdepends = gvfs: trash support, mounting with udisks, and remote filesystems
optdepends = xfce4-panel: trash applet
optdepends = tumbler: for thumbnail previews
optdepends = thunar-volman: manages removable devices
optdepends = thunar-archive-plugin: create and deflate archives
optdepends = thunar-media-tags-plugin: view/edit id3/ogg tags
- provides = thunar=1.6.12
+ provides = thunar=4.15.1+57+g0eb5aa16
conflicts = thunar
- source = thunar-git::git+https://git.xfce.org/xfce/thunar
+ source = thunar::git+https://gitlab.xfce.org/xfce/thunar.git
sha256sums = SKIP
pkgname = thunar-git
diff --git a/PKGBUILD b/PKGBUILD
index b6f28cdc86a0..f83837db58f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,39 @@
-# Maintainer: Alad Wenter <nynq@nepuyvahk.vasb> (rot13)
+# Maintainer: twa022 <twa022 at gmail dot com>
+# Contributor: Alad Wenter <nynq@nepuyvahk.vasb> (rot13)
# Contributor: Limao Luo <luolimao+AUR@gmail.com>
# Contributor: Evangelos Foutras <evangelos@foutrelis.com>
# Contributor: Andrew Simmons <andrew.simmons@gmail.com>
-pkgname=thunar-git
-pkgver=1.6.12.r96.g9d9ed111
+_pkgname=thunar
+pkgname=${_pkgname}-git
+pkgver=4.15.1+57+g0eb5aa16
pkgrel=1
pkgdesc='file manager for xfce'
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'armv7h' 'aarch64')
license=('GPL')
-url='http://thunar.xfce.org'
-groups=('xfce4-git')
+groups=('xfce4-devel')
+url='https://thunar.xfce.org'
depends=('desktop-file-utils' 'exo' 'gtk3' 'hicolor-icon-theme' 'libgudev'
- 'libexif' 'libnotify' 'libpng' 'libxfce4ui' 'libxfce4util')
-makedepends=('git' 'xfce4-dev-tools')
+ 'libexif' 'libnotify' 'libpng' 'libxfce4ui>=4.15.3' 'libxfce4util>=4.15.2')
+makedepends=('intltool' 'xfce4-panel' 'gtk-doc' 'gobject-introspection' 'xfce4-dev-tools' 'git')
optdepends=('gvfs: trash support, mounting with udisks, and remote filesystems'
- 'xfce4-panel: trash applet'
- 'tumbler: for thumbnail previews'
- 'thunar-volman: manages removable devices'
- 'thunar-archive-plugin: create and deflate archives'
- 'thunar-media-tags-plugin: view/edit id3/ogg tags')
-provides=("thunar=${pkgver%%.r*}")
-conflicts=('thunar')
-source=("$pkgname::git+https://git.xfce.org/xfce/thunar")
+ 'xfce4-panel: trash applet'
+ 'tumbler: for thumbnail previews'
+ 'thunar-volman: manages removable devices'
+ 'thunar-archive-plugin: create and deflate archives'
+ 'thunar-media-tags-plugin: view/edit id3/ogg tags')
+provides=("${_pkgname}=${pkgver}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}::git+https://gitlab.xfce.org/xfce/${_pkgname}.git")
sha256sums=('SKIP')
pkgver() {
- cd "$pkgname"
- git describe --long | sed -e 's/^thunar.//' -e 's/\([^-]*-g\)/r\1/' -e 's/-/./g'
+ cd "${_pkgname}"
+ git describe --long --tags | sed -r "s:^${_pkgname}.::;s/^v//;s/^xfce-//;s/-/+/g"
}
prepare() {
- cd "$pkgname"
+ cd "${_pkgname}"
./autogen.sh \
--prefix=/usr \
--sysconfdir=/etc \
@@ -39,8 +41,6 @@ prepare() {
--localstatedir=/var \
--disable-static \
--enable-gio-unix \
- --enable-dbus \
- --enable-startup-notification \
--enable-gudev \
--enable-exif \
--enable-pcre \
@@ -49,11 +49,12 @@ prepare() {
}
build() {
- cd "$pkgname"
+ cd "${_pkgname}"
make
}
package() {
- cd "$pkgname"
+ cd "${_pkgname}"
make DESTDIR="$pkgdir" install
}
+