summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2017-12-28 22:39:39 -0500
committerTed Alff2017-12-28 22:39:39 -0500
commit6125276afcd40a2a6f0e1097290a778f898e10eb (patch)
tree3b0a2d7022a55e7deb310ef32b8467fb067e8bae
parent071276453a01d3e1927b0dbc7e1d1deaec491e9b (diff)
downloadaur-6125276afcd40a2a6f0e1097290a778f898e10eb.tar.gz
Version bump 0.5.0. Split to python and python2 packages which are not currently coinstallable. Now requires thunarx-3 (thunar >= 1.7.0). If you need thunarx-python for GTK2 thunar thunarx-2, use thunarx-python-0.3
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD58
-rw-r--r--pygtk.patch12
-rw-r--r--python2.patch16
-rw-r--r--thunarx-python.install13
5 files changed, 51 insertions, 82 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 56fee246261d..0810a89ea4f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,31 @@
# Generated by mksrcinfo v8
-# Thu Dec 21 02:17:29 UTC 2017
+# Fri Dec 29 03:37:23 UTC 2017
pkgbase = thunarx-python
pkgdesc = Thunarx Python Bindings
- pkgver = 0.3.0
+ pkgver = 0.5.0
pkgrel = 1
epoch = 1
url = http://goodies.xfce.org/projects/bindings/thunarx-python
- install = thunarx-python.install
arch = i686
arch = x86_64
license = GPL
- makedepends = thunar
- depends = thunar<1.7.0
- depends = python2-gobject2
- depends = pygtk
- source = https://archive.xfce.org/src/bindings/thunarx-python/0.3/thunarx-python-0.3.0.tar.bz2
- source = python2.patch
- source = pygtk.patch
- sha256sums = 5650e045565af82f3a5f67bbecb46182b502a37f94d08c23adac697dbb4ce258
- sha256sums = 40c8ec1598142962349314eedb30fab5e115c719571490dcc39d1bcc793451e9
- sha256sums = c1386f440d3e3b10ee69afeed48f349b91720111aad2d2956b3767085ed8ff87
+ makedepends = thunar>=1.7.0
+ makedepends = python2-gobject
+ makedepends = python-gobject
+ source = https://archive.xfce.org/src/bindings/thunarx-python/0.5/thunarx-python-0.5.0.tar.bz2
+ sha256sums = c7ee5ab236285209a8a1fc1c9d5fc7b1004806c2c91bda6065ee66070bf85864
-pkgname = thunarx-python
+pkgname = python2-thunarx
+ pkgdesc = Thunarx Python 2 Bindings
+ depends = thunar>=1.7.0
+ depends = python2-gobject
+ provides = thunarx-python=0.5.0
+ conflicts = thunarx-python
+ replaces = thunarx-python
+
+pkgname = python-thunarx
+ depends = thunar>=1.7.0
+ depends = python-gobject
+ provides = thunarx-python=0.5.0
+ conflicts = thunarx-python
diff --git a/PKGBUILD b/PKGBUILD
index 5ee74836fc98..7091c649e3b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,47 +2,51 @@
# Contributor: D. Can Celasun <dcelasun[at]gmail[dot]com>
# Contributor: Dmitry Batenkov <dima dot batenkov at gmail dot com>
-pkgname=thunarx-python
+pkgbase=thunarx-python
+pkgname=('python2-thunarx' 'python-thunarx')
epoch=1
-pkgver=0.4.0
+pkgver=0.5.0
pkgrel=1
pkgdesc="Thunarx Python Bindings"
arch=('i686' 'x86_64')
url='http://goodies.xfce.org/projects/bindings/thunarx-python'
-makedepends=('thunar')
+makedepends=('thunar>=1.7.0' 'python2-gobject' 'python-gobject')
license=('GPL')
-install="${pkgname}.install"
-sha256sums=('435f4750f660575c6a854663bfc93f2f16d445128db0e8190e901aa09c15a615'
- '40c8ec1598142962349314eedb30fab5e115c719571490dcc39d1bcc793451e9'
- 'c1386f440d3e3b10ee69afeed48f349b91720111aad2d2956b3767085ed8ff87')
-if [[ "`pkg-config --modversion thunarx-3 2>/dev/null`" != '' ]] ; then
- depends+=('thunar>=1.7.0' 'python2-gobject')
-elif [[ "`pkg-config --modversion thunarx-2 2>/dev/null`" != '' ]] ; then
- depends+=('thunar<1.7.0' 'python2-gobject2' 'pygtk')
- pkgver=0.3.0
- sha256sums[0]='5650e045565af82f3a5f67bbecb46182b502a37f94d08c23adac697dbb4ce258'
-else
- return 1
-fi
-source=("https://archive.xfce.org/src/bindings/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2"
- 'python2.patch'
- 'pygtk.patch')
+sha256sums=('c7ee5ab236285209a8a1fc1c9d5fc7b1004806c2c91bda6065ee66070bf85864')
+source=("https://archive.xfce.org/src/bindings/${pkgbase}/${pkgver%.*}/${pkgbase}-${pkgver}.tar.bz2")
prepare() {
- cd "${pkgname}-${pkgver}"
- patch -p1 -i ../python2.patch
- if [[ `vercmp "${pkgver}" '0.3.0'` -le 0 ]] ; then
- patch -p1 -i ../pygtk.patch
- fi
+ [ -d "${pkgbase}-${pkgver}"-py2 ] && rm -fr "${pkgbase}-${pkgver}"-py2
+ cp -r "${pkgbase}-${pkgver}" "${pkgbase}-${pkgver}"-py2
}
build() {
- cd "${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+ PYTHON=python ./configure --prefix=/usr
+ make
+
+ cd "${srcdir}/${pkgbase}-${pkgver}"-py2
PYTHON=python2 ./configure --prefix=/usr
make
}
-package() {
- cd "${pkgname}-${pkgver}"
+package_python2-thunarx() {
+ pkgdesc="${pkgdesc/Python/Python 2}"
+ depends=('thunar>=1.7.0' 'python2-gobject')
+ provides=("${pkgbase}=${pkgver}")
+ conflicts=("${pkgbase}")
+ replaces=("${pkgbase}")
+
+ cd "${pkgbase}-${pkgver}"-py2
+ make DESTDIR="${pkgdir}" install
+}
+
+package_python-thunarx() {
+ depends=('thunar>=1.7.0' 'python-gobject')
+ provides=("${pkgbase}=${pkgver}")
+ conflicts=("${pkgbase}")
+
+ cd "${pkgbase}-${pkgver}"
make DESTDIR="${pkgdir}" install
}
+
diff --git a/pygtk.patch b/pygtk.patch
deleted file mode 100644
index e9000018c963..000000000000
--- a/pygtk.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -aur package.pristine/configure package.new/configure
---- package.pristine/configure 2011-03-12 23:12:15.000000000 +0200
-+++ package.new/configure 2011-03-12 23:21:31.000000000 +0200
-@@ -13339,7 +13339,7 @@
-
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for pygtk codegen" >&5
- $as_echo_n "checking for pygtk codegen... " >&6; }
--PYGTK_CODEGEN="/usr/bin/python `$PKG_CONFIG --variable=codegendir pygobject-2.0`/codegen.py"
-+PYGTK_CODEGEN="$PYTHON `$PKG_CONFIG --variable=codegendir pygobject-2.0`/codegen.py"
-
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $PYGTK_CODEGEN" >&5
- $as_echo "$PYGTK_CODEGEN" >&6; }
diff --git a/python2.patch b/python2.patch
deleted file mode 100644
index a58317d4315a..000000000000
--- a/python2.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff -aur package.pristine/configure package.new/configure
---- package.pristine/configure 2011-03-12 23:12:15.000000000 +0200
-+++ package.new/configure 2011-03-12 23:21:31.000000000 +0200
-@@ -13307,9 +13307,9 @@
- fi
-
-
--PYTHON_CFLAGS="`python-config --includes`"
--PYTHON_LIBS="`python-config --libs`"
--PYTHON_LDFLAGS="`python-config --ldflags`"
-+PYTHON_CFLAGS="`python2-config --includes`"
-+PYTHON_LIBS="`python2-config --libs`"
-+PYTHON_LDFLAGS="`python2-config --ldflags`"
-
-
-
diff --git a/thunarx-python.install b/thunarx-python.install
deleted file mode 100644
index 65e72cf20bb4..000000000000
--- a/thunarx-python.install
+++ /dev/null
@@ -1,13 +0,0 @@
-post_install() {
- if [[ "`pkg-config --modversion thunarx-2 2>/dev/null`" != '' ]] ; then
- printf "$(tput setaf 1)$(tput bold) ==> NOTE: $(tput sgr0)"
- echo "You have installed thunarx-python 0.3.0 for the GTK2 version of"
- echo " thunar. Do not upgrade to verson 0.4.0 until you install the GTK3 version of"
- echo " thunar (version >=1.7.0) which has not yet been added to the extra repo"
- fi
-}
-
-post_upgrade() {
- post_install
-}
-