summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Ambo2017-03-09 19:49:35 +0100
committerVincent Ambo2017-03-09 19:52:40 +0100
commit4955b1316311aae728d8533c4fa1b7ecd7b87b97 (patch)
treed7ade1a09df3dcb185066f57da91845c8c3eb07c
downloadaur-thunderbolt-icm-dkms-git.tar.gz
feat: Initial package for thunderbolt-icm-dkms
Adds a PKGBUILD for fetching and building Dell's thunderbolt-icm-dkms module from Github: https://github.com/dell/thunderbolt-icm-dkms This is required for the Dell XPS Thunderbolt firmware updates: https://github.com/dell/thunderbolt-nvm-linux
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3d721cb7511c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = thunderbolt-icm-dkms-git
+ pkgdesc = DKMS Package for the thunderbolt ICM driver
+ pkgver = r2.2d1bd45
+ pkgrel = 1
+ url = https://github.com/dell/thunderbolt-icm-dkms
+ arch = x86_64
+ license = GPL2
+ depends = dkms
+ optdepends = linux-headers
+ optdepends = linux-lts-headers
+ source = git+https://github.com/dell/thunderbolt-icm-dkms.git
+ sha1sums = SKIP
+
+pkgname = thunderbolt-icm-dkms-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..342089c41426
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Vincent Ambo <tazjin@gmail.com>
+
+_pkgname=thunderbolt-icm-dkms
+pkgname=thunderbolt-icm-dkms-git
+pkgver=r2.2d1bd45
+pkgrel=1
+pkgdesc="DKMS Package for the thunderbolt ICM driver"
+arch=('x86_64')
+url="https://github.com/dell/thunderbolt-icm-dkms"
+# No license file in repo yet, but see discussion on Github:
+# https://github.com/dell/thunderbolt-icm-dkms/issues/1
+license=('GPL2')
+depends=('dkms')
+optdepends=('linux-headers' 'linux-lts-headers')
+source=('git+https://github.com/dell/thunderbolt-icm-dkms.git')
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ local dest="${pkgdir}/usr/src/${_pkgname}-${pkgver}"
+
+ mkdir -p "${dest}"
+ cp "${srcdir}/${_pkgname}/thunderbolt-icm"/* "${dest}"
+}