summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorn0vember2018-09-26 14:44:21 +0200
committern0vember2018-09-26 14:44:21 +0200
commit141dba3b3573a8d303cbae5d719745fca65c041f (patch)
tree2abaaaf07251b8c907cdc4da73a38f0b69bb16d7
parent785447e6776f1899c08661fe8db72f717f3f3f37 (diff)
downloadaur-thunderbolt-software-user-space.tar.gz
add Makefile used to build
-rw-r--r--.gitignore4
-rw-r--r--Makefile13
2 files changed, 17 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d29f17db34a3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+thunderbolt-software-user-space
+thunderbolt-software-user-space-*-x86_64.pkg.tar.xz
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..3f4b3ba8fbed
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,13 @@
+package: .SRCINFO
+ makepkg
+
+.SRCINFO:
+ makepkg --printsrcinfo > .SRCINFO
+
+clean:
+ rm -rf pkg
+ rm -rf src
+ rm -rf thunderbolt-software-user-space
+ rm thunderbolt-software-user-space-*-x86_64.pkg.tar.xz
+
+.PHONY: .SRCINFO