summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexei Colin2023-09-10 18:39:11 -0400
committerAlexei Colin2023-09-10 18:39:11 -0400
commit6d714f85acaf647fec7bbb6d5e867f817f0ffc81 (patch)
tree755ce170e0e7cc74e05b9293957a8a04bd5f1554
parentbe86e700add154a523a0308d11d567bbee571fd8 (diff)
downloadaur-ti-ble-sdk.tar.gz
update to 2.02.07.06, lxml dep to python 3
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f54d1637f25..12e3491e282c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = ti-ble-sdk
pkgdesc = Texas Instruments BLE Stack for CC2640/CC2650/CC1350
- pkgver = 2.02.05.02
+ pkgver = 2.02.07.06
pkgrel = 1
url = http://www.ti.com/tool/ble-stack
install = ti-ble-sdk.install
arch = x86_64
license = custom:LPRF
makedepends = wine
- depends = python2-lxml
+ depends = python-lxml
depends = ti-rtos-cc13xx-cc26xx
optdepends = ccstudio
optdepends = ti-cgt-arm
@@ -17,10 +17,9 @@ pkgbase = ti-ble-sdk
options = emptydirs
options = !purge
options = !zipman
- source = local://ble_sdk_2_02_05_02_setup.exe
+ source = local://ble_sdk_2_02_07_06_setup.exe
source = ltoa.patch
- sha256sums = 9b65f2b1c6152c72af4d20d4bb1af375b01151b68163bf5cc0d8e384228d05a0
- sha256sums = 675fd1fcd998eb17726210540d5ce3e0061b84defba1b246e7a720e2de1f463e
+ md5sums = f681835d5795944959b085c377262edc
+ md5sums = 3e6e7a357007813934822a31eaed51c9
pkgname = ti-ble-sdk
-
diff --git a/PKGBUILD b/PKGBUILD
index 199bd76e6883..e29492d5d313 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,7 @@
# generate a GUI box. Parent installer fails if run headless.
pkgname=ti-ble-sdk
-pkgver=2.02.05.02
-_pkgver=2_02_05_02
+pkgver=2.02.07.06
pkgrel=1
pkgdesc="Texas Instruments BLE Stack for CC2640/CC2650/CC1350"
arch=('x86_64')
@@ -14,11 +13,11 @@ url="http://www.ti.com/tool/ble-stack"
license=('custom:LPRF')
makedepends=('wine')
-depends=('python2-lxml' 'ti-rtos-cc13xx-cc26xx')
+depends=('python-lxml' 'ti-rtos-cc13xx-cc26xx')
optdepends=('ccstudio' 'ti-cgt-arm')
install=$pkgname.install
-_bundle=ble_sdk_${_pkgver}
+_bundle=ble_sdk_${pkgver//./_}
_installer=${_bundle}_setup.exe
# Alternatively, to download from TI, you need a download key, which
@@ -30,6 +29,10 @@ source=(# Requires you to open "$url" in browser to get download link with key
local://${_installer}
ltoa.patch)
+# TI website provides MD5 specifically
+md5sums=('f681835d5795944959b085c377262edc'
+ '3e6e7a357007813934822a31eaed51c9')
+
options=(!strip libtool staticlibs emptydirs !purge !zipman)
_winedir=wine
@@ -196,6 +199,3 @@ package() {
install -D -m0644 $srcdir/${_installpath}/${_bundle}/license.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
}
-
-sha256sums=('9b65f2b1c6152c72af4d20d4bb1af375b01151b68163bf5cc0d8e384228d05a0'
- '675fd1fcd998eb17726210540d5ce3e0061b84defba1b246e7a720e2de1f463e')