summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkolorafa2016-12-15 09:34:09 +0100
committerkolorafa2016-12-15 09:34:09 +0100
commit067fc723df422c03f9eec118e6b5f4411dceeb6a (patch)
treef4df8d31369373689464271052088905ccb77a2b
parent874f612e8ad401b764d798bc5387547d0c943f87 (diff)
downloadaur-067fc723df422c03f9eec118e6b5f4411dceeb6a.tar.gz
Added old dep
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--update.sh2
3 files changed, 15 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7523b894de05..4796d36ad721 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = timedoctorpro
pkgdesc = App to track work time from timedoctor.com
pkgver = 1.4.75.14
- pkgrel = 2
+ pkgrel = 3
url = https://www.timedoctor.com/download.html
arch = x86_64
license = proprietary
@@ -12,7 +12,9 @@ pkgbase = timedoctorpro
depends = opencv2
depends = jasper
source = https://updates.timedoctor.com/download/_production/tdpro/linux-ubuntu-16.04/timedoctorpro_1.4.75-14ubuntu16.04_amd64.deb
+ source = https://archive.archlinux.org/packages/j/jasper/jasper-1.900.5-1-x86_64.pkg.tar.xz
md5sums = 0d50154852f5f10bd8e470066f61a523
+ md5sums = c8360ae58c424f1c1d4cff50d56e47ec
pkgname = timedoctorpro
diff --git a/PKGBUILD b/PKGBUILD
index 9a23d4636db7..a838954535af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=timedoctorpro
pkgver=1.4.75.14
urlver=$(echo $pkgver|sed 's/\.\([^.]*\)$/-\1/')
-pkgrel=2
+pkgrel=3
arch=('x86_64')
pkgdesc="App to track work time from timedoctor.com"
url="https://www.timedoctor.com/download.html"
@@ -16,10 +16,17 @@ license=('proprietary')
#maybe also depends=('libxss')
depends=('libx11' 'libxcb' 'zlib' 'qt4' 'opencv2' 'jasper')
-source=("https://updates.timedoctor.com/download/_production/tdpro/linux-ubuntu-16.04/timedoctorpro_${urlver}ubuntu16.04_amd64.deb")
-md5sums=('0d50154852f5f10bd8e470066f61a523')
+source=(
+ "https://updates.timedoctor.com/download/_production/tdpro/linux-ubuntu-16.04/timedoctorpro_${urlver}ubuntu16.04_amd64.deb"
+ "https://archive.archlinux.org/packages/j/jasper/jasper-1.900.5-1-x86_64.pkg.tar.xz"
+)
+md5sums=(
+ "0d50154852f5f10bd8e470066f61a523"
+ "c8360ae58c424f1c1d4cff50d56e47ec"
+)
package() {
cd $pkgdir
tar -xf $srcdir/data.tar.xz
+ cp $srcdir/usr/lib/libjasper.so.1.0.0 opt/timedoctorpro/libjasper.so.1
}
diff --git a/update.sh b/update.sh
new file mode 100644
index 000000000000..8893d4554112
--- /dev/null
+++ b/update.sh
@@ -0,0 +1,2 @@
+#!/bin/bash
+makepkg --printsrcinfo > .SRCINFO && git commit .SRCINFO PKGBUILD && git push