summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-08-02 13:08:42 -0600
committerMark Wagie2023-08-02 13:08:42 -0600
commitc4fd9c546dcca297cae6646214f1eefd1bb1a88a (patch)
treed30274de48b74766938397d154ff7180dfbc40f2
parent960f257e1146e49078a2850e4623d258a65fc7a2 (diff)
downloadaur-timeshift-bin.tar.gz
add aarch64 & riscv64 sources
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD19
2 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 72855b3b03d9..eec833a773b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,11 @@
pkgbase = timeshift-bin
pkgdesc = A system restore utility for Linux
pkgver = 23.07.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/linuxmint/timeshift
arch = x86_64
+ arch = aarch64
+ arch = riscv64
license = GPL3
depends = cronie
depends = gtk3
@@ -19,7 +21,11 @@ pkgbase = timeshift-bin
optdepends = grub-btrfs: BTRFS snapshots in GRUB
provides = timeshift
conflicts = timeshift
- source = https://launchpad.net/~linuxmint-daily-build-team/+archive/ubuntu/daily-builds/+files/timeshift_23.07.1-unstable-202307081612~ubuntu23.04.1_amd64.deb
- sha256sums = 10e04c964cf353457f0bb650be733da60e06ab5e5ad798d416176feff038d009
+ source_x86_64 = https://launchpad.net/ubuntu/+archive/primary/+files/timeshift_23.07.1-1_amd64.deb
+ sha256sums_x86_64 = af483c62a227306c935fc5a35dd08757bb2519be8e773d7dda7d2fd7733a9265
+ source_aarch64 = https://launchpad.net/ubuntu/+archive/primary/+files/timeshift_23.07.1-1_arm64.deb
+ sha256sums_aarch64 = f5e6915cc80a877428f57d80dad3383c90269a34d31f1073787d6dd3ae4b043c
+ source_riscv64 = https://launchpad.net/ubuntu/+archive/primary/+files/timeshift_23.07.1-1_riscv64.deb
+ sha256sums_riscv64 = 93fee40b0108ea6d5b53097d7bfa37b8762975003cee0838453b621e7a9d49f6
pkgname = timeshift-bin
diff --git a/PKGBUILD b/PKGBUILD
index f8e436a1d238..594110ba23cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,11 @@
# Contributor: Fire100265 <fire100265@outlook.com>
pkgname=timeshift-bin
pkgver=23.07.1
-pkgrel=1
+pkgrel=2
_build_id=202307081612
_ubuntu_ver=23.04.1
pkgdesc="A system restore utility for Linux"
-arch=('x86_64')
-#arch=('x86_64' 'aarch64' 'riscv64')
+arch=('x86_64' 'aarch64' 'riscv64')
url="https://github.com/linuxmint/timeshift"
license=('GPL3')
depends=('cronie' 'gtk3' 'libgee' 'libnotify' 'libsoup' 'rsync' 'vte3' 'which'
@@ -16,14 +15,12 @@ optdepends=('btrfs-progs: BTRFS support'
'grub-btrfs: BTRFS snapshots in GRUB')
provides=("${pkgname%-bin}")
conflicts=("${pkgname%-bin}")
-source=("https://launchpad.net/~linuxmint-daily-build-team/+archive/ubuntu/daily-builds/+files/${pkgname%-bin}_${pkgver}-unstable-${_build_id}~ubuntu${_ubuntu_ver}_amd64.deb")
-sha256sums=('10e04c964cf353457f0bb650be733da60e06ab5e5ad798d416176feff038d009')
-#source_x86_64=("https://launchpad.net/ubuntu/+archive/primary/+files/${pkgname%-bin}_${pkgver}-1_amd64.deb")
-#source_aarch64=("https://launchpad.net/ubuntu/+archive/primary/+files/${pkgname%-bin}_${pkgver}-1_arm64.deb")
-#source_riscv64=("https://launchpad.net/ubuntu/+archive/primary/+files/${pkgname%-bin}_${pkgver}-1_riscv64.deb")
-#sha256sums_x86_64=('a10a439f3259dd10b77ed883855cec8425c06c0516b231ea2ece7c9539d28460')
-#sha256sums_aarch64=('2d8184b38c532693374deaedf871c6987846b187a786b72b0ff7a173b033b266')
-#sha256sums_riscv64=('ae65276830fb3b6a46d3f31bc1f729883f000927ddc3dae012913f9eded75057')
+source_x86_64=("https://launchpad.net/ubuntu/+archive/primary/+files/${pkgname%-bin}_${pkgver}-1_amd64.deb")
+source_aarch64=("https://launchpad.net/ubuntu/+archive/primary/+files/${pkgname%-bin}_${pkgver}-1_arm64.deb")
+source_riscv64=("https://launchpad.net/ubuntu/+archive/primary/+files/${pkgname%-bin}_${pkgver}-1_riscv64.deb")
+sha256sums_x86_64=('af483c62a227306c935fc5a35dd08757bb2519be8e773d7dda7d2fd7733a9265')
+sha256sums_aarch64=('f5e6915cc80a877428f57d80dad3383c90269a34d31f1073787d6dd3ae4b043c')
+sha256sums_riscv64=('93fee40b0108ea6d5b53097d7bfa37b8762975003cee0838453b621e7a9d49f6')
package() {
bsdtar -xvf data.tar.zst -C "$pkgdir/"