summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEike Gebauer2022-09-16 18:33:22 +0200
committerEike Gebauer2022-09-16 18:38:42 +0200
commit54a850e3c8a9028110d2d822d06259440ca0cc70 (patch)
tree8d9a1126720f169db3464e9a51afc8b428454fbf
downloadaur-tinytiff-git.tar.gz
First version of PKGBUILD
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD31
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3e7c4a955bf7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = tinytiff-git
+ pkgdesc = A lightweight C/C++ library for reading and writing TIFF files
+ pkgver = r82.f13ce29
+ pkgrel = 1
+ url = https://jkriege2.github.io/TinyTIFF
+ arch = any
+ license = custom
+ makedepends = git
+ source = tinytiff::git+https://github.com/jkriege2/TinyTIFF
+ sha256sums = SKIP
+
+pkgname = tinytiff-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..11659877ccfd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Eike <e.g@wwu.de>
+pkgname=tinytiff-git
+_pkgname=tinytiff
+pkgdesc="A lightweight C/C++ library for reading and writing TIFF files"
+pkgver=r82.f13ce29
+pkgrel=1
+arch=('any')
+license=(custom)
+url="https://jkriege2.github.io/TinyTIFF"
+depends=()
+makedepends=('git')
+source=("${_pkgname}::git+https://github.com/jkriege2/TinyTIFF")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cmake -B build -S "${_pkgname}" \
+ -DTinyTIFF_BUILD_SHARED_LIBS=ON \
+ -DTinyTIFF_BUILD_STATIC_LIBS=OFF \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -Wno-dev
+ cmake --build build --config Release
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}