summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Bachmann2016-08-15 22:18:20 +0200
committerSimon Bachmann2016-08-15 22:18:20 +0200
commitdbaa6fe9616dd0fc14b970b1d7ae64f7320d6982 (patch)
tree5654bc6398a343830e7d04c3dd5062015708d5ad
downloadaur-tkcon-cvs.tar.gz
Created PKGBUILD. Included a patch for a bug not yet fixed uptstreams
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD58
-rw-r--r--under-patch.diff55
3 files changed, 130 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f027652f6881
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = tkcon-cvs
+ pkgdesc = TkCon is an enhanced interactive console for developing in Tcl.
+ pkgver = 20160814
+ pkgrel = 1
+ url = http://tkcon.sourceforge.net
+ arch = any
+ license = BSD
+ makedepends = cvs
+ depends = tcl
+ depends = tk
+ provides = tkcon
+ conflicts = tkcon
+ source = under-patch.diff
+ md5sums = aba22675d6dc3bdc4685f334ef2e7a4d
+
+pkgname = tkcon-cvs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cbfc2b059f9b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Simon Bachmann <simonbachmann@bluewin.ch>
+
+pkgname=tkcon-cvs
+pkgver=20160814
+pkgrel=1
+pkgdesc="TkCon is an enhanced interactive console for developing in Tcl."
+url="http://tkcon.sourceforge.net"
+license=('BSD')
+arch=(any)
+depends=('tcl' 'tk')
+makedepends=('cvs')
+conflicts=('tkcon')
+provides=('tkcon')
+source=('under-patch.diff')
+md5sums=('aba22675d6dc3bdc4685f334ef2e7a4d')
+
+_cvsroot=pserver:anonymous@tkcon.cvs.sourceforge.net:/cvsroot/tkcon
+_cvsmod=tkcon
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to $_cvsmod.sourceforge.net CVS server...."
+
+ if [[ -d "$_cvsmod/CVS" ]]; then
+ cd "$_cvsmod"
+ cvs -z3 update -d
+ else
+ cvs -z3 -d:"$_cvsroot" co -D "$pkgver" -f -P "$_cvsmod"
+ cd "$_cvsmod"
+ fi
+
+ msg "CVS checkout done or server timeout"
+ msg "Starting build..."
+
+ rm -rf "$srcdir/$_cvsmod-build"
+ cp -r "$srcdir/$_cvsmod" "$srcdir/$_cvsmod-build"
+ cd "$srcdir/$_cvsmod-build"
+
+ #
+ # patch tkcon.tcl
+ #
+ patch -p1 < "$srcdir/under-patch.diff"
+}
+
+package() {
+ cd "$srcdir/$_cvsmod-build"
+ install -D -m644 -t "${pkgdir}/usr/share/${pkgname}-${pkgver}/docs/" docs/*.html docs/*.txt docs/*.css docs/*.png
+ install -D -m644 docs/license.terms "${pkgdir}/usr/share/licenses/${pkgname}/licensce.terms"
+ install -D -m644 index.html "${pkgdir}/usr/share/${pkgname}-${pkgver}/index.html"
+ install -D -m644 -t "${pkgdir}/usr/share/man/mann/" docs/*.n.man
+ install -D -m644 -t "${pkgdir}/usr/share/man/man1/" docs/*.1.man
+ #install -D -m755 "${srcdir}/tkcon-run.sh ${pkgdir}/usr/bin/tkcon"
+ install -D -m755 tkcon.tcl "${pkgdir}/usr/share/$pkgname-$pkgver/tkcon.tcl"
+ install -d "${pkgdir}/usr/bin/"
+ cd "${pkgdir}/usr/bin/"
+ ln -s "../share/${pkgname}-${pkgver}/tkcon.tcl" "tkcon"
+}
+
diff --git a/under-patch.diff b/under-patch.diff
new file mode 100644
index 000000000000..94859dc47938
--- /dev/null
+++ b/under-patch.diff
@@ -0,0 +1,55 @@
+--- a/tkcon.tcl 2016-08-14 19:28:05.435157497 +0200
++++ b/tkcon.tcl 2016-08-14 07:44:27.021557898 +0200
+@@ -1069,9 +1069,9 @@
+ set tag [UniqueTag $w]
+ $w insert output $res [list stderr $tag] \n$trailer stderr
+ $w tag bind $tag <Enter> \
+- [list $w tag configure $tag -under 1]
++ [list $w tag configure $tag -underline 1]
+ $w tag bind $tag <Leave> \
+- [list $w tag configure $tag -under 0]
++ [list $w tag configure $tag -underline 0]
+ $w tag bind $tag <ButtonRelease-1> \
+ "if {!\[info exists tk::Priv(mouseMoved)\] || !\$tk::Priv(mouseMoved)} \
+ {[list $OPT(edit) -attach [Attach] -type error -- $PRIV(errorInfo)]}"
+@@ -3070,8 +3070,8 @@
+ set tag [UniqueTag $w]
+ $w tag add $tag $start+${c0}c $start+1c+${c1}c
+ $w tag configure $tag -foreground $COLOR(stdout)
+- $w tag bind $tag <Enter> [list $w tag configure $tag -under 1]
+- $w tag bind $tag <Leave> [list $w tag configure $tag -under 0]
++ $w tag bind $tag <Enter> [list $w tag configure $tag -underline 1]
++ $w tag bind $tag <Leave> [list $w tag configure $tag -underline 0]
+ $w tag bind $tag <ButtonRelease-1> "if {!\$tk::Priv(mouseMoved)} \
+ {[list $OPT(edit) -attach $app -type proc -find $what -- $cmd]}"
+ }
+@@ -3099,8 +3099,8 @@
+ set tag [UniqueTag $w]
+ $w tag add $tag $ix+1c $start
+ $w tag configure $tag -foreground $COLOR(proc)
+- $w tag bind $tag <Enter> [list $w tag configure $tag -under 1]
+- $w tag bind $tag <Leave> [list $w tag configure $tag -under 0]
++ $w tag bind $tag <Enter> [list $w tag configure $tag -underline 1]
++ $w tag bind $tag <Leave> [list $w tag configure $tag -underline 0]
+ $w tag bind $tag <ButtonRelease-1> "if {!\$tk::Priv(mouseMoved)} \
+ {[list $OPT(edit) -attach $app -type proc -- $cmd]}"
+ }
+@@ -3935,14 +3935,14 @@
+ ##
+ set text $w.text
+ set m [menu [::tkcon::MenuButton $menu Edit edit]]
+- $m add command -label "Cut" -under 2 \
++ $m add command -label "Cut" -underline 2 \
+ -command [list tk_textCut $text]
+- $m add command -label "Copy" -under 0 \
++ $m add command -label "Copy" -underline 0 \
+ -command [list tk_textCopy $text]
+- $m add command -label "Paste" -under 0 \
++ $m add command -label "Paste" -underline 0 \
+ -command [list tk_textPaste $text]
+ $m add separator
+- $m add command -label "Find" -under 0 \
++ $m add command -label "Find" -underline 0 \
+ -command [list ::tkcon::FindBox $text]
+
+ ## Send To Menu