summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2023-03-30 10:08:45 +0200
committerHans-Nikolai Viessmann2023-03-30 10:08:45 +0200
commit15d3bec63e041e563b9b91434c4f61ff017075fd (patch)
tree21df3c9f548544d8d2077ca5f976342b51360155
parentf5da4f931f2a5ac68a1c16f09f8a2d533fd4f817 (diff)
downloadaur-tllocalmgr.tar.gz
bump version to 0.8.3
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 099e86bbac7e..fb628e8e2bc6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,22 @@
pkgbase = tllocalmgr
pkgdesc = A shell and command-line utility to manage TeXLive on Arch Linux
- pkgver = 0.8
+ pkgver = 0.8.3
pkgrel = 1
url = https://github.com/hv15/tllocalmgr
arch = any
license = GPL
makedepends = git
- depends = texlive-core>=2016
- depends = texlive-core<2023
+ depends = texlive-core>=2022
depends = perl-libwww
depends = perl-term-shellui
depends = perl-term-readline-gnu
depends = perl-list-moreutils
depends = perl-lwp-protocol-https
- provides = texlive-localmanager=0.8
+ provides = texlive-localmanager=0.8.3
conflicts = texlive-localmanager
conflicts = texlive-localmanager-git
conflicts = tllocalmgr-git
- source = tllocalmgr::git+https://github.com/hv15/tllocalmgr.git#tag=v0.8
+ source = tllocalmgr::git+https://github.com/hv15/tllocalmgr.git#tag=v0.8.3
sha256sums = SKIP
pkgname = tllocalmgr
diff --git a/PKGBUILD b/PKGBUILD
index fc77fe724a9c..f3973f7e8075 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Firmicus <francois . archlinux . org>
pkgname=tllocalmgr
-pkgver=0.8
+pkgver=0.8.3
pkgrel=1
pkgdesc='A shell and command-line utility to manage TeXLive on Arch Linux'
arch=('any')
@@ -15,8 +15,7 @@ provides=("texlive-localmanager=$pkgver")
conflicts=('texlive-localmanager'
'texlive-localmanager-git'
'tllocalmgr-git')
-depends=('texlive-core>=2016'
- 'texlive-core<2023'
+depends=('texlive-core>=2022'
'perl-libwww'
'perl-term-shellui'
'perl-term-readline-gnu'
@@ -29,10 +28,10 @@ sha256sums=('SKIP')
package() {
cd "$pkgname"
- install -d "$pkgdir/usr/"{bin,share/texmf/arch/tlpkg/TeXLive}
+ install -d "$pkgdir/usr/"{bin,share/tllmgr/TLLocalMgr}
install -m755 tllocalmgr "$pkgdir/usr/bin/"
- cd tlpkg/TeXLive
+ cd tllmgr/TLLocalMgr
for _f in *; do
- install -m644 "$_f" "$pkgdir/usr/share/texmf/arch/tlpkg/TeXLive/"
+ install -m644 "$_f" "$pkgdir/usr/share/tllmgr/TLLocalMgr/"
done
}