summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomáš Mládek2015-08-29 21:57:37 +0200
committerTomáš Mládek2015-08-29 22:00:44 +0200
commit46529cecbff52ae9198072e5dc35148e6cf2f939 (patch)
treebf213715798eb364010447cf1f044141df486762
downloadaur-46529cecbff52ae9198072e5dc35148e6cf2f939.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD26
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ff1cbd505dab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = tmsu
+ pkgdesc = A tool for tagging your files and accessing them through a virtual filesystem.
+ pkgver = 0.5.2
+ pkgrel = 1
+ url = http://tmsu.org/
+ arch = i686
+ arch = x86_64
+ license = GNU GPL v3
+ depends = go
+ depends = fuse
+ depends = sqlite>=3
+ provides = tmsu
+ source_i686 = https://github.com/oniony/TMSU/releases/download/v0.5.2/tmsu-i686-0.5.2.tgz
+ sha256sums_i686 = e09ef8dab30f16cf1cec42610e575cc03362276da614bcf4f904decd79201466
+ source_x86_64 = https://github.com/oniony/TMSU/releases/download/v0.5.2/tmsu-x86_64-0.5.2.tgz
+ sha256sums_x86_64 = 5e994bc3112beeb0fe2a692aae2b313b185b9628f63ad09654b2c61e813104cc
+
+pkgname = tmsu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd34b8b588c9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# This is the PKGBUILD for TMSU
+
+# Maintainer: Tomáš Mládek <tmladek{at}inventati{dt}org>
+
+pkgname=tmsu
+pkgver=0.5.2
+pkgrel=1
+pkgdesc="A tool for tagging your files and accessing them through a virtual filesystem."
+arch=('i686' 'x86_64')
+url="http://tmsu.org/"
+depends=('go' 'fuse' 'sqlite>=3')
+provides=('tmsu')
+license=('GNU GPL v3')
+source_i686=("https://github.com/oniony/TMSU/releases/download/v$pkgver/tmsu-i686-$pkgver.tgz")
+source_x86_64=("https://github.com/oniony/TMSU/releases/download/v$pkgver/tmsu-x86_64-$pkgver.tgz")
+sha256sums_i686=('e09ef8dab30f16cf1cec42610e575cc03362276da614bcf4f904decd79201466')
+sha256sums_x86_64=('5e994bc3112beeb0fe2a692aae2b313b185b9628f63ad09654b2c61e813104cc')
+
+package(){
+ mkdir -p "$pkgdir/usr/bin" "$pkgdir/usr/share/man/man1" "$pkgdir/usr/share/zsh/site-functions"
+ cd "$srcdir/$pkgname-$CARCH-$pkgver"
+
+ cp "bin/"* "$pkgdir/usr/bin"
+ cp "man/tmsu.1.gz" "$pkgdir/usr/share/man/man1"
+ cp "misc/zsh/_tmsu" "$pkgdir/usr/share/zsh/site-functions"
+}