summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Webster2024-01-08 20:48:50 -0800
committerDonald Webster2024-01-08 20:48:50 -0800
commit774afc6460b5f33e8d78c9a3fa566ed59b2cfa8d (patch)
tree1d931e17bb3ff4b372868892219b24952e80028d
parent9606681a6943d64d295ec6cf1c0e87b425b200cb (diff)
downloadaur-774afc6460b5f33e8d78c9a3fa566ed59b2cfa8d.tar.gz
Fix xdg patch.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--xdg.patch20
3 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6de15a0bda8d..ce070ffb3164 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,6 +15,6 @@ pkgbase = tmuxinator
source = tmuxinator-3.1.0.tar.gz::https://github.com/aziz/tmuxinator/archive/v3.1.0.tar.gz
source = xdg.patch
sha256sums = 5d5a2d0bcfc507f5a4518fe5f8077cb449040a504d0701cdde59b63f927adbfe
- sha256sums = 96da8eb64998ac48f76e156ea39bda46f462f5be3e28c1dcd06decb95dff1dc9
+ sha256sums = 4a120cc210af73190561d2788f2d47c19b11d6f0f129f18fb2614748d5bd9470
pkgname = tmuxinator
diff --git a/PKGBUILD b/PKGBUILD
index 29befc819993..3fdf4ca2754a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,7 +23,7 @@ source=(
"xdg.patch"
)
sha256sums=('5d5a2d0bcfc507f5a4518fe5f8077cb449040a504d0701cdde59b63f927adbfe'
- '96da8eb64998ac48f76e156ea39bda46f462f5be3e28c1dcd06decb95dff1dc9')
+ '4a120cc210af73190561d2788f2d47c19b11d6f0f129f18fb2614748d5bd9470')
prepare() {
cd ${pkgname}-${pkgver}
diff --git a/xdg.patch b/xdg.patch
index 034a6b2bc1ee..c2bf27299540 100644
--- a/xdg.patch
+++ b/xdg.patch
@@ -1,5 +1,5 @@
diff --git a/lib/tmuxinator/config.rb b/lib/tmuxinator/config.rb
-index 25620bf..fcc61a3 100644
+index 9b64b75..d89e835 100644
--- a/lib/tmuxinator/config.rb
+++ b/lib/tmuxinator/config.rb
@@ -29,7 +29,7 @@ module Tmuxinator
@@ -9,14 +9,14 @@ index 25620bf..fcc61a3 100644
- XDG["CONFIG"].to_s + "/tmuxinator"
+ XDG::Config.new.home.to_s + "/tmuxinator"
end
-
+
def xdg?
diff --git a/spec/lib/tmuxinator/config_spec.rb b/spec/lib/tmuxinator/config_spec.rb
-index 71b8da2..d28a60a 100644
+index 877cac4..9be2aa3 100644
--- a/spec/lib/tmuxinator/config_spec.rb
+++ b/spec/lib/tmuxinator/config_spec.rb
@@ -53,7 +53,8 @@ describe Tmuxinator::Config do
-
+
Dir.mktmpdir do |dir|
config_parent = "#{dir}/non_existant_parent/s"
- allow(XDG).to receive(:[]).with("CONFIG").and_return config_parent
@@ -26,7 +26,7 @@ index 71b8da2..d28a60a 100644
to eq "#{config_parent}/tmuxinator"
expect(File.directory?("#{config_parent}/tmuxinator")).to be true
@@ -134,7 +135,8 @@ describe Tmuxinator::Config do
-
+
describe "#xdg" do
it "is $XDG_CONFIG_HOME/tmuxinator" do
- expect(described_class.xdg).to eq "#{XDG['CONFIG_HOME']}/tmuxinator"
@@ -34,17 +34,17 @@ index 71b8da2..d28a60a 100644
+ expect(described_class.xdg).to eq "#{config_home}/tmuxinator"
end
end
-
+
diff --git a/tmuxinator.gemspec b/tmuxinator.gemspec
-index 1b02053..3f4c8f8 100644
+index df933d8..f8e9fe7 100644
--- a/tmuxinator.gemspec
+++ b/tmuxinator.gemspec
@@ -41,7 +41,7 @@ Gem::Specification.new do |s|
-
+
s.add_dependency "erubis", "~> 2.6"
- s.add_dependency "thor", "~> 1.2.1"
+ s.add_dependency "thor", "~> 1.3.0"
- s.add_dependency "xdg", "~> 2.2", ">= 2.2.5"
+ s.add_dependency "xdg", ">= 4.3.0"
-
+
s.add_development_dependency "activesupport", "< 5.0.0" # Please see issue #432
s.add_development_dependency "awesome_print", "~> 1.2"