summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2015-06-13 17:59:24 +0200
committerMuflone2015-06-13 17:59:24 +0200
commit54b76182632b1d3c33ffb2ea8a18ad9b32eb4ab5 (patch)
tree8b8bce9202fa6beac1a28b3bfb937ed5add920a1
downloadaur-tn5250j-plugin-itext.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..85d7eb91dd11
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = tn5250j-plugin-itext
+ pkgdesc = Support for spool and text transformation in tn5250j
+ pkgver = 4.2.0
+ pkgrel = 1
+ url = https://github.com/ymasory/iText-4.2.0/
+ arch = any
+ license = LGPL
+ depends = tn5250j
+ noextract = iText-4.2.0.jar
+ source = https://github.com/downloads/ymasory/iText-4.2.0/iText-4.2.0.jar
+ md5sums = b2c1f84b9960ba3cc336ef25a4fa3c65
+
+pkgname = tn5250j-plugin-itext
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f2be4c46768e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Muflone <muflone@vbsimple.net>
+pkgname=tn5250j-plugin-itext
+pkgver=4.2.0
+pkgrel=1
+pkgdesc="Support for spool and text transformation in tn5250j"
+arch=(any)
+url="https://github.com/ymasory/iText-4.2.0/"
+license=('LGPL')
+depends=(tn5250j)
+source=("https://github.com/downloads/ymasory/iText-${pkgver}/iText-${pkgver}.jar")
+md5sums=('b2c1f84b9960ba3cc336ef25a4fa3c65')
+noextract=("iText-${pkgver}.jar")
+
+package() {
+ # Install files for the package
+ install -m 644 -D "$srcdir/iText-${pkgver}.jar" "$pkgdir/usr/share/java/tn5250j/itext.jar"
+}
+