summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Platte2015-07-22 21:32:38 +0200
committerJonas Platte2015-07-22 21:32:38 +0200
commit25ca4e6e1b63f1c6b2ec5a7a693ba11e4c41ba49 (patch)
tree0cbbd37f0ead6123264b26d779ee368fa2f5f21e
parentb17033cb9b5ea89896bb3c25e6818e20cf5b47bb (diff)
downloadaur-tntdb-git.tar.gz
Upstream uses git tags now, fix pkgver()
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 3 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d2ef7c9220eb..d9d5262ae26a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tntdb-git
pkgdesc = A C++ library for easy and robust access of SQL databases
- pkgver = 1.3.1.3dd171f
+ pkgver = 1.4rc1.r1.gef30fa1
pkgrel = 1
url = http://www.tntnet.org/tntdb.html
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 758149e98547..b9febb7f4e3e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jonas Platte <aur@jonasplatte.de>
pkgname=tntdb-git
-pkgver=1.3.1.3dd171f
+pkgver=1.4rc1.r1.gef30fa1
pkgrel=1
pkgdesc="A C++ library for easy and robust access of SQL databases"
arch=('i686' 'x86_64')
@@ -14,11 +14,9 @@ conflicts=('tntdb')
source=("$pkgname::git+https://github.com/maekitalo/${pkgname%-git}.git")
sha256sums=('SKIP')
-# This will very likely break if tntdb starts using tags. That is intentional,
-# as the --always will be removed then anyway, requiring an update
pkgver() {
cd "$pkgname"
- echo "1.3.1.$(git describe --always)"
+ git describe --long | sed 's/^V//' | sed 's/-/.r/;s/-/./'
}
build() {