summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSerge Pavlyuk2018-02-27 03:45:23 +0300
committerSerge Pavlyuk2018-02-27 03:47:02 +0300
commit721cd3dcf51a2c4686c357447adfcfeec1b59102 (patch)
tree83db4aaaf37afad1bf1c93d683394a689dbdf207
parent4179464a9572d96553b12beb0d562e4793be0ba0 (diff)
downloadaur-721cd3dcf51a2c4686c357447adfcfeec1b59102.tar.gz
Revert "Reverted poco patch usage."
This reverts commit 4179464a9572d96553b12beb0d562e4793be0ba0.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD15
-rw-r--r--systemlibs.patch68
3 files changed, 85 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b069afa996b6..7794a1256408 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = toggldesktop
pkgdesc = Toggl time tracking software
- pkgver = 7.4.122
+ pkgver = 7.4.107
pkgrel = 1
url = https://github.com/toggl/toggldesktop
arch = x86_64
@@ -9,6 +9,7 @@ pkgbase = toggldesktop
makedepends = gendesk
depends = libxss
depends = openssl
+ depends = poco
depends = qt5-base
depends = qt5-declarative
depends = qt5-location
@@ -19,10 +20,12 @@ pkgbase = toggldesktop
depends = qt5-x11extras
conflicts = toggldesktop-bin
conflicts = toggl-bin
- source = toggldesktop-7.4.122.tar.gz::https://github.com/toggl/toggldesktop/archive/v7.4.122.tar.gz
+ source = toggldesktop-7.4.107.tar.gz::https://github.com/toggl/toggldesktop/archive/v7.4.107.tar.gz
source = production.patch
- sha512sums = c6bec5cd729cb77a82293b953ae9db82d549f1fd15a2bd940451659e7ef4ef01293e7bccb4d030a1f1ef1749b9e7ed11459e9e68f5cf2b9c1339714301c6791c
+ source = systemlibs.patch
+ sha512sums = b38e205eb8e2c8f65a1f8e3609b0263b55d84fdb8751346d786ce0657fcb8c4ec04a9a7b6c37300b57c89ef20eadd7bf5b39f3c0c5b9207426087006816cd079
sha512sums = 484c6e3ba73e2f2ccbe9737424bee68624bd8d46a06735937b3ca134aa34ad9e335b260f7d22bcd3e351ae9d8b989ef048e78cf7ed52bac363bb651a7d229428
+ sha512sums = e2084ecaf7ba3d3c630597450f5aff6bb65844002f2f7332a01228f0f0f0a2c8dae7b7af5f28063db63c5ce10dcd0b21d92adfb5fd8e25677e94eaa0c578c34d
pkgname = toggldesktop
diff --git a/PKGBUILD b/PKGBUILD
index 8d899b06d0a9..6136a3b11ece 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: phi-mah
pkgname=toggldesktop
-pkgver=7.4.122
+pkgver=7.4.107
pkgrel=1
pkgdesc="Toggl time tracking software"
arch=('x86_64')
@@ -12,6 +12,7 @@ url="https://github.com/toggl/toggldesktop"
license=('BSD')
depends=('libxss'
'openssl'
+ 'poco'
'qt5-base'
'qt5-declarative'
'qt5-location'
@@ -22,10 +23,12 @@ depends=('libxss'
'qt5-x11extras')
makedepends=('readline' 'gendesk')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/toggl/toggldesktop/archive/v${pkgver}.tar.gz"
- "production.patch")
+ "production.patch"
+ "systemlibs.patch")
-sha512sums=('c6bec5cd729cb77a82293b953ae9db82d549f1fd15a2bd940451659e7ef4ef01293e7bccb4d030a1f1ef1749b9e7ed11459e9e68f5cf2b9c1339714301c6791c'
- '484c6e3ba73e2f2ccbe9737424bee68624bd8d46a06735937b3ca134aa34ad9e335b260f7d22bcd3e351ae9d8b989ef048e78cf7ed52bac363bb651a7d229428')
+sha512sums=('b38e205eb8e2c8f65a1f8e3609b0263b55d84fdb8751346d786ce0657fcb8c4ec04a9a7b6c37300b57c89ef20eadd7bf5b39f3c0c5b9207426087006816cd079'
+ '484c6e3ba73e2f2ccbe9737424bee68624bd8d46a06735937b3ca134aa34ad9e335b260f7d22bcd3e351ae9d8b989ef048e78cf7ed52bac363bb651a7d229428'
+ 'e2084ecaf7ba3d3c630597450f5aff6bb65844002f2f7332a01228f0f0f0a2c8dae7b7af5f28063db63c5ce10dcd0b21d92adfb5fd8e25677e94eaa0c578c34d')
conflicts=('toggldesktop-bin' 'toggl-bin')
@@ -39,6 +42,10 @@ prepare() {
# https://github.com/toggl/toggldesktop/wiki/Building-Toggl-Desktop-from-source-for-usage-with-live-servers
msg2 "production patch"
patch -p1 < ../production.patch
+
+ # patch to use sytem openssl and poco libs
+ msg2 "systmlibs patch"
+ patch -p1 < ../systemlibs.patch
)
# make the run script
diff --git a/systemlibs.patch b/systemlibs.patch
new file mode 100644
index 000000000000..8e1d6d5d6134
--- /dev/null
+++ b/systemlibs.patch
@@ -0,0 +1,68 @@
+reverted:
+--- toggldesktop-7.4.76/Makefile 2017-11-04 12:40:34.000000000 +0100
++++ mod/Makefile 2017-12-20 10:36:37.658884088 +0100
+@@ -5,8 +5,8 @@
+ architecture=$(shell uname -m)
+ timestamp=$(shell date "+%Y-%m-%d-%H-%M-%S")
+
++#pocodir=third_party/poco
++#openssldir=third_party/openssl
+-pocodir=third_party/poco
+-openssldir=third_party/openssl
+ jsoncppdir=third_party/jsoncpp/dist
+
+ GTEST_ROOT=third_party/googletest-read-only
+reverted:
+--- toggldesktop-7.4.76/src/lib/linux/TogglDesktopLibrary/TogglDesktopLibrary.pro 2017-11-04 12:40:34.000000000 +0100
++++ mod/src/lib/linux/TogglDesktopLibrary/TogglDesktopLibrary.pro 2017-12-20 10:38:12.312213226 +0100
+@@ -167,32 +167,32 @@
+ INCLUDEPATH += $$PWD/../../../../third_party/lua/src
+ DEPENDPATH += $$PWD/../../../../third_party/lua/src
+
++;INCLUDEPATH += $$PWD/../../../../third_party/poco/Foundation/include
++;DEPENDPATH += $$PWD/../../../../third_party/poco/Foundation/include
+-INCLUDEPATH += $$PWD/../../../../third_party/poco/Foundation/include
+-DEPENDPATH += $$PWD/../../../../third_party/poco/Foundation/include
+
++;INCLUDEPATH += $$PWD/../../../../third_party/poco/Util/include
++;DEPENDPATH += $$PWD/../../../../third_party/poco/Util/include
+-INCLUDEPATH += $$PWD/../../../../third_party/poco/Util/include
+-DEPENDPATH += $$PWD/../../../../third_party/poco/Util/include
+
++;INCLUDEPATH += $$PWD/../../../../third_party/poco/Data/include
++;DEPENDPATH += $$PWD/../../../../third_party/poco/Data/include
+-INCLUDEPATH += $$PWD/../../../../third_party/poco/Data/include
+-DEPENDPATH += $$PWD/../../../../third_party/poco/Data/include
+
++;INCLUDEPATH += $$PWD/../../../../third_party/poco/Data/SQLite/include
++;DEPENDPATH += $$PWD/../../../../third_party/poco/Data/SQLite/include
+-INCLUDEPATH += $$PWD/../../../../third_party/poco/Data/SQLite/include
+-DEPENDPATH += $$PWD/../../../../third_party/poco/Data/SQLite/include
+
++;INCLUDEPATH += $$PWD/../../../../third_party/openssl/include
++;DEPENDPATH += $$PWD/../../../../third_party/openssl/include
+-INCLUDEPATH += $$PWD/../../../../third_party/openssl/include
+-DEPENDPATH += $$PWD/../../../../third_party/openssl/include
+
++;INCLUDEPATH += $$PWD/../../../../third_party/poco/Crypto/include
++;DEPENDPATH += $$PWD/../../../../third_party/poco/Crypto/include
+-INCLUDEPATH += $$PWD/../../../../third_party/poco/Crypto/include
+-DEPENDPATH += $$PWD/../../../../third_party/poco/Crypto/include
+
++;INCLUDEPATH += $$PWD/../../../../third_party/poco/Net/include
++;DEPENDPATH += $$PWD/../../../../third_party/poco/Net/include
+-INCLUDEPATH += $$PWD/../../../../third_party/poco/Net/include
+-DEPENDPATH += $$PWD/../../../../third_party/poco/Net/include
+
++;INCLUDEPATH += $$PWD/../../../../third_party/poco/NetSSL_OpenSSL/include
++;DEPENDPATH += $$PWD/../../../../third_party/poco/NetSSL_OpenSSL/include
+-INCLUDEPATH += $$PWD/../../../../third_party/poco/NetSSL_OpenSSL/include
+-DEPENDPATH += $$PWD/../../../../third_party/poco/NetSSL_OpenSSL/include
+
++;INCLUDEPATH += $$PWD/../../../../third_party/poco/Data/SQLite/src
++;DEPENDPATH += $$PWD/../../../../third_party/poco/Data/SQLite/src
+-INCLUDEPATH += $$PWD/../../../../third_party/poco/Data/SQLite/src
+-DEPENDPATH += $$PWD/../../../../third_party/poco/Data/SQLite/src
+
+ #QMAKE_CXXFLAGS += -fsanitize=thread -fPIE
+ #QMAKE_LFLAGS += -pie -fsanitize=thread