summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSerge Pavlyuk2019-04-30 22:43:55 +0300
committerSerge Pavlyuk2019-04-30 22:43:55 +0300
commit92c07c74659c52addeff4d562c0be55ec967d0b6 (patch)
treeff6a9bde2498dfa5bd710cbe6dcfe2745fc96a05
parentf57289a3fc49bc471af1aa772f9edd8c9c8d1599 (diff)
downloadaur-92c07c74659c52addeff4d562c0be55ec967d0b6.tar.gz
update to 7.4.410
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD22
-rw-r--r--jsoncpp.patch6
-rw-r--r--production.patch36
4 files changed, 21 insertions, 55 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05169a42f7b4..6341495078bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = toggldesktop
pkgdesc = Toggl time tracking software
- pkgver = 7.4.347
- pkgrel = 2
+ pkgver = 7.4.410
+ pkgrel = 1
url = https://github.com/toggl/toggldesktop
arch = x86_64
license = BSD
@@ -16,12 +16,10 @@ pkgbase = toggldesktop
depends = jsoncpp
conflicts = toggldesktop-bin
conflicts = toggl-bin
- source = toggldesktop-7.4.347.tar.gz::https://github.com/toggl/toggldesktop/archive/v7.4.347.tar.gz
- source = production.patch
+ source = toggldesktop-7.4.410.tar.gz::https://github.com/toggl/toggldesktop/archive/v7.4.410.tar.gz
source = jsoncpp.patch
- sha512sums = d6dbbef0039f9f4b0e5a560d716cb1dcfb9e4d7bb2b590b89269e3cc1625a0e58ab73bbc5a8df852e420f6422aa031b47df5b6a3bf12e01fb07d5a4aca92a09e
- sha512sums = 90ed77b0c2b6708c256e5f8fd74d37275cd85ccb81b6eeffa96f6adb22441b853386d6b16a157522d77820a032daf044917d2fb885a15502d218e3e48458e75a
- sha512sums = 1b340bf5df760c47b0a8c7ba46c783ed2821ef4336d350a346782e74f0308ec96d350a6fe7acee59441f24b42ee55904095beba1162ac49de6418a7cfd139e63
+ sha512sums = add33909555e105f64793247476e4a2898a21d1aeaf6213dbb37db8a231a8b3c6502a1881b6e8947482256cdff68ca99a4ec48f9ea8528995ace6c1379b62cb0
+ sha512sums = 05813df185163e1361d99cf24291bd44bdfefeee050b56f2923fb909c2c57d532e0a459cdaea96504ed10d27004fe3ee9f3c34ec35bcc9f9f2e064cccd8cfe77
pkgname = toggldesktop
diff --git a/PKGBUILD b/PKGBUILD
index 28be49cc4d23..bf118b8a926d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: phi-mah
pkgname=toggldesktop
-pkgver=7.4.347
-pkgrel=2
+pkgver=7.4.410
+pkgrel=1
pkgdesc="Toggl time tracking software"
arch=('x86_64')
url="https://github.com/toggl/toggldesktop"
@@ -21,28 +21,28 @@ depends=('libxss'
)
makedepends=('cmake')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/toggl/toggldesktop/archive/v${pkgver}.tar.gz"
- "production.patch"
- 'jsoncpp.patch')
+ "jsoncpp.patch")
-sha512sums=('d6dbbef0039f9f4b0e5a560d716cb1dcfb9e4d7bb2b590b89269e3cc1625a0e58ab73bbc5a8df852e420f6422aa031b47df5b6a3bf12e01fb07d5a4aca92a09e'
- '90ed77b0c2b6708c256e5f8fd74d37275cd85ccb81b6eeffa96f6adb22441b853386d6b16a157522d77820a032daf044917d2fb885a15502d218e3e48458e75a'
- '1b340bf5df760c47b0a8c7ba46c783ed2821ef4336d350a346782e74f0308ec96d350a6fe7acee59441f24b42ee55904095beba1162ac49de6418a7cfd139e63')
+sha512sums=('add33909555e105f64793247476e4a2898a21d1aeaf6213dbb37db8a231a8b3c6502a1881b6e8947482256cdff68ca99a4ec48f9ea8528995ace6c1379b62cb0'
+ '05813df185163e1361d99cf24291bd44bdfefeee050b56f2923fb909c2c57d532e0a459cdaea96504ed10d27004fe3ee9f3c34ec35bcc9f9f2e064cccd8cfe77')
conflicts=('toggldesktop-bin' 'toggl-bin')
prepare() {
cd "${pkgname}-${pkgver}"
- # patch to build for production
- # https://github.com/toggl/toggldesktop/wiki/Building-Toggl-Desktop-from-source-for-usage-with-live-servers
- patch -p1 < ../production.patch
+ # patch to build
patch -p1 < ../jsoncpp.patch
}
build() {
mkdir -p build
cd build
- cmake ../${pkgname}-${pkgver} -DCMAKE_INSTALL_PREFIX=/usr -DTOGGL_PRODUCTION_BUILD=ON
+ cmake ../${pkgname}-${pkgver}\
+ -DCMAKE_INSTALL_PREFIX=/usr\
+ -DTOGGL_PRODUCTION_BUILD=ON\
+ -DTOGGL_ALLOW_UPDATE_CHECK=OFF\
+ -DUSE_BUNDLED_LIBRARIES=OFF
make
}
diff --git a/jsoncpp.patch b/jsoncpp.patch
index ba3c96917f7d..3c4cddc830a2 100644
--- a/jsoncpp.patch
+++ b/jsoncpp.patch
@@ -2,13 +2,17 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
index b52dbb3..f278060 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -36,7 +36,8 @@ if(NOT USE_BUNDLED_LIBRARIES)
+@@ -37,10 +37,9 @@
include_directories(${LUA_INCLUDE_DIRS})
# Look for JSON
- find_package(jsoncpp CONFIG)
+- if(jsoncpp_FOUND)
+- set(JSONCPP_LIBRARIES jsoncpp_lib)
+- endif()
+ pkg_search_module(jsoncpp jsoncpp)
+ include_directories(${jsoncpp_INCLUDE_DIRS})
++ set(JSONCPP_LIBRARIES ${jsoncpp_LIBRARIES})
# Look for Qxt
pkg_search_module(QXT_CORE QxtCore-qt5)
diff --git a/production.patch b/production.patch
deleted file mode 100644
index 90a7325d878b..000000000000
--- a/production.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff --git a/src/context.cc b/src/context.cc
-index 7c9f0fb..8d839ab 100644
---- a/src/context.cc
-+++ b/src/context.cc
-@@ -76,7 +76,7 @@ Context::Context(const std::string app_name, const std::string app_version)
- , idle_(&ui_)
- , last_sync_started_(0)
- , sync_interval_seconds_(0)
--, update_check_disabled_(false)
-+, update_check_disabled_(true)
- , trigger_sync_(false)
- , trigger_push_(false)
- , quit_(false)
-@@ -92,9 +92,6 @@ Context::Context(const std::string app_name, const std::string app_version)
- Poco::Net::HTTPSStreamFactory::registerFactory();
- }
-
-- urls::SetUseStagingAsBackend(
-- app_version.find("7.0.0") != std::string::npos);
--
- Poco::ErrorHandler::set(&error_handler_);
- Poco::Net::initializeSSL();
-
-diff --git a/src/ui/linux/TogglDesktop/TogglDesktop.pro b/src/ui/linux/TogglDesktop/TogglDesktop.pro
-index 4bbf84b..cf44f8e 100644
---- a/src/ui/linux/TogglDesktop/TogglDesktop.pro
-+++ b/src/ui/linux/TogglDesktop/TogglDesktop.pro
-@@ -8,7 +8,7 @@ VERSION = 7.0.0
-
- DEFINES += APP_VERSION=\\\"$$VERSION\\\"
-
--ENVIRONMENT = "development"
-+ENVIRONMENT = "production"
-
- DEFINES += APP_ENVIRONMENT=\\\"$$ENVIRONMENT\\\"
-