summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2020-01-12 22:18:05 +0100
committerFabioLolix2020-01-12 22:18:05 +0100
commitc35f8189220eb0e94b2601d948df79152f128c96 (patch)
treec10b836e5df9d0fbd759cf900693e422d0a86c9e
parent9818900713f64d034701c15b2bad10508d544cea (diff)
downloadaur-c35f8189220eb0e94b2601d948df79152f128c96.tar.gz
revision
-rwxr-xr-x.SRCINFO23
-rw-r--r--[-rwxr-xr-x]PKGBUILD50
2 files changed, 36 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb12b4731696..7b843ea66115 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,27 @@
pkgbase = torrential-git
pkgdesc = Download torrents in style with this speedy, minimalist torrent client designed for Pantheon Shell
- pkgver = r219.465f834
+ pkgver = 1.1.0.r15.gd950ce8
pkgrel = 1
url = https://github.com/davidmhewitt/torrential
arch = i686
arch = x86_64
- license = GPL3
- makedepends = cmake
- makedepends = vala
+ license = GPL2
makedepends = git
- depends = gtk3
- depends = granite
- depends = curl
- depends = libb64
+ makedepends = cmake
+ makedepends = vala-0.42
+ depends = libgranite.so
+ depends = libunity
depends = libevent
depends = libnatpmp
- depends = libunity
- depends = libtransmission
- depends = libutp-git
+ depends = libb64
+ depends = dht
depends = miniupnpc
- depends = openssl
+ depends = libutp
provides = torrential
conflicts = torrential
source = git+https://github.com/davidmhewitt/torrential.git
+ source = torrential-transmission::git+https://github.com/davidmhewitt/transmission.git#branch=2.9x-torrential
+ md5sums = SKIP
md5sums = SKIP
pkgname = torrential-git
diff --git a/PKGBUILD b/PKGBUILD
index 946544facbe9..beb33f1c26f4 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,38 @@
-# Maintainer: Helder Bertoldo <helder.bertoldo@gmail.com>
-# Contributor:
+# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Helder Bertoldo <helder.bertoldo@gmail.com>
-_gitname=torrential
-_author=davidmhewitt
-pkgname=("${_gitname}-git")
-pkgver=r219.465f834
+pkgname=torrential-git
+pkgver=1.1.0.r15.gd950ce8
pkgrel=1
pkgdesc="Download torrents in style with this speedy, minimalist torrent client designed for Pantheon Shell"
-arch=('i686' 'x86_64')
-url="https://github.com/${_author}/${_gitname}"
-license=('GPL3')
-depends=('gtk3' 'granite' 'curl' 'libb64' 'libevent' 'libnatpmp' 'libunity'
- 'libtransmission' 'libutp-git' 'miniupnpc' 'openssl')
-optdepends=()
-makedepends=('cmake' 'vala' 'git')
-provides=("${_gitname}")
-conflicts=("${_gitname}")
-source=("git+${url}.git")
-md5sums=('SKIP')
+arch=(i686 x86_64)
+url="https://github.com/davidmhewitt/torrential"
+license=(GPL2)
+depends=(libgranite.so libunity libevent libnatpmp libb64 dht miniupnpc libutp)
+makedepends=(git cmake vala-0.42)
+provides=(torrential)
+conflicts=(torrential)
+source=("git+https://github.com/davidmhewitt/torrential.git"
+ "torrential-transmission::git+https://github.com/davidmhewitt/transmission.git#branch=2.9x-torrential")
+md5sums=('SKIP'
+ 'SKIP')
pkgver() {
- cd "${_gitname}"
- ( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+ cd "${pkgname%-git}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "${_gitname}"
+ cd "${pkgname%-git}"
+ git submodule init
+ git config 'submodule.transmission.url' "${srcdir}/torrential-transmission"
+ git submodule update
+
install -d build
}
build() {
- cd "${_gitname}/build"
+ cd "${pkgname%-git}/build"
cmake .. \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr
@@ -41,7 +40,8 @@ build() {
}
package() {
- cd "${_gitname}/build"
+ cd "${pkgname%-git}/build"
make DESTDIR="${pkgdir}" install
+ ln -s /usr/bin/com.github.davidmhewitt.torrential "$pkgdir/usr/bin/torrential"
}