summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Witschel2020-07-23 15:45:50 +0200
committerJonas Witschel2020-07-23 15:45:50 +0200
commita728e259175389ba06f56a76fc3dfa84422cd7eb (patch)
treef29a9cc0af6cd9325a49ac67a57c04e4ecb9a674
parentcd36bd1f10a9ffa0658b40cbfd39f73c4ddc556a (diff)
downloadaur-a728e259175389ba06f56a76fc3dfa84422cd7eb.tar.gz
upgpkg: tpm2-abrmd-git 2.3.2.r11.78ba8ea-1: add libdepends
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c20c65cbd1e4..5d994225edb4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,9 +11,12 @@ pkgbase = tpm2-abrmd-git
makedepends = git
makedepends = autoconf-archive
makedepends = python
- depends = dbus
depends = glib2
depends = tpm2-tss
+ depends = libtss2-mu.so
+ depends = libtss2-rc.so
+ depends = libtss2-sys.so
+ depends = libtss2-tctildr.so
provides = tpm2-abrmd
conflicts = tpm2-abrmd
source = git+https://github.com/tpm2-software/tpm2-abrmd.git
diff --git a/PKGBUILD b/PKGBUILD
index 6a63cbfdc60a..d67a8e5c179c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgdesc='Trusted Platform Module 2.0 Access Broker and Resource Management Daemo
arch=('x86_64')
url='https://github.com/tpm2-software/tpm2-abrmd'
license=('BSD')
-depends=('dbus' 'glib2' 'tpm2-tss')
+depends=('glib2' 'tpm2-tss' 'libtss2-mu.so' 'libtss2-rc.so' 'libtss2-sys.so' 'libtss2-tctildr.so')
makedepends=('git' 'autoconf-archive' 'python')
checkdepends=('cmocka' 'ibm-sw-tpm2' 'iproute2')
provides=("${pkgname%-git}")
@@ -27,11 +27,10 @@ prepare () {
build() {
cd "${pkgname%-git}"
- (( CHECKFUNC )) && _opts=('--enable-unit' '--enable-integration')
./configure --prefix=/usr \
--sbindir=/usr/bin \
--with-dbuspolicydir=/usr/share/dbus-1/system.d \
- "${_opts[@]}"
+ $( ((CHECKFUNC)) && echo --enable-unit --enable-integration)
make
}