summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Theodorou2022-04-30 00:56:41 +0200
committerAngelo Theodorou2022-04-30 00:56:41 +0200
commit53d783b1c8f89985746ad2f7bd1da684285325f3 (patch)
tree9b65e6ed1fb8f17b5b27e7d238a74f7f48a2d1b0
parentb10fc554c6d524bfae55a087a72be8a88f46cb22 (diff)
downloadaur-53d783b1c8f89985746ad2f7bd1da684285325f3.tar.gz
Update to v0.8.1
- Use upstream XDG Desktop entry, trace file MIME type, and icon - Delete supplied XDG Desktop entry, trace file MIME type, and icon
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD20
-rw-r--r--application-tracy.svg35
-rw-r--r--application-tracy.xml13
-rw-r--r--tracy.desktop13
5 files changed, 11 insertions, 82 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c8395b9e3eeb..fa64537b7caf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tracy
pkgdesc = Real-time, nanosecond resolution frame profiler
- pkgver = 0.8
- pkgrel = 3
+ pkgver = 0.8.1
+ pkgrel = 1
url = https://github.com/wolfpld/tracy
arch = i686
arch = x86_64
@@ -14,13 +14,7 @@ pkgbase = tracy
depends = capstone
provides = tracy
conflicts = tracy
- source = git+https://github.com/wolfpld/tracy#tag=v0.8
- source = tracy.desktop
- source = application-tracy.xml
- source = application-tracy.svg
+ source = git+https://github.com/wolfpld/tracy#tag=v0.8.1
sha256sums = SKIP
- sha256sums = d3e0e3433e10a154ed38103a98600585a20ac49212f53370b2ead89971f47652
- sha256sums = f814d8f15a25b0014ca5781ae2b8941326c9f1e777d61368ec4c5128f3ddefcb
- sha256sums = 2f65177164c7601aef7b204d12c9e8dd94930056472d8f22d14339072cc6c8fb
pkgname = tracy
diff --git a/PKGBUILD b/PKGBUILD
index 61bf86e50272..7462279cffc9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Maintainer: Angelo Theodorou <encelo at gmail dot com>
pkgname=tracy
-pkgver=0.8
-pkgrel=3
+pkgver=0.8.1
+pkgrel=1
pkgdesc="Real-time, nanosecond resolution frame profiler"
arch=('i686' 'x86_64')
url="https://github.com/wolfpld/tracy"
@@ -12,12 +12,8 @@ depends=('glfw-x11' 'gtk3' 'intel-tbb' 'capstone')
makedepends=('pkgconf' 'git')
provides=('tracy')
conflicts=('tracy')
-source=("git+$url#tag=v$pkgver" "tracy.desktop" "application-tracy.xml" "application-tracy.svg")
-sha256sums=('SKIP'
- 'd3e0e3433e10a154ed38103a98600585a20ac49212f53370b2ead89971f47652'
- 'f814d8f15a25b0014ca5781ae2b8941326c9f1e777d61368ec4c5128f3ddefcb'
- '2f65177164c7601aef7b204d12c9e8dd94930056472d8f22d14339072cc6c8fb')
-
+source=("git+$url#tag=v$pkgver")
+sha256sums=('SKIP')
build() {
cd tracy
@@ -27,14 +23,14 @@ build() {
}
package() {
- install -Dm644 tracy.desktop $pkgdir/usr/share/applications/tracy.desktop
- install -Dm644 application-tracy.xml $pkgdir//usr/share/mime/packages/application-tracy.xml
- install -Dm644 application-tracy.svg $pkgdir/usr/share/icons/hicolor/scalable/apps/application-tracy.svg
-
cd tracy
install -Dm755 profiler/build/unix/Tracy-release $pkgdir/usr/bin/tracy
install -Dm755 update/build/unix/update-release $pkgdir/usr/bin/tracy-update
install -Dm755 capture/build/unix/capture-release $pkgdir/usr/bin/tracy-capture
+
install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 extra/desktop/tracy.desktop $pkgdir/usr/share/applications/tracy.desktop
install -Dm644 icon/icon.svg $pkgdir/usr/share/icons/hicolor/scalable/apps/tracy.svg
+ install -Dm644 extra/desktop/application-tracy.xml $pkgdir//usr/share/mime/packages/application-tracy.xml
+ install -Dm644 icon/application-tracy.svg $pkgdir/usr/share/icons/hicolor/scalable/apps/application-tracy.svg
}
diff --git a/application-tracy.svg b/application-tracy.svg
deleted file mode 100644
index 5f945b571698..000000000000
--- a/application-tracy.svg
+++ /dev/null
@@ -1,35 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!-- Created with Inkscape (http://www.inkscape.org/) -->
-<svg id="svg2331" width="135.47mm" height="135.47mm" version="1.1" viewBox="0 0 135.47 135.47" xmlns="http://www.w3.org/2000/svg">
- <defs id="defs2328">
- <filter id="filter16020" x="-.013633" y="-.010717" width="1.0273" height="1.0214" color-interpolation-filters="sRGB">
- <feGaussianBlur id="feGaussianBlur16022" stdDeviation="2.0004419"/>
- </filter>
- </defs>
- <g id="layer1" transform="translate(-15.03 -32.374)">
- <g id="use2061" transform="matrix(1.0583 0 0 1.0583 15.03 -2340.4)" enable-background="new" stroke-width=".25">
- <title id="title2018">text-x-preview</title>
- <g id="g2068">
- <g id="g2030" transform="matrix(.25 0 0 .25 0 2295)" stroke-width=".25">
- <g id="g2026" stroke-width=".25">
- <path id="path2020" d="m111.83-178.55h200l120.17 119.67 5e-3 296.24c3.1e-4 17.728-14.449 32.088-32.177 32.088h-288c-17.728 0-32-14.272-32-32v-384c0-17.728 14.272-32 32-32z" enable-background="new" filter="url(#filter16020)" opacity=".4"/>
- <path id="path2022" d="m111.83-179.67h200l120.17 119.67 5e-3 296.24c3.1e-4 17.728-14.449 32.088-32.177 32.088h-288c-17.728 0-32-14.272-32-32v-384c0-17.728 14.272-32 32-32z" enable-background="new" fill="#f6f5f4"/>
- <path id="path2024" d="m311.83-179.67v88c0 17.728 14.442 31.694 32.17 31.694l88.001-0.022223z" enable-background="new" fill="#deddda"/>
- </g>
- </g>
- <rect id="rect2032" x="-1.5e-6" y="2242" width="128" height="128" enable-background="new" fill="none" style="paint-order:normal"/>
- </g>
- </g>
- <g id="g1223" transform="matrix(.17198 0 0 .17198 -155.61 392.08)" enable-background="new">
- <rect id="rect3988" x="1218.9" y="-1801.1" width="340.16" height="340.16" rx="2" ry="5.3723e-6" fill="#d6e4ff" stroke="#000" stroke-width="15.118" style="paint-order:normal"/>
- <g id="g4861" transform="matrix(3.7795 0 0 3.7795 1200 -2572.1)" fill="#006ed6" stroke="#004586">
- <rect id="rect4803" x="15" y="217" width="70" height="10" rx=".52917" ry="1.4214e-6" style="paint-order:normal"/>
- <rect id="rect4803-8" x="38" y="228" width="24" height="10" rx=".52917" ry="1.4214e-6" style="paint-order:normal"/>
- <rect id="rect4803-8-0" x="39" y="239" width="22" height="10" rx=".52917" ry="1.4214e-6" style="paint-order:normal"/>
- <rect id="rect4803-8-7" x="40" y="250" width="20" height="10" rx=".52917" ry="1.4214e-6" style="paint-order:normal"/>
- <rect id="rect4803-8-77" x="41" y="261" width="18" height="10" rx=".52917" ry="1.4214e-6" style="paint-order:normal"/>
- <rect id="rect4803-8-1" x="42" y="272" width="16" height="10" rx=".52917" ry="1.4214e-6" style="paint-order:normal"/>
- </g>
- </g>
- </g>
-</svg>
diff --git a/application-tracy.xml b/application-tracy.xml
deleted file mode 100644
index 3ca6cd848ff3..000000000000
--- a/application-tracy.xml
+++ /dev/null
@@ -1,13 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
- <mime-type type="application/tracy">
- <comment>Tracy Profiler trace file</comment>
- <comment xml:lang="pl">Zrzut sesji profilera Tracy</comment>
- <icon name="application-tracy"/>
- <magic>
- <match type="string" value="tlZ\x04" offset="0"/>
- <match type="string" value="tZst" offset="0"/>
- </magic>
- <glob pattern="*.tracy"/>
- </mime-type>
-</mime-info>
diff --git a/tracy.desktop b/tracy.desktop
deleted file mode 100644
index 0604e219e1ef..000000000000
--- a/tracy.desktop
+++ /dev/null
@@ -1,13 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Type=Application
-Name=Tracy Profiler
-GenericName=Code profiler
-GenericName[pl]=Profiler kodu
-Comment=Examine code to see where it is slow
-Comment[pl]=Znajdowanie wolno wykonującego się kodu
-Exec=/usr/bin/tracy %f
-Icon=tracy
-Terminal=false
-Categories=Development;Profiling;
-MimeType=application/tracy;