summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Theodorou2018-12-19 21:49:55 +0000
committerAngelo Theodorou2018-12-19 21:51:32 +0000
commit6accff58ef65ccc649e2d283a824e53a13ddfae2 (patch)
treeb0d391970936bae0cc7d8d7cd89986068177a55e
parent82c03f8eb9285769d854811a2f68441ad7aaca85 (diff)
downloadaur-6accff58ef65ccc649e2d283a824e53a13ddfae2.tar.gz
Initial import of the Tracy frame profiler at v0.4
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD48
2 files changed, 29 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1e8b10a5c9f7..b27f0a5e5313 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
-# Generated by mksrcinfo v8
-# Tue Sep 27 11:03:45 UTC 2016
pkgbase = tracy
- pkgdesc = A system call tracer and injector
- pkgver = 0.08
+ pkgdesc = Real-time, nanosecond resolution frame profiler
+ pkgver = 0.4
pkgrel = 1
- url = http://hetgrotebos.org/wiki/Tracy
+ url = https://bitbucket.org/wolfpld/tracy
arch = i686
arch = x86_64
license = BSD
- optdepends = python
- source = https://github.com/MerlijnWajer/tracy/archive/tracy-0.08.tar.gz
- md5sums = 546ec78803e83697b1330190da7ce42c
+ depends = glfw-x11
+ depends = gtk2
+ provides = tracy
+ conflicts = tracy
+ source = git+https://bitbucket.org/wolfpld/tracy#tag=v0.4
+ md5sums = SKIP
pkgname = tracy
diff --git a/PKGBUILD b/PKGBUILD
index c63634371e95..b733c416200f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,30 @@
-# Maintainer: Daichi Shinozaki <dsdseg@gmail.com>
+# Maintainer: Angelo Theodorou <encelo at gmail dot com>
+
pkgname=tracy
-pkgver=0.08
+pkgver=0.4
pkgrel=1
-pkgdesc="A system call tracer and injector"
+pkgdesc="Real-time, nanosecond resolution frame profiler"
arch=('i686' 'x86_64')
-url="http://hetgrotebos.org/wiki/Tracy"
+url="https://bitbucket.org/wolfpld/tracy"
license=('BSD')
-optdepends=(python)
-source=("https://github.com/MerlijnWajer/tracy/archive/$pkgname-$pkgver.tar.gz"
-)
-md5sums=('546ec78803e83697b1330190da7ce42c')
+depends=('glfw-x11' 'gtk2')
+makdepends=('pkgconf')
+provides=('tracy')
+conflicts=('tracy')
+source=("git+$url#tag=v0.4")
+md5sums=('SKIP')
build() {
- cd "$srcdir/$pkgname-$pkgname-$pkgver/src"
- make
- cd ./soxy
- make
-}
-
-check() {
- cd "$srcdir/$pkgname-$pkgname-$pkgver/src"
- make tests
+ cd tracy
+ make -C profiler/build/unix release
+ make -C update/build/unix release
+ make -C capture/build/unix release
}
-
package() {
- cd "$srcdir/$pkgname-$pkgname-$pkgver/src"
- for ext in a so; do
- install -Dm644 lib"$pkgname.$ext" "$pkgdir/usr/lib/lib$pkgname.$ext"
- done
- install -Dm644 tracy.h "$pkgdir"/usr/include/tracy.h
- install -Dm755 soxy/soxy "$pkgdir"/usr/bin/soxy
- mkdir -p $pkgdir/usr/lib/python3.4/site-packages/$pkgname
- install -Dm644 *.py $pkgdir/usr/lib/python3.4/site-packages/$pkgname/
+ cd tracy
+ install -Dm755 profiler/build/unix/Tracy-release $pkgdir/usr/bin/tracy
+ install -Dm755 update/build/unix/update-release $pkgdir/usr/bin/tracy-update
+ install -Dm755 capture/build/unix/capture-release $pkgdir/usr/bin/tracy-capture
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
}
-
-# vim:set ts=2 sw=2 et: