summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Theodorou2022-04-14 00:12:26 +0200
committerAngelo Theodorou2022-04-14 00:12:26 +0200
commit8171fbc1dfa0c26483a150f234a6c8b3c57a08ad (patch)
treed36e2a5ae0edca23b3923a26ba47eae0548c500b
parent0da1a7bd618458c3c8bb73da3c85cc8c022135e1 (diff)
downloadaur-8171fbc1dfa0c26483a150f234a6c8b3c57a08ad.tar.gz
Install the official XDG Desktop entry from GitHub
- Install the SVG version of the icon
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--tracy.desktop10
3 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 296821667363..bb69b2fa1de7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tracy
pkgdesc = Real-time, nanosecond resolution frame profiler
pkgver = 0.8
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/wolfpld/tracy
arch = i686
arch = x86_64
@@ -17,6 +17,6 @@ pkgbase = tracy
source = git+https://github.com/wolfpld/tracy#tag=v0.8
source = tracy.desktop
sha256sums = SKIP
- sha256sums = d70322648a10aacab4b471fa657ae57bf477ac98c77383d1a8491b3aa5a1c907
+ sha256sums = d3e0e3433e10a154ed38103a98600585a20ac49212f53370b2ead89971f47652
pkgname = tracy
diff --git a/PKGBUILD b/PKGBUILD
index 3512207e877e..965001c53402 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=tracy
pkgver=0.8
-pkgrel=1
+pkgrel=2
pkgdesc="Real-time, nanosecond resolution frame profiler"
arch=('i686' 'x86_64')
url="https://github.com/wolfpld/tracy"
@@ -13,7 +13,7 @@ makedepends=('pkgconf' 'git')
provides=('tracy')
conflicts=('tracy')
source=("git+$url#tag=v$pkgver" "tracy.desktop")
-sha256sums=('SKIP' 'd70322648a10aacab4b471fa657ae57bf477ac98c77383d1a8491b3aa5a1c907')
+sha256sums=('SKIP' 'd3e0e3433e10a154ed38103a98600585a20ac49212f53370b2ead89971f47652')
build() {
cd tracy
@@ -30,5 +30,5 @@ package() {
install -Dm755 update/build/unix/update-release $pkgdir/usr/bin/tracy-update
install -Dm755 capture/build/unix/capture-release $pkgdir/usr/bin/tracy-capture
install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
- install -Dm644 icon/icon.png $pkgdir/usr/share/icons/hicolor/256x256/apps/tracy.png
+ install -Dm644 icon/icon.svg $pkgdir/usr/share/icons/hicolor/scalable/apps/tracy.svg
}
diff --git a/tracy.desktop b/tracy.desktop
index ce34cf729ead..0604e219e1ef 100644
--- a/tracy.desktop
+++ b/tracy.desktop
@@ -2,8 +2,12 @@
Version=1.0
Type=Application
Name=Tracy Profiler
-Exec=/usr/bin/tracy
+GenericName=Code profiler
+GenericName[pl]=Profiler kodu
+Comment=Examine code to see where it is slow
+Comment[pl]=Znajdowanie wolno wykonującego się kodu
+Exec=/usr/bin/tracy %f
Icon=tracy
Terminal=false
-StartupNotify=true
-StartupWMClass=tracy
+Categories=Development;Profiling;
+MimeType=application/tracy;