summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOSAMC2022-11-20 18:03:24 +0000
committerChristopher Arndt2022-11-20 18:03:24 +0000
commitd1672b1ab863313a54b13be2a51d81ca95637d8f (patch)
tree0d1ca2f9a738bdaf023db8db01b770343faa16ff
parent9b8883c16ab6a1599ddfd82fcb516d24fc83cfca (diff)
downloadaur-triceratops.tar.gz
feat: sync package 'triceratops' with AUR (#157)
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD28
-rw-r--r--triceratops-gui-instantiate.patch13
-rw-r--r--triceratops-remove-printf.patch12
-rw-r--r--triceratops-symbol-visibility.patch14
6 files changed, 71 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43722120e35a..d7456142509b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = triceratops
pkgdesc = Polyphonic synthesizer LV2 plugin
pkgver = 0.5.0
- pkgrel = 1
+ pkgrel = 2
url = https://sourceforge.net/projects/triceratops/
arch = aarch64
arch = x86_64
@@ -16,8 +16,14 @@ pkgbase = triceratops
provides = triceratops.lv2
conflicts = triceratops.lv2
source = https://downloads.sourceforge.net/project/triceratops/triceratops_v0.5.0_Oct_2022.tar.gz
+ source = triceratops-gui-instantiate.patch
+ source = triceratops-remove-printf.patch
+ source = triceratops-symbol-visibility.patch
source = triceratops-ttl.patch
sha256sums = 93b2d74bb611fc3a26c2060ba678656b89d7ddba5b9e31e27a5758ec9924596e
+ sha256sums = c2442694fbde36782d419e5d2e6c61b9b61eaaa4f464e7b3895a555c731ad9fc
+ sha256sums = 316e46bfe6c18aa2032fd66fa9a95b32a8b657a8e4b0b3c77246d44942bc8e75
+ sha256sums = 7f993a07d1e32876e49f2477b17c2349e886864ae694d0035f4e000f53d1cc9d
sha256sums = 1083b10d0a004b3dd39afe37f6385d815e7cfdd26078aa7bcf85e2fc24afc262
pkgname = triceratops
diff --git a/.gitignore b/.gitignore
index f53fcac353c8..57e7fd90984f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,4 @@
pkg/
src/
-triceratops-*.pkg.tar.*
-triceratops-*.pkg.tar.zst
-triceratops-*.src.tar.gz
-triceratops_*.tar.gz
+*.tar.*
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
index 3b1b761ca5b1..7c66104bdf9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_plugin_uri='http://nickbailey.co.nr/triceratops'
pkgname=triceratops
pkgver=0.5.0
-pkgrel=1
+pkgrel=2
pkgdesc='Polyphonic synthesizer LV2 plugin'
arch=(aarch64 x86_64)
url='https://sourceforge.net/projects/triceratops/'
@@ -18,17 +18,36 @@ optdepends=('lv2-host: for loading the LV2 plugin')
provides=($pkgname.lv2)
conflicts=($pkgname.lv2)
source=("https://downloads.sourceforge.net/project/triceratops/${pkgname}_v${pkgver}_Oct_2022.tar.gz"
+ 'triceratops-gui-instantiate.patch'
+ 'triceratops-remove-printf.patch'
+ 'triceratops-symbol-visibility.patch'
'triceratops-ttl.patch')
sha256sums=('93b2d74bb611fc3a26c2060ba678656b89d7ddba5b9e31e27a5758ec9924596e'
+ 'c2442694fbde36782d419e5d2e6c61b9b61eaaa4f464e7b3895a555c731ad9fc'
+ '316e46bfe6c18aa2032fd66fa9a95b32a8b657a8e4b0b3c77246d44942bc8e75'
+ '7f993a07d1e32876e49f2477b17c2349e886864ae694d0035f4e000f53d1cc9d'
'1083b10d0a004b3dd39afe37f6385d815e7cfdd26078aa7bcf85e2fc24afc262')
prepare() {
cd $pkgname
+ # Fix warning due to invalid type conversion in LV2UI_Handle instantiation
+ # https://github.com/thunderox/triceratops/pull/11
+ patch -p1 -N -r - -i "$srcdir"/triceratops-gui-instantiate.patch
+ # Remove left-over printf debugging statement in LV2 UI descriptor function
+ # https://github.com/thunderox/triceratops/pull/13
+ patch -p1 -N -r - -i "$srcdir"/triceratops-remove-printf.patch
+ # Don't export any symbols except LV2 descriptor
+ # https://github.com/thunderox/triceratops/pull/12
+ patch -p1 -N -r - -i "$srcdir"/triceratops-symbol-visibility.patch
+ # Fix lvlint errors and warnings
+ # https://sourceforge.net/p/triceratops/bugs/15/
patch -p1 -N -r - -i "$srcdir"/triceratops-ttl.patch
}
build() {
cd $pkgname
+ # Supress glib deprecation warnings about use of outdated types by GTK2
+ export CXXFLAGS="$CXXFLAGS -Wno-deprecated-declarations"
python waf configure --prefix=/usr
python waf
}
@@ -37,10 +56,9 @@ check() {
cd $pkgname
mkdir -p lv2
ln -sf ../build/$pkgname.lv2 lv2/$pkgname.lv2
- LV2_PATH="$PWD/lv2:/usr/lib/lv2" lv2lint \
- -s _Z* \
- -s minBLEP_table \
- -M pack \
+ LV2_PATH="$PWD/lv2:/usr/lib/lv2" lv2lint -M pack \
+ -s *_bss* \
+ -s __end__ \
"$_plugin_uri"
}
diff --git a/triceratops-gui-instantiate.patch b/triceratops-gui-instantiate.patch
new file mode 100644
index 000000000000..759ee392d798
--- /dev/null
+++ b/triceratops-gui-instantiate.patch
@@ -0,0 +1,13 @@
+diff --git a/triceratops_gui.cpp b/triceratops_gui.cpp
+index d91d3ff..5374164 100755
+--- a/triceratops_gui.cpp
++++ b/triceratops_gui.cpp
+@@ -312,7 +312,7 @@ static GtkWidget* make_gui(triceratopsGUI *self) {
+ }
+
+
+-static LV2UI_Handle instantiate(const struct _LV2UI_Descriptor * descriptor,
++static LV2UI_Handle instantiate(const struct LV2UI_Descriptor * descriptor,
+ const char * plugin_uri,
+ const char * bundle_path,
+ LV2UI_Write_Function write_function,
diff --git a/triceratops-remove-printf.patch b/triceratops-remove-printf.patch
new file mode 100644
index 000000000000..93b84997b10a
--- /dev/null
+++ b/triceratops-remove-printf.patch
@@ -0,0 +1,12 @@
+diff --git a/triceratops_gui.cpp b/triceratops_gui.cpp
+index d91d3ff..ccafc3b 100755
+--- a/triceratops_gui.cpp
++++ b/triceratops_gui.cpp
+@@ -893,7 +893,6 @@ static LV2UI_Descriptor descriptors[] = {
+ };
+
+ const LV2UI_Descriptor * lv2ui_descriptor(uint32_t index) {
+- printf("lv2ui_descriptor(%u) called\n", (unsigned int)index);
+ if (index >= sizeof(descriptors) / sizeof(descriptors[0])) {
+ return NULL;
+ }
diff --git a/triceratops-symbol-visibility.patch b/triceratops-symbol-visibility.patch
new file mode 100644
index 000000000000..51ce0c6f2382
--- /dev/null
+++ b/triceratops-symbol-visibility.patch
@@ -0,0 +1,14 @@
+diff --git a/wscript b/wscript
+index a8f4f22..a38d638 100644
+--- a/wscript
++++ b/wscript
+@@ -27,7 +27,8 @@ def configure(conf):
+ if conf.env['MSVC_COMPILER']:
+ conf.env.append_unique('CXXFLAGS', ['-TP', '-MD', '-g'])
+ else:
+- conf.env.append_unique('CXXFLAGS', ['-O2','-funroll-loops','-std=c++0x','-g'])
++ conf.env.append_unique('CXXFLAGS',
++ ['-O2', '-funroll-loops', '-fvisibility=hidden', '-std=c++0x', '-g'])
+
+ if sys.maxsize >= 9223372036854775807:
+ print("detected 64 bit architecture, enabling -fPIC")