summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Diehl2024-04-02 07:38:09 +0200
committerMartin Diehl2024-04-02 07:38:09 +0200
commitfb6891872a9ef3137cac7f268217d739abd1e3d1 (patch)
tree941772a8c17190b2fabf9821c7de9b1ab995b442
parent125309a4853448d823468d5af8be101cb9c2a696 (diff)
downloadaur-trilinos.tar.gz
15.1.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
-rw-r--r--compiler-errors.patch22
3 files changed, 8 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e422fa027c8..0bc382e5f7fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = trilinos
pkgdesc = algorithms for the solution of large-scale scientific problems
- pkgver = 15.0.0
- pkgrel = 3
+ pkgver = 15.1.1
+ pkgrel = 1
url = http://trilinos.org
arch = x86_64
license = LGPL3
@@ -23,9 +23,7 @@ pkgbase = trilinos
provides = trilinos-ml
provides = zoltan
provides = kokkos
- source = https://github.com/trilinos/Trilinos/archive/refs/tags/trilinos-release-15-0-0.tar.gz
- source = compiler-errors.patch
- sha512sums = a364e67686cdd4e1e34aa0e14b6cc051ed21a72b63719c47260d7839d47590b9e652be76cb9d61e513c7933b965fc8141c3ff898167e22353b33c9491a525c84
- sha512sums = cccd319861b33b9e809e6bee3a11f5f8604dbb765b9c074b0c02cb941231f621dc332eab58fcb07d4e291150be3372d0e58b4916de98b5a01b096a9ad5e5cfe8
+ source = https://github.com/trilinos/Trilinos/archive/refs/tags/trilinos-release-15-1-1.tar.gz
+ sha512sums = 5a1a7d321dd3b47fafe0422884d1a7bf6731d5ee806a4fd1bf31f179ca5d6f4290cda4515d0d7786024ea15c17e88422a9518370c5cfb32b4b44761de232e0de
pkgname = trilinos
diff --git a/PKGBUILD b/PKGBUILD
index 577342598a28..e87c7ab4b279 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,9 +5,9 @@
# Contributor: Simon Pintarelli <simon.pintarelli@gmail.com>
# Contributor: Feng Wang <wanng.fenng@gmail.com>
pkgname=trilinos
-pkgver=15.0.0
+pkgver=15.1.1
_pkgver=${pkgver//./-}
-pkgrel=3
+pkgrel=1
pkgdesc="algorithms for the solution of large-scale scientific problems"
arch=('x86_64')
url="http://trilinos.org"
@@ -16,14 +16,9 @@ depends=('python' 'lapack' 'boost' 'netcdf-openmpi' 'libmatio' 'libx11' 'hdf5-op
makedepends=('gcc-fortran' 'perl' 'blas' 'cmake' 'bc' 'python-numpy')
provides=('trilinos-sacado' 'trilinos-ml' 'zoltan' 'kokkos')
checkdepends=('cmake')
-source=("https://github.com/trilinos/Trilinos/archive/refs/tags/trilinos-release-$_pkgver.tar.gz"
- 'compiler-errors.patch')
-sha512sums=('a364e67686cdd4e1e34aa0e14b6cc051ed21a72b63719c47260d7839d47590b9e652be76cb9d61e513c7933b965fc8141c3ff898167e22353b33c9491a525c84'
- 'cccd319861b33b9e809e6bee3a11f5f8604dbb765b9c074b0c02cb941231f621dc332eab58fcb07d4e291150be3372d0e58b4916de98b5a01b096a9ad5e5cfe8')
+source=("https://github.com/trilinos/Trilinos/archive/refs/tags/trilinos-release-$_pkgver.tar.gz")
+sha512sums=('5a1a7d321dd3b47fafe0422884d1a7bf6731d5ee806a4fd1bf31f179ca5d6f4290cda4515d0d7786024ea15c17e88422a9518370c5cfb32b4b44761de232e0de')
-prepare() {
- patch -d Trilinos-trilinos-release-"$_pkgver" -p1 -i ../compiler-errors.patch
-}
build() {
cmake -S Trilinos-trilinos-release-"$_pkgver" \
diff --git a/compiler-errors.patch b/compiler-errors.patch
deleted file mode 100644
index 854bade6b4d8..000000000000
--- a/compiler-errors.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff --color -urt Trilinos-trilinos-release-14-0-0.orig/packages/krino/cmake/Dependencies.cmake Trilinos-trilinos-release-14-0-0.new/packages/krino/cmake/Dependencies.cmake
---- Trilinos-trilinos-release-14-0-0.orig/packages/krino/cmake/Dependencies.cmake 2023-05-18 08:34:11.085906271 +0200
-+++ Trilinos-trilinos-release-14-0-0.new/packages/krino/cmake/Dependencies.cmake 2023-05-18 08:29:48.930168370 +0200
-@@ -1,6 +1,6 @@
- SET(LIB_REQUIRED_DEP_PACKAGES SEACASIoss SEACASExodus SEACASAprepro STKBalance STKMath STKIO STKSearch STKTopology STKUtil STKTools STKEmend Percept Intrepid)
- SET(LIB_OPTIONAL_DEP_PACKAGES)
--SET(TEST_REQUIRED_DEP_PACKAGES Gtest STKUnit_test_utils)
-+SET(TEST_REQUIRED_DEP_PACKAGES Gtest)
- SET(TEST_OPTIONAL_DEP_PACKAGES)
- SET(LIB_REQUIRED_DEP_TPLS Boost)
- SET(LIB_OPTIONAL_DEP_TPLS MPI ParMETIS yaml-cpp)
-diff --color -urt Trilinos-trilinos-release-14-0-0.orig/packages/krino/krino/CMakeLists.txt Trilinos-trilinos-release-14-0-0.new/packages/krino/krino/CMakeLists.txt
---- Trilinos-trilinos-release-14-0-0.orig/packages/krino/krino/CMakeLists.txt 2023-05-18 08:34:11.085906271 +0200
-+++ Trilinos-trilinos-release-14-0-0.new/packages/krino/krino/CMakeLists.txt 2023-05-18 08:35:25.202277721 +0200
-@@ -4,7 +4,6 @@
- add_subdirectory(region)
- add_subdirectory(rebalance_utils)
- add_subdirectory(parser)
--add_subdirectory(unit_tests)
-
- SET(SOURCES_MAIN Apps_krino.cpp)
-