summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPetri Lehtinen2020-11-23 18:57:42 +0200
committerPetri Lehtinen2020-11-23 18:57:42 +0200
commit92f411ef5060271e48fd6f88c61114933432f5df (patch)
treea82d9c2239e266ef1c8dca53d134101deda68b32
downloadaur-triplane.tar.gz
1.08+sp2-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d832f9c79f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = triplane
+ pkgdesc = Classic side-scrolling dogfighting game featuring solo missions and multiplayer mode
+ pkgver = 1.08+sp2
+ pkgrel = 1
+ url = https://github.com/suomipelit/triplane
+ arch = x86_64
+ license = GPL
+ depends = sdl2
+ depends = sdl2_mixer
+ source = https://github.com/suomipelit/triplane/archive/aeff31106f94a31550f33daa41104e0681eee626.tar.gz
+ md5sums = 27bdb6493311695552988b571fc2e786
+
+pkgname = triplane
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..671810f75433
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Petri Lehtinen <petri@digip.org>
+pkgname=triplane
+_sprel=2
+_commit=aeff31106f94a31550f33daa41104e0681eee626
+pkgver=1.08+sp${_sprel}
+pkgrel=1
+pkgdesc="Classic side-scrolling dogfighting game featuring solo missions and multiplayer mode"
+arch=(x86_64)
+url="https://github.com/suomipelit/triplane"
+license=('GPL')
+depends=(sdl2 sdl2_mixer)
+source=("https://github.com/suomipelit/triplane/archive/${_commit}.tar.gz")
+md5sums=('27bdb6493311695552988b571fc2e786')
+
+build() {
+ cd "$pkgname-$_commit"
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_BUILD_TYPE=Release ..
+ make
+}
+
+package() {
+ cd "$pkgname-$_commit"
+ cd build
+ make DESTDIR="$pkgdir/" install
+}