summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormutantmonkey2020-11-28 15:52:20 -0800
committermutantmonkey2020-11-28 15:52:20 -0800
commit1a0e3658c840b2cbaaaa0bae39056d0ee5201ced (patch)
tree4f143b4e6789e1e2cca867a9555a3b4255eae855
parent4ada91a5855116ee6a4cabcf12f6cf197abdf5d4 (diff)
downloadaur-1a0e3658c840b2cbaaaa0bae39056d0ee5201ced.tar.gz
Fix trousers build
Upstream changes had broken a patch, and the tarball has double-nested directories for some reason.
-rw-r--r--.SRCINFO4
-rw-r--r--01-tss-user.patch6
-rw-r--r--PKGBUILD19
3 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 134713c0c893..cd914d70edda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,14 +15,12 @@ pkgbase = trousers
source = tcsd.service
source = 70-tpmd.rules
source = 01-tss-user.patch
- source = trousers-0.3.14-fno-common.patch
sha256sums = 1e5be93e518372acf1d92d2f567d01a46fdb0b730487e544e6fb896c59cac77f
sha256sums = 4c2684501e7a67132d4f53466b32fc06bd2a0275d4cf1fbd5479d0cdb2349bc7
sha256sums = 1afd455b6c17e730b2cc4ec71d5625f0b63fde54f9409ae4762dc6f084c194de
sha256sums = 653c3a94ec628e7a7fb150d0d289b0866c6b3bb9aa57af2c59724517d205d7bd
sha256sums = c50ea41a4809699dd50f2e621acc6baafb2dffa43cd5a0df8a0679f1d1b1b884
- sha256sums = 169cc2cbc3a8bce7fd76e0c96e5b04b5249a0db9e857b274a0c5da461bb604f7
- sha256sums = 770fd94510adb90605eb38745b62450a4cda25c2b8c9c6c8ea2e6043582d0e27
+ sha256sums = d6d2f72389ffc1f61c363d839de24ba7ebb9a6453d99ece151a65933ebb0235c
pkgname = trousers
diff --git a/01-tss-user.patch b/01-tss-user.patch
index 37f74617aa3a..7518b9ab4cf7 100644
--- a/01-tss-user.patch
+++ b/01-tss-user.patch
@@ -10,12 +10,12 @@ Index: trousers/dist/Makefile.am
--- trousers.orig/dist/Makefile.am
+++ trousers/dist/Makefile.am
@@ -3,24 +3,10 @@ EXTRA_DIST = system.data.auth system.dat
-
+
install: install-exec-hook
if test ! -e ${DESTDIR}/@sysconfdir@/tcsd.conf; then mkdir -p ${DESTDIR}/@sysconfdir@ && cp tcsd.conf ${DESTDIR}/@sysconfdir@; fi
-if !NOUSERCHECK
-- /bin/chown tss:tss ${DESTDIR}/@sysconfdir@/tcsd.conf || true
-- /bin/chmod 0600 ${DESTDIR}/@sysconfdir@/tcsd.conf
+- /bin/chown root:tss ${DESTDIR}/@sysconfdir@/tcsd.conf || true
+- /bin/chmod 0640 ${DESTDIR}/@sysconfdir@/tcsd.conf
-endif
install-exec-hook:
diff --git a/PKGBUILD b/PKGBUILD
index b48acc4d8684..1a108ebfcbd3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,27 +20,29 @@ source=("http://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgver
'tmpfiles.conf'
'tcsd.service'
'70-tpmd.rules'
- '01-tss-user.patch'
- 'trousers-0.3.14-fno-common.patch')
+ '01-tss-user.patch')
+# 'trousers-0.3.14-fno-common.patch')
noextract=("${pkgname}-${pkgver}.tar.gz")
sha256sums=('1e5be93e518372acf1d92d2f567d01a46fdb0b730487e544e6fb896c59cac77f'
'4c2684501e7a67132d4f53466b32fc06bd2a0275d4cf1fbd5479d0cdb2349bc7'
'1afd455b6c17e730b2cc4ec71d5625f0b63fde54f9409ae4762dc6f084c194de'
'653c3a94ec628e7a7fb150d0d289b0866c6b3bb9aa57af2c59724517d205d7bd'
'c50ea41a4809699dd50f2e621acc6baafb2dffa43cd5a0df8a0679f1d1b1b884'
- '169cc2cbc3a8bce7fd76e0c96e5b04b5249a0db9e857b274a0c5da461bb604f7'
- '770fd94510adb90605eb38745b62450a4cda25c2b8c9c6c8ea2e6043582d0e27')
+ 'd6d2f72389ffc1f61c363d839de24ba7ebb9a6453d99ece151a65933ebb0235c')
+# '770fd94510adb90605eb38745b62450a4cda25c2b8c9c6c8ea2e6043582d0e27')
prepare() {
mkdir -p ${pkgname}-${pkgver}
bsdtar -x -f ${pkgname}-${pkgver}.tar.gz -C ${pkgname}-${pkgver}
- cd ${pkgname}-${pkgver}
+ # this is not a typo; the trousers devs released the tarball like this
+ cd ${pkgname}-${pkgver}/${pkgname}-${pkgver}
patch -p1 -i ${srcdir}/01-tss-user.patch
- patch -p1 -i ${srcdir}/trousers-0.3.14-fno-common.patch
+ #patch -p1 -i ${srcdir}/trousers-0.3.14-fno-common.patch
}
build() {
- cd ${pkgname}-${pkgver}
+ # this is not a typo; the trousers devs released the tarball like this
+ cd ${pkgname}-${pkgver}/${pkgname}-${pkgver}
./bootstrap.sh
./configure --prefix=/usr \
--sysconfdir=/etc \
@@ -52,7 +54,8 @@ build() {
}
package() {
- cd ${pkgname}-${pkgver}
+ # this is not a typo; the trousers devs released the tarball like this
+ cd ${pkgname}-${pkgver}/${pkgname}-${pkgver}
make DESTDIR=${pkgdir} install
install -Dm644 ${srcdir}/tcsd.service ${pkgdir}/usr/lib/systemd/system/tcsd.service
install -Dm644 ${srcdir}/70-tpmd.rules ${pkgdir}/usr/lib/udev/rules.d/70-tpmd.rules