summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormutantmonkey2020-11-28 16:05:11 -0800
committermutantmonkey2020-11-28 16:05:11 -0800
commite4f73a9c0f32de03bb3b613194158b3bf5a6ac78 (patch)
tree617a5fe3a5097cfdf392f416a1fc334d3048921f
parent1a0e3658c840b2cbaaaa0bae39056d0ee5201ced (diff)
downloadaur-e4f73a9c0f32de03bb3b613194158b3bf5a6ac78.tar.gz
trousers: remove noextract workaround
Whoops, the double-nesting was actually my fault, so let's fix that.
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD12
2 files changed, 3 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd914d70edda..2f7c97deaa4b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,7 +7,6 @@ pkgbase = trousers
arch = x86_64
license = CPL
depends = openssl
- noextract = trousers-0.3.15.tar.gz
options = libtool
source = http://downloads.sourceforge.net/project/trousers/trousers/0.3.15/trousers-0.3.15.tar.gz
source = sysusers.conf
diff --git a/PKGBUILD b/PKGBUILD
index 1a108ebfcbd3..8eee99106c06 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,7 +22,6 @@ source=("http://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgver
'70-tpmd.rules'
'01-tss-user.patch')
# 'trousers-0.3.14-fno-common.patch')
-noextract=("${pkgname}-${pkgver}.tar.gz")
sha256sums=('1e5be93e518372acf1d92d2f567d01a46fdb0b730487e544e6fb896c59cac77f'
'4c2684501e7a67132d4f53466b32fc06bd2a0275d4cf1fbd5479d0cdb2349bc7'
'1afd455b6c17e730b2cc4ec71d5625f0b63fde54f9409ae4762dc6f084c194de'
@@ -32,17 +31,13 @@ sha256sums=('1e5be93e518372acf1d92d2f567d01a46fdb0b730487e544e6fb896c59cac77f'
# '770fd94510adb90605eb38745b62450a4cda25c2b8c9c6c8ea2e6043582d0e27')
prepare() {
- mkdir -p ${pkgname}-${pkgver}
- bsdtar -x -f ${pkgname}-${pkgver}.tar.gz -C ${pkgname}-${pkgver}
- # this is not a typo; the trousers devs released the tarball like this
- cd ${pkgname}-${pkgver}/${pkgname}-${pkgver}
+ cd ${pkgname}-${pkgver}
patch -p1 -i ${srcdir}/01-tss-user.patch
#patch -p1 -i ${srcdir}/trousers-0.3.14-fno-common.patch
}
build() {
- # this is not a typo; the trousers devs released the tarball like this
- cd ${pkgname}-${pkgver}/${pkgname}-${pkgver}
+ cd ${pkgname}-${pkgver}
./bootstrap.sh
./configure --prefix=/usr \
--sysconfdir=/etc \
@@ -54,8 +49,7 @@ build() {
}
package() {
- # this is not a typo; the trousers devs released the tarball like this
- cd ${pkgname}-${pkgver}/${pkgname}-${pkgver}
+ cd ${pkgname}-${pkgver}
make DESTDIR=${pkgdir} install
install -Dm644 ${srcdir}/tcsd.service ${pkgdir}/usr/lib/systemd/system/tcsd.service
install -Dm644 ${srcdir}/70-tpmd.rules ${pkgdir}/usr/lib/udev/rules.d/70-tpmd.rules