summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Schneider2016-04-18 14:38:54 +0200
committerPeter Schneider2016-04-18 14:38:54 +0200
commitc3c52e5c07645eb9e5dd2491b1d319b85dab648b (patch)
tree1edfa6e6298fd001514da2926597d439332320b8
downloadaur-trustedgrub2-git.tar.gz
Initial commit for trustedgrub2
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD63
-rw-r--r--grub.default48
3 files changed, 138 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..45c0754e872c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = trustedgrub2-git
+ pkgdesc = TPM enabled GRUB2 Bootloader
+ pkgver = r9387.6750c4e
+ pkgrel = 1
+ url = https://github.com/Sirrix-AG/TrustedGRUB2/
+ arch = x86
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = autogen
+ makedepends = autoconf
+ makedepends = automake
+ makedepends = gcc
+ makedepends = bison
+ makedepends = flex
+ provides = trustedgrub2
+ provides = grub
+ conflicts = trustedgrub2
+ conflicts = grub
+ replaces = grub
+ source = git+https://github.com/Sirrix-AG/TrustedGRUB2
+ source = grub.default
+ md5sums = SKIP
+ md5sums = 860933e5027697900a13e9b592cb4ca6
+
+pkgname = trustedgrub2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ae758af86d69
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer: Peter Schneider <e.at.chi.kaen@gmail.com>
+pkgname='trustedgrub2-git' # '-bzr', '-git', '-hg' or '-svn'
+pkgver=r9387.6750c4e
+pkgrel=1
+pkgdesc="TPM enabled GRUB2 Bootloader"
+arch=('x86' 'x86_64')
+url="https://github.com/Sirrix-AG/TrustedGRUB2/"
+license=('GPL')
+groups=()
+depends=()
+makedepends=('git' 'autogen' 'autoconf' 'automake' 'gcc' 'bison' 'flex') # 'bzr', 'git', 'mercurial' or 'subversion'
+provides=("${pkgname%-git}" "grub")
+conflicts=("${pkgname%-git}" "grub")
+replaces=("grub")
+backup=()
+options=()
+install=
+source=('git+https://github.com/Sirrix-AG/TrustedGRUB2'
+ 'grub.default')
+noextract=()
+md5sums=('SKIP'
+ '860933e5027697900a13e9b592cb4ca6')
+
+pkgver() {
+ cd "$srcdir/TrustedGRUB2"
+# Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/TrustedGRUB2"
+}
+
+build() {
+ cd "$srcdir/TrustedGRUB2"
+ ./autogen.sh
+ ./configure --prefix=/usr \
+ --bindir="/usr/bin" \
+ --sbindir="/usr/bin" \
+ --mandir="/usr/share/man" \
+ --infodir="/usr/share/info" \
+ --datarootdir="/usr/share" \
+ --sysconfdir="/etc" \
+ --with-bootdir="/boot" \
+ --with-grubdir="grub" \
+ --enable-grub-mkfont \
+ --enable-grub-mount \
+ --target=i386 -with-platform=pc
+ make CFLAGS+="-fno-stack-protector"
+}
+
+check() {
+ cd "$srcdir/TrustedGRUB2"
+ #make -k check CFLAGS+="-fno-stack-protector"
+}
+
+package() {
+ cd "$srcdir/TrustedGRUB2"
+ make DESTDIR="$pkgdir/" bashcompletiondir="/usr/share/bash-completion/completions" install
+ mkdir -p "${pkgdir}/usr/etc/default"
+ msg "Install /etc/default/grub (used by grub-mkconfig)"
+ install -D -m0644 "${srcdir}/grub.default" "${pkgdir}/etc/default/grub"
+}
diff --git a/grub.default b/grub.default
new file mode 100644
index 000000000000..5a73dd5d1c4a
--- /dev/null
+++ b/grub.default
@@ -0,0 +1,48 @@
+GRUB_DEFAULT=0
+GRUB_TIMEOUT=5
+GRUB_DISTRIBUTOR="Arch"
+GRUB_CMDLINE_LINUX_DEFAULT="quiet"
+GRUB_CMDLINE_LINUX=""
+GRUB_ENABLE_CRYPTODISK=y
+
+# Preload both GPT and MBR modules so that they are not missed
+GRUB_PRELOAD_MODULES="part_gpt part_msdos"
+
+# Uncomment to enable Hidden Menu, and optionally hide the timeout count
+#GRUB_HIDDEN_TIMEOUT=5
+#GRUB_HIDDEN_TIMEOUT_QUIET=true
+
+# Uncomment to use basic console
+GRUB_TERMINAL_INPUT=console
+
+# Uncomment to disable graphical terminal
+#GRUB_TERMINAL_OUTPUT=console
+
+# The resolution used on graphical terminal
+# note that you can use only modes which your graphic card supports via VBE
+# you can see them in real GRUB with the command `vbeinfo'
+GRUB_GFXMODE=auto
+
+# Uncomment to allow the kernel use the same resolution used by grub
+GRUB_GFXPAYLOAD_LINUX=keep
+
+# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
+# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
+#GRUB_DISABLE_LINUX_UUID=true
+
+# Uncomment to disable generation of recovery mode menu entries
+GRUB_DISABLE_RECOVERY=true
+
+# Uncomment and set to the desired menu colors. Used by normal and wallpaper
+# modes only. Entries specified as foreground/background.
+#GRUB_COLOR_NORMAL="light-blue/black"
+#GRUB_COLOR_HIGHLIGHT="light-cyan/blue"
+
+# Uncomment one of them for the gfx desired, a image background or a gfxtheme
+#GRUB_BACKGROUND="/path/to/wallpaper"
+#GRUB_THEME="/path/to/gfxtheme"
+
+# Uncomment to get a beep at GRUB start
+#GRUB_INIT_TUNE="480 440 1"
+
+#GRUB_SAVEDEFAULT="true"