summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSondre Nilsen2018-01-14 19:43:03 +0100
committerSondre Nilsen2018-01-14 19:43:03 +0100
commit8197c45858f86af8cbcf5c6c748cd0c1252106b9 (patch)
tree5bcad85a1f01261467811a63fda1732cf9080846
downloadaur-ttf-devicons.tar.gz
In the beginning there was darkness
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--MIT21
-rw-r--r--PKGBUILD20
4 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ece6df0c521e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ttf-devicons
+ pkgdesc = An iconic font for developers
+ pkgver = 1.8.0
+ pkgrel = 1
+ url = https://github.com/vorillaz/devicons
+ arch = any
+ license = MIT
+ depends = fontconfig
+ source = ttf-devicons-1.8.0.tar.gz::https://github.com/vorillaz/devicons/archive/1.8.0.tar.gz
+ source = MIT
+ sha256sums = d8d2dc243ca42897a082ffe32a22cab53cdd148cf87b24162cf450ccfc12fece
+ sha256sums = fd2b2a28ff7d4fbe6073edaf43ce6387430f10193a28fa09f893398463b8000b
+
+pkgname = ttf-devicons
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0c4fd0a40ca3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+*.xz
+*.gz
diff --git a/MIT b/MIT
new file mode 100644
index 000000000000..3878a6e849f1
--- /dev/null
+++ b/MIT
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2015 Theodore Vorillas
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b937de7d057
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+
+# Maintainer: Sondre Nilsen <nilsen.sondre@gmail.com>
+pkgname=ttf-devicons
+pkgver=1.8.0
+pkgrel=1
+pkgdesc="An iconic font for developers"
+arch=("any")
+url="https://github.com/vorillaz/devicons"
+license=("MIT")
+depends=("fontconfig")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/vorillaz/devicons/archive/${pkgver}.tar.gz"
+ "MIT")
+sha256sums=("d8d2dc243ca42897a082ffe32a22cab53cdd148cf87b24162cf450ccfc12fece"
+ "fd2b2a28ff7d4fbe6073edaf43ce6387430f10193a28fa09f893398463b8000b")
+
+package_ttf-devicons() {
+ install -d "${pkgdir}/usr/share/fonts/TTF"
+ install -m644 "${srcdir}/devicons-${pkgver}"/fonts/*.ttf "${pkgdir}/usr/share/fonts/TTF/"
+ install -D -m644 MIT "${pkgdir}/usr/share/licenses/${pkgname}/MIT"
+}