summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Crerar2017-11-09 08:26:14 -0500
committerAndrew Crerar2017-11-09 08:26:14 -0500
commit12ed35041d6bb202035c6d9df88d6a172906262b (patch)
tree53992e4f08717a59a579bb958e051cf1c94e95be
parent025d81fc0de7e73941be06c52a57a97029a63032 (diff)
downloadaur-12ed35041d6bb202035c6d9df88d6a172906262b.tar.gz
Adding official font packages as deps., removing repo fonts from install if satisifed by dep. package
-rw-r--r--.SRCINFO30
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD72
3 files changed, 60 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6a71d9b9a5b..452f5e64a158 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,25 @@
pkgbase = ttf-google-fonts-git
pkgdesc = TrueType fonts from the Google Fonts project (git version)
- pkgver = r1206.2e2caa23
- pkgrel = 2
+ pkgver = r1210.787dfb1f
+ pkgrel = 1
epoch = 1
url = https://github.com/google/fonts
arch = any
license = custom:SIL Open Font License
license = custom:Ubuntu Font License v1.0
makedepends = git
- depends = cantarell-fonts
depends = fontconfig
- depends = noto-fonts
- depends = xorg-fonts-encodings
depends = xorg-mkfontdir
depends = xorg-mkfontscale
+ depends = xorg-fonts-encodings
+ depends = noto-fonts
+ depends = noto-fonts-extra
+ depends = ttf-fira-sans
+ depends = ttf-fira-mono
+ depends = ttf-ubuntu-font-family
+ depends = ttf-croscore
+ depends = ttf-roboto
+ depends = ttf-inconsolata
provides = adobe-source-code-pro-fonts
provides = adobe-source-sans-pro-fonts
provides = jsmath-fonts
@@ -22,10 +28,6 @@ pkgbase = ttf-google-fonts-git
provides = ttf-anonymous-pro
provides = ttf-cardo
provides = ttf-comfortaa
- provides = ttf-croscore
- provides = ttf-fira-mono
- provides = ttf-fira-sans
- provides = ttf-inconsolata
provides = ttf-lato
provides = ttf-lora-cyrillic
provides = ttf-lekton
@@ -39,15 +41,12 @@ pkgbase = ttf-google-fonts-git
provides = ttf-oxygen-git
provides = ttf-pt-fonts
provides = ttf-quintessential
- provides = ttf-roboto
provides = ttf-roboto-mono
provides = ttf-signika
provides = ttf-sil-fonts
provides = ttf-source-code-pro-ibx
provides = ttf-source-sans-pro-ibx
- provides = ttf-ubuntu-font-family-ib
provides = ttf-vollkorn-ibx
- provides = ttf-ubuntu-font-family
conflicts = adobe-source-code-pro-fonts
conflicts = adobe-source-sans-pro-fonts
conflicts = jsmath-fonts
@@ -56,10 +55,6 @@ pkgbase = ttf-google-fonts-git
conflicts = ttf-anonymous-pro
conflicts = ttf-cardo
conflicts = ttf-comfortaa
- conflicts = ttf-croscore
- conflicts = ttf-fira-mono
- conflicts = ttf-fira-sans
- conflicts = ttf-inconsolata
conflicts = ttf-lato
conflicts = ttf-lora-cyrillic
conflicts = ttf-lekton
@@ -73,16 +68,13 @@ pkgbase = ttf-google-fonts-git
conflicts = ttf-oxygen-git
conflicts = ttf-pt-fonts
conflicts = ttf-quintessential
- conflicts = ttf-roboto
conflicts = ttf-roboto-mono
conflicts = ttf-signika
conflicts = ttf-sil-fonts
conflicts = ttf-source-code-pro-ibx
conflicts = ttf-source-sans-pro-ibx
- conflicts = ttf-ubuntu-font-family-ib
conflicts = ttf-vollkorn-ibx
conflicts = ttf-arabeyes-fonts
- conflicts = ttf-ubuntu-font-family
source = git+https://github.com/google/fonts.git
sha512sums = SKIP
diff --git a/.gitignore b/.gitignore
index e087cfeaffa3..f71c635dafda 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
*
!.gitignore
!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index c21256b7320f..4d371362ba2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,35 +9,41 @@
# Contributor: Alexander De Sousa <archaur.xandy21@spamgourmet.com>
pkgname=ttf-google-fonts-git
-pkgver=r1206.2e2caa23
-pkgrel=2
+pkgver=r1210.787dfb1f
+pkgrel=1
epoch=1
pkgdesc="TrueType fonts from the Google Fonts project (git version)"
arch=(any)
url="https://github.com/google/fonts"
license=('custom:SIL Open Font License' 'custom:Ubuntu Font License v1.0')
-# About why "cantarell-fonts" and "noto-fonts" is a dependency see comment in package() function.
-depends=(cantarell-fonts fontconfig noto-fonts xorg-fonts-encodings xorg-mkfontdir
- xorg-mkfontscale)
+depends=(fontconfig
+ xorg-mkfontdir
+ xorg-mkfontscale
+ xorg-fonts-encodings
+ noto-fonts
+ noto-fonts-extra
+ ttf-fira-sans
+ ttf-fira-mono
+ ttf-ubuntu-font-family
+ ttf-croscore
+ ttf-roboto
+ ttf-inconsolata)
makedepends=(git)
conflicts=(adobe-source-code-pro-fonts adobe-source-sans-pro-fonts jsmath-fonts
lohit-fonts ttf-andika ttf-anonymous-pro ttf-cardo ttf-comfortaa
- ttf-croscore ttf-fira-mono ttf-fira-sans ttf-inconsolata ttf-lato
+ ttf-lato
ttf-lora-cyrillic ttf-lekton ttf-medievalsharp ttf-merriweather
ttf-merriweather-sans ttf-nova ttf-opensans ttf-oswald ttf-oxygen
- ttf-oxygen-git ttf-pt-fonts ttf-quintessential ttf-roboto ttf-roboto-mono
- ttf-signika ttf-sil-fonts ttf-source-code-pro-ibx ttf-source-sans-pro-ibx
- ttf-ubuntu-font-family-ib ttf-vollkorn-ibx ttf-arabeyes-fonts
- ttf-ubuntu-font-family)
+ ttf-oxygen-git ttf-pt-fonts ttf-quintessential ttf-roboto-mono
+ ttf-signika ttf-sil-fonts ttf-source-code-pro-ibx ttf-source-sans-pro-ibx ttf-vollkorn-ibx ttf-arabeyes-fonts)
provides=(adobe-source-code-pro-fonts adobe-source-sans-pro-fonts jsmath-fonts
lohit-fonts ttf-andika ttf-anonymous-pro ttf-cardo ttf-comfortaa
- ttf-croscore ttf-fira-mono ttf-fira-sans ttf-inconsolata ttf-lato
+ ttf-lato
ttf-lora-cyrillic ttf-lekton ttf-medievalsharp ttf-merriweather
ttf-merriweather-sans ttf-nova ttf-opensans ttf-oswald ttf-oxygen
- ttf-oxygen-git ttf-pt-fonts ttf-quintessential ttf-roboto ttf-roboto-mono
- ttf-signika ttf-sil-fonts ttf-source-code-pro-ibx ttf-source-sans-pro-ibx
- ttf-ubuntu-font-family-ib ttf-vollkorn-ibx ttf-ubuntu-font-family)
+ ttf-oxygen-git ttf-pt-fonts ttf-quintessential ttf-roboto-mono
+ ttf-signika ttf-sil-fonts ttf-source-code-pro-ibx ttf-source-sans-pro-ibx ttf-vollkorn-ibx)
source=("git+${url}.git")
sha512sums=('SKIP')
@@ -51,15 +57,33 @@ package() {
install -dm755 "$pkgdir/usr/share/fonts/TTF"
find . -type f -name \*.[Tt][Tt][Ff] -exec install -Dm644 '{}' ${pkgdir}/usr/share/fonts/TTF \;
- # remove Cantarell fonts because Google ships the original Cantarell
- # instead of the improved version of Cantarell shipped by the GNOME Project
- #
- # it is safe to remove "Cantarell-*.ttf" from this dir because the
- # cantarell-fonts package installs its fonts into /usr/share/fonts/cantarell/
- # and because cantarell-fonts installs .otf files instead of .ttf files
- find ${pkgdir}/usr/share/fonts/TTF -type f -name "Cantarell-*.ttf" -delete
+ # [fonts/ofl/notosanstamil, fonts/ofl/notoserif] provided by extra/noto-fonts
+ find ${pkgdir}/usr/share/fonts/TTF -type f -name "NotoSansTamil-*.ttf" -delete
+ find ${pkgdir}/usr/share/fonts/TTF -type f -name "NotoSerif-*.ttf" -delete
+
+ # [fonts/ofl/notosans] provided by extra/noto-fonts-extra
+ find ${pkgdir}/usr/share/fonts/TTF -type f -name "NotoSans-*.ttf" -delete
+
+ # [fonts/ofl/firasans] provided by community/ttf-fira-sans
+ find ${pkgdir}/usr/share/fonts/TTF -type f -name "FiraSans-*.ttf" -delete
+
+ # [fonts/ofl/firamono] provided by community/ttf-fira-mono
+ find ${pkgdir}/usr/share/fonts/TTF -type f -name "FiraMono-*.ttf" -delete
+
+ # [fonts/ufl/ubuntu, fonts/ufl/ubuntumono] provided by community/ttf-ubuntu-font-family
+ find ${pkgdir}/usr/share/fonts/TTF -type f -name "Ubuntu-*.ttf" -delete
+ find ${pkgdir}/usr/share/fonts/TTF -type f -name "UbuntuMono-*.ttf" -delete
+
+ # [fonts/apache/tinos, fonts/apache/arimo, fonts/apache/cousine] provided by extra/ttf-croscore
+ find ${pkgdir}/usr/share/fonts/TTF -type f -name "Tinos-*.ttf" -delete
+ find ${pkgdir}/usr/share/fonts/TTF -type f -name "Arimo-*.ttf" -delete
+ find ${pkgdir}/usr/share/fonts/TTF -type f -name "Cousine-*.ttf" -delete
+
+ # [fonts/apache/roboto, fonts/apache/robotocondensed] provided by community/ttf-roboto
+ find ${pkgdir}/usr/share/fonts/TTF -type f -name "Roboto-*.ttf" -delete
+ find ${pkgdir}/usr/share/fonts/TTF -type f -name "RobotoCondensed-*.ttf" -delete
+
+ # [fonts/ofl/inconsolata] provided by community/ttf-inconsolata
+ find ${pkgdir}/usr/share/fonts/TTF -type f -name "Inconsolata-*.ttf" -delete
- # remove Noto fonts because noto-fonts package have more fonts than this package
- # and also noto-fonts install it's fonts in /usr/share/fonts/noto.
- find ${pkgdir}/usr/share/fonts/TTF -type f -name "Noto*.ttf" -delete
}