summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Crerar2019-10-09 04:50:11 +0200
committerAndrew Crerar2019-10-09 04:50:11 +0200
commit16651bfe25264be0ff0d20fde3e6657a9efaeb86 (patch)
tree0b5f228329bb02c344264d993836eca038637c3c
parentab8042526bcbec50ce0b18ef1279fccabe0d1b7b (diff)
downloadaur-16651bfe25264be0ff0d20fde3e6657a9efaeb86.tar.gz
Adding prepare block to address ongoing font issues
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 91cb29091047..50b22520dc81 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ttf-google-fonts-git
pkgdesc = TrueType fonts from the Google Fonts project (git version)
- pkgver = r1377.1ebe5dcf
+ pkgver = r1704.59afb78a
pkgrel = 1
epoch = 1
url = https://github.com/google/fonts
diff --git a/PKGBUILD b/PKGBUILD
index b25f31f65370..32e54af59dba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
# Contributor: Alexander De Sousa <archaur.xandy21@spamgourmet.com>
pkgname=ttf-google-fonts-git
-pkgver=r1377.1ebe5dcf
+pkgver=r1704.59afb78a
pkgrel=1
epoch=1
pkgdesc="TrueType fonts from the Google Fonts project (git version)"
@@ -90,6 +90,18 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd fonts
+
+ # NOTE: Remove VTT commit for Rubik as it caused some issues with display.
+ # See: https://github.com/google/fonts/issues/1137
+ git revert -n dfd435109b718b1c5a8da7bd0872c751e2ae1820
+
+ # NOTE: Adobe Blank is not meant to be installed.
+ # See: https://github.com/google/fonts/issues/2106#issuecomment-520067314
+ rm --recursive "${srcdir}/fonts/ofl/adobeblank"
+}
+
package() {
# NOTE: These are the font families that already exist in the [extra] and [community] repos.
declare -A omitted_font_families=([cantarell]=1 [noto-sans-tamil]=1 [noto-serif]=1
@@ -99,6 +111,7 @@ package() {
[inconsolata]=1 [merriweather]=1 [merriweather-sans]=1
[open-sans]=1 [oswald]=1 [quintessential]=1)
+
while IFS= read -rd '' file; do
font_family=$(fc-query -f '%{family[0]|downcase|translate( ,-)}\n' "$file" | sed -n '1p')
@@ -114,7 +127,6 @@ package() {
if [[ -f "$src_license_path" && ! -f "$pkg_font_license" ]]; then
install -Dm644 "$src_license_path" "$pkg_font_license"
fi
-
done < <(find "$srcdir" -type f -iname \*.ttf -print0)
# NOTE: Since the zcool xiaowei chinese font has special characters. We need to change